summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@alunduil.com>2014-08-11 09:00:16 -0500
committerAlex Brandt <alunduil@alunduil.com>2014-08-11 09:00:16 -0500
commit3965db9dffbc61a8fe03c46f900fdb9d0db90750 (patch)
treea7292899f12446bca13a1587ab08484fa9be1d02 /setup.py
parent22f897ed094a12cc205ac6f471bccc799be4907b (diff)
Exclude tests package from installation.
Installing the top-level tests package is asking for conflicts with other python packages and isn't required to run fig. This simply lets find_packages know to ignore tests and any sub-packages.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1c3c6536..1bf8db38 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ setup(
url='http://www.fig.sh/',
author='Docker, Inc.',
license='Apache License 2.0',
- packages=find_packages(),
+ packages=find_packages(exclude=[ 'tests.*', 'tests' ]),
include_package_data=True,
test_suite='nose.collector',
install_requires=install_requires,