summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAanand Prasad <aanand.prasad@gmail.com>2015-07-20 14:03:44 +0100
committerAanand Prasad <aanand.prasad@gmail.com>2015-07-20 14:13:25 +0100
commit4ba9d9dac2c661d6ed56ad0dfca71e64c4162b9c (patch)
tree38fc065b8ba16fd188f0093f65d5efaba450aef9 /setup.py
parent4ffae4a1acb2c0ec339ff82b56ec6ebb267908dd (diff)
Make parallel tasks interruptible with Ctrl-C
The concurrent.futures backport doesn't play well with KeyboardInterrupt, so I'm using Thread and Queue instead. Since thread pooling would likely be a pain to implement, I've just removed `COMPOSE_MAX_WORKERS` for now. We'll implement it later if we decide we need it. Signed-off-by: Aanand Prasad <aanand.prasad@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6ce7da44..d0ec1067 100644
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,6 @@ install_requires = [
'docker-py >= 1.3.0, < 1.4',
'dockerpty >= 0.3.4, < 0.4',
'six >= 1.3.0, < 2',
- 'futures >= 3.0.3',
]