summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBen Firshman <ben@firshman.co.uk>2013-12-20 21:35:00 +0000
committerBen Firshman <ben@firshman.co.uk>2013-12-20 21:35:00 +0000
commit8998bd1adc3def9e6e55b654b16415a46e1ca28b (patch)
tree5beb77c0212bc316f76767b8471b4a2129c97068 /setup.py
parent23d6ae867d0602b2e99172fe30df0ed4e17a5ca7 (diff)
Make setup.py actually work for release
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index fdffe020..aaf506ba 100644
--- a/setup.py
+++ b/setup.py
@@ -24,14 +24,18 @@ def find_version(*file_paths):
with open('requirements.txt') as f:
install_requires = f.read().splitlines()
+with open('README.md') as f:
+ long_description = f.read()
+
setup(
name='fig',
version=find_version("fig", "__init__.py"),
- description='',
+ description='Punctual, lightweight development environments using Docker',
+ long_description=long_description,
url='https://github.com/orchardup/fig',
author='Orchard Laboratories Ltd.',
author_email='hello@orchardup.com',
- packages=['fig'],
+ packages=['fig', 'fig.cli'],
package_data={},
include_package_data=True,
install_requires=install_requires,