summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorfunkyfuture <funkyfuture@riseup.net>2015-03-26 23:28:02 +0100
committerDaniel Nephin <dnephin@gmail.com>2015-08-25 10:41:09 -0400
commit9aa61e596e2475fa0bbcf227f2c388f6a9df471a (patch)
tree42c3a66c4d1ea17978712559073b43b9cc24481d /setup.py
parent809443d6d03e1ec687c01e546ddd9031b56ce40c (diff)
Run tests against Python 2.6, 2.7, 3.3, 3.4 and PyPy2
In particular it includes: - some extension of CONTRIBUTING.md - one fix for Python 2.6 in tests/integration/cli_test.py - one fix for Python 3.3 in tests/integration/service_test.py - removal of unused imports Make stream_output Python 3-compatible Signed-off-by: Frank Sachsenheim <funkyfuture@riseup.net>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b7fd4403..cdb5686c 100644
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,7 @@ tests_require = [
]
-if sys.version_info < (2, 6):
+if sys.version_info < (2, 7):
tests_require.append('unittest2')
if sys.version_info[:1] < (3,):
tests_require.append('pyinstaller')