summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--requirements-build.txt2
-rw-r--r--requirements.txt4
-rwxr-xr-xscript/build/linux-entrypoint7
-rw-r--r--setup.py2
4 files changed, 8 insertions, 7 deletions
diff --git a/requirements-build.txt b/requirements-build.txt
index 9161fadf..2a1cd7d6 100644
--- a/requirements-build.txt
+++ b/requirements-build.txt
@@ -1 +1 @@
-pyinstaller==3.4
+pyinstaller==3.5
diff --git a/requirements.txt b/requirements.txt
index e5b6883e..726b43b0 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -11,14 +11,14 @@ enum34==1.1.6; python_version < '3.4'
functools32==3.2.3.post2; python_version < '3.2'
idna==2.5
ipaddress==1.0.18
-jsonschema==2.6.0
+jsonschema==3.0.1
paramiko==2.4.2
pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
pypiwin32==223; sys_platform == 'win32' and python_version >= '3.6'
PySocks==1.6.7
PyYAML==4.2b1
requests==2.22.0
-six==1.10.0
+six==1.12.0
texttable==1.6.2
urllib3==1.24.2; python_version == '3.3'
websocket-client==0.32.0
diff --git a/script/build/linux-entrypoint b/script/build/linux-entrypoint
index 1c5438d8..d607dd5c 100755
--- a/script/build/linux-entrypoint
+++ b/script/build/linux-entrypoint
@@ -20,10 +20,11 @@ echo "${DOCKER_COMPOSE_GITSHA}" > compose/GITSHA
export PATH="${CODE_PATH}/pyinstaller:${PATH}"
if [ ! -z "${BUILD_BOOTLOADER}" ]; then
- # Build bootloader for alpine
- git clone --single-branch --branch master https://github.com/pyinstaller/pyinstaller.git /tmp/pyinstaller
+ # Build bootloader for alpine; develop is the main branch
+ git clone --single-branch --branch develop https://github.com/pyinstaller/pyinstaller.git /tmp/pyinstaller
cd /tmp/pyinstaller/bootloader
- git checkout v3.4
+ # Checkout commit corresponding to version in requirements-build
+ git checkout v3.5
"${VENV}"/bin/python3 ./waf configure --no-lsb all
"${VENV}"/bin/pip3 install ..
cd "${CODE_PATH}"
diff --git a/setup.py b/setup.py
index a4020df4..4b47c8bf 100644
--- a/setup.py
+++ b/setup.py
@@ -39,7 +39,7 @@ install_requires = [
'docker[ssh] >= 3.7.0, < 5',
'dockerpty >= 0.4.1, < 1',
'six >= 1.3.0, < 2',
- 'jsonschema >= 2.5.1, < 3',
+ 'jsonschema >= 2.5.1, < 4',
]