summaryrefslogtreecommitdiff
path: root/script/release
diff options
context:
space:
mode:
Diffstat (limited to 'script/release')
-rw-r--r--script/release/README.md4
-rwxr-xr-xscript/release/release.py4
2 files changed, 4 insertions, 4 deletions
diff --git a/script/release/README.md b/script/release/README.md
index f7f911e5..0c6f12cb 100644
--- a/script/release/README.md
+++ b/script/release/README.md
@@ -40,7 +40,7 @@ This API token should be exposed to the release script through the
### A Bintray account and Bintray API key
Your Bintray account will need to be an admin member of the
-[docker-compose organization](https://github.com/settings/tokens).
+[docker-compose organization](https://bintray.com/docker-compose).
Additionally, you should generate a personal API key. To do so, click your
username in the top-right hand corner and select "Edit profile" ; on the new
page, select "API key" in the left-side menu.
@@ -129,7 +129,7 @@ assets public), proceed to the "Finalize a release" section of this guide.
Once you're ready to make your release public, you may execute the following
command from the root of the Compose repository:
```
-./script/release/release.sh -b <BINTRAY_USERNAME> finalize RELEAE_VERSION
+./script/release/release.sh -b <BINTRAY_USERNAME> finalize RELEASE_VERSION
```
Note that this command will create and publish versioned assets to the public.
diff --git a/script/release/release.py b/script/release/release.py
index 63bf863d..9db1a49d 100755
--- a/script/release/release.py
+++ b/script/release/release.py
@@ -7,7 +7,6 @@ import os
import shutil
import sys
import time
-from distutils.core import run_setup
from jinja2 import Template
from release.bintray import BintrayAPI
@@ -276,7 +275,8 @@ def finalize(args):
repository.checkout_branch(br_name)
- run_setup(os.path.join(REPO_ROOT, 'setup.py'), script_args=['sdist', 'bdist_wheel'])
+ os.system('python {setup_script} sdist bdist_wheel'.format(
+ setup_script=os.path.join(REPO_ROOT, 'setup.py')))
merge_status = pr_data.merge()
if not merge_status.merged and not args.finalize_resume: