summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Changes3
-rw-r--r--README13
-rw-r--r--README.md15
-rw-r--r--share/templates/readme-md.tmpl30
-rw-r--r--share/templates/readme.tmpl26
-rw-r--r--t/data/ansicolor/output/readme13
-rw-r--r--t/data/ansicolor/output/readme-md15
7 files changed, 115 insertions, 0 deletions
diff --git a/Changes b/Changes
index fe659d5..319ccf8 100644
--- a/Changes
+++ b/Changes
@@ -6,6 +6,9 @@ DocKnot 1.01 (unreleased)
should be appended to the end of the stock license statement wherever
it is generated.
+ Add support for stock building and installation sections for Perl
+ module packages using either Module::Build or ExtUtils::MakeMaker.
+
DocKnot 1.00 (2016-10-26)
Initial public release. Supports generating text and Markdown README
diff --git a/README b/README
index 27a5557..12b69b8 100644
--- a/README
+++ b/README
@@ -81,6 +81,19 @@ REQUIREMENTS
many problems, set the environment variable AUTHOR_TESTING to a true
value.
+BUILDING AND INSTALLATION
+
+ DocKnot uses Module::Build and can be installed using the same process
+ as any other Module::Build module:
+
+ perl Build.PL
+ ./Build
+ ./Build test
+ ./Build install
+
+ You will have to run the last command as root unless you're installing
+ into a local Perl module tree in your home directory.
+
SUPPORT
The DocKnot web page at:
diff --git a/README.md b/README.md
index 52e2da5..d835c5b 100644
--- a/README.md
+++ b/README.md
@@ -79,6 +79,21 @@ environment or that produce a lot of false positives without uncovering
many problems, set the environment variable `AUTHOR_TESTING` to a true
value.
+## Building and Installation
+
+DocKnot uses Module::Build and can be installed using the same process as
+any other Module::Build module:
+
+```
+ perl Build.PL
+ ./Build
+ ./Build test
+ ./Build install
+```
+
+You will have to run the last command as root unless you're installing
+into a local Perl module tree in your home directory.
+
## Support
The [DocKnot web page](https://www.eyrie.org/~eagle/software/docknot/)
diff --git a/share/templates/readme-md.tmpl b/share/templates/readme-md.tmpl
index 6639512..c2e3685 100644
--- a/share/templates/readme-md.tmpl
+++ b/share/templates/readme-md.tmpl
@@ -31,6 +31,36 @@ configure.ac or any of the m4 files it includes and need to regenerate
configure or config.h.in, you will need Autoconf [% build.autoconf %] or
later.[% IF build.manpages %] Perl is also required to generate manual
pages from a fresh Git checkout.[% END %]
+[% END %][% IF build.type == 'Module::Build' %]
+## Building and Installation
+
+[% name %] uses Module::Build and can be installed using the same process
+as any other Module::Build module:
+
+```
+ perl Build.PL
+ ./Build
+ ./Build test
+ ./Build install
+```
+
+You will have to run the last command as root unless you're installing
+into a local Perl module tree in your home directory.
+[% ELSIF build.type == 'ExtUtils::MakeMaker' %]
+## Building and Installation
+
+[% name %] uses ExtUtils::MakeMaker and can be installed using the same
+process as any other ExtUtils::MakeMaker module:
+
+```
+ perl Makefile.PL
+ make
+ make test
+ make install
+```
+
+You'll probably need to do the last as root unless you're installing
+into a local Perl module tree in your home directory.
[% END %]
[% FOREACH section IN readme.sections %]## [% section.title %]
diff --git a/share/templates/readme.tmpl b/share/templates/readme.tmpl
index 3f4bf6a..ccb5109 100644
--- a/share/templates/readme.tmpl
+++ b/share/templates/readme.tmpl
@@ -34,6 +34,32 @@ REQUIREMENTS
configure or config.h.in, you will need Autoconf [% build.autoconf %] or
later.[% IF build.manpages %] Perl is also required to generate manual
pages from a fresh Git checkout.[% END %]
+[% END %][% IF build.type == 'Module::Build' %]
+BUILDING AND INSTALLATION
+
+ [% name %] uses Module::Build and can be installed using the same process
+ as any other Module::Build module:
+
+ perl Build.PL
+ ./Build
+ ./Build test
+ ./Build install
+
+ You will have to run the last command as root unless you're installing
+ into a local Perl module tree in your home directory.
+[% ELSIF build.type == 'ExtUtils::MakeMaker' %]
+BUILDING AND INSTALLATION
+
+ [% name %] uses ExtUtils::MakeMaker and can be installed using the same
+ process as any other ExtUtils::MakeMaker module:
+
+ perl Makefile.PL
+ make
+ make test
+ make install
+
+ You'll probably need to do the last as root unless you're installing
+ into a local Perl module tree in your home directory.
[% END %]
[% FOREACH section IN readme.sections %][% section.title FILTER upper %]
diff --git a/t/data/ansicolor/output/readme b/t/data/ansicolor/output/readme
index 29c2ca6..648f0c3 100644
--- a/t/data/ansicolor/output/readme
+++ b/t/data/ansicolor/output/readme
@@ -84,6 +84,19 @@ REQUIREMENTS
many problems, set the environment variable AUTHOR_TESTING to a true
value.
+BUILDING AND INSTALLATION
+
+ Term::ANSIColor uses ExtUtils::MakeMaker and can be installed using the
+ same process as any other ExtUtils::MakeMaker module:
+
+ perl Makefile.PL
+ make
+ make test
+ make install
+
+ You'll probably need to do the last as root unless you're installing
+ into a local Perl module tree in your home directory.
+
SUPPORT
The Term::ANSIColor web page at:
diff --git a/t/data/ansicolor/output/readme-md b/t/data/ansicolor/output/readme-md
index 474187d..3e495a8 100644
--- a/t/data/ansicolor/output/readme-md
+++ b/t/data/ansicolor/output/readme-md
@@ -81,6 +81,21 @@ environment or that produce a lot of false positives without uncovering
many problems, set the environment variable `AUTHOR_TESTING` to a true
value.
+## Building and Installation
+
+Term::ANSIColor uses ExtUtils::MakeMaker and can be installed using the
+same process as any other ExtUtils::MakeMaker module:
+
+```
+ perl Makefile.PL
+ make
+ make test
+ make install
+```
+
+You'll probably need to do the last as root unless you're installing into
+a local Perl module tree in your home directory.
+
## Support
The [Term::ANSIColor web