summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authoronqtam <vik.kirilov@gmail.com>2016-05-27 17:01:15 +0300
committeronqtam <vik.kirilov@gmail.com>2016-09-21 15:46:06 +0300
commit8126b563cb0864710cb7482cf109d2288227e092 (patch)
tree267da86ac05335e8c61c82ecf4471cbcd2bb2d74 /examples
parent2e66b6197590ff0d66dd84050258aa6882b42ef8 (diff)
fixed python scripts for wandbox link update and html doc generation
Diffstat (limited to 'examples')
-rw-r--r--examples/dll_and_executable/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/dll_and_executable/CMakeLists.txt b/examples/dll_and_executable/CMakeLists.txt
index c2c5bff..c728979 100644
--- a/examples/dll_and_executable/CMakeLists.txt
+++ b/examples/dll_and_executable/CMakeLists.txt
@@ -5,10 +5,12 @@ project(${PROJECT_NAME})
include(../../scripts/common.cmake)
-if(DEFINED ENV{TRAVIS} AND APPLE)
+if(APPLE)
set(CMAKE_MACOSX_RPATH ON)
- # force 64 bit for OSX because -m32 fails >>> SOMETIMES <<< (x86_64 vs 386 - like the dll is not linked with -m32...)
- add_compiler_flags(-m64)
+ if(DEFINED ENV{TRAVIS})
+ # force 64 bit for OSX because -m32 fails >>> SOMETIMES <<< (x86_64 vs 386 - like the dll is not linked with -m32...)
+ add_compiler_flags(-m64)
+ endif()
endif()
include_directories("../../doctest/")