summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authoronqtam <vik.kirilov@gmail.com>2016-08-03 13:07:00 +0300
committeronqtam <vik.kirilov@gmail.com>2016-09-21 15:46:12 +0300
commitfe740c2c1a31347ada50806053c537538701f0c4 (patch)
treeefe13c27c752b5e9872f4837904e31a8a1a9a751 /examples
parent15d2d9d03abd7e2be401f9575c2dfc33f8d261f5 (diff)
moved code coverage sources outside of examples
Diffstat (limited to 'examples')
-rw-r--r--examples/code_coverage/CMakeLists.txt37
-rw-r--r--examples/code_coverage/main.cpp64
-rw-r--r--examples/code_coverage/test.cpp52
-rw-r--r--examples/code_coverage/test_output/abort_after.txt29
-rw-r--r--examples/code_coverage/test_output/count.txt4
-rw-r--r--examples/code_coverage/test_output/filter_1.txt38
-rw-r--r--examples/code_coverage/test_output/filter_2.txt21
-rw-r--r--examples/code_coverage/test_output/filter_3.txt5
-rw-r--r--examples/code_coverage/test_output/filter_4.txt5
-rw-r--r--examples/code_coverage/test_output/filter_5.txt44
-rw-r--r--examples/code_coverage/test_output/filter_6.txt15
-rw-r--r--examples/code_coverage/test_output/first_last.txt54
-rw-r--r--examples/code_coverage/test_output/help.txt49
-rw-r--r--examples/code_coverage/test_output/list_test_cases.txt10
-rw-r--r--examples/code_coverage/test_output/list_test_suites.txt7
-rw-r--r--examples/code_coverage/test_output/order_1.txt54
-rw-r--r--examples/code_coverage/test_output/order_2.txt54
-rw-r--r--examples/code_coverage/test_output/order_3.txt5
-rw-r--r--examples/code_coverage/test_output/successful.txt72
-rw-r--r--examples/code_coverage/test_output/version.txt1
20 files changed, 0 insertions, 620 deletions
diff --git a/examples/code_coverage/CMakeLists.txt b/examples/code_coverage/CMakeLists.txt
deleted file mode 100644
index e6134de..0000000
--- a/examples/code_coverage/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-cmake_minimum_required(VERSION 2.8)
-
-get_filename_component(PROJECT_NAME ${CMAKE_CURRENT_SOURCE_DIR} NAME)
-project(${PROJECT_NAME})
-
-include(../../scripts/common.cmake)
-
-include_directories("../../doctest/")
-
-add_executable(${PROJECT_NAME} main.cpp test.cpp)
-
-if(DEFINED ENV{TRAVIS} AND APPLE AND CMAKE_CXX_COMPILER_ID MATCHES "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.5)
- # don't do tests for GCC 4.4 on OSX - the output will be different from the reference output
- # for some reason the summary after the tests run isn't printed... see this build - https://travis-ci.org/onqtam/doctest/jobs/135979391
- return()
-endif()
-
-# queries
-add_test(NAME help COMMAND $<TARGET_FILE:${PROJECT_NAME}> -dt-h)
-add_test(NAME version COMMAND $<TARGET_FILE:${PROJECT_NAME}> -v)
-add_test(NAME count COMMAND $<TARGET_FILE:${PROJECT_NAME}> -c)
-add_test(NAME list_test_cases COMMAND $<TARGET_FILE:${PROJECT_NAME}> -ltc)
-add_test(NAME list_test_suites COMMAND $<TARGET_FILE:${PROJECT_NAME}> -lts)
-
-# options
-add_test(NAME successful COMMAND $<TARGET_FILE:${PROJECT_NAME}> -s=true -e=Off -sfe=*main*) # exclude main because of RawMemoryToStr
-add_test(NAME abort_after COMMAND $<TARGET_FILE:${PROJECT_NAME}> -aa=3 -no-colors)
-add_test(NAME first_last COMMAND $<TARGET_FILE:${PROJECT_NAME}> -f=2 -l=5)
-add_test(NAME filter_1 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -tc=assert*********)
-add_test(NAME filter_2 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -tce=???ert*)
-add_test(NAME filter_3 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -sf=asgghdgsa)
-add_test(NAME filter_4 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -sfe=*test.cpp*)
-add_test(NAME filter_5 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -ts=ts1)
-add_test(NAME filter_6 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -tse=ts1)
-add_test(NAME order_1 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -ob=suite)
-add_test(NAME order_2 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -ob=name)
-add_test(NAME order_3 COMMAND $<TARGET_FILE:${PROJECT_NAME}> -ob=rand -rs=324 -sfe=*) # sfe=* to exclude all tests for no output
diff --git a/examples/code_coverage/main.cpp b/examples/code_coverage/main.cpp
deleted file mode 100644
index 1531c41..0000000
--- a/examples/code_coverage/main.cpp
+++ /dev/null
@@ -1,64 +0,0 @@
-#define DOCTEST_CONFIG_COLORS_NONE // the easy way to fix code coverage
-#define DOCTEST_CONFIG_IMPLEMENT
-#include "doctest.h"
-
-// intentionally here so there are subcases on the same lines in different files
-TEST_CASE("subcases") {
- SUBCASE("1") {
- SUBCASE("1.1") {}
- SUBCASE("1.2") {}
- SUBCASE("1.2") {}
- }
- // clang-format off
- SUBCASE("2") {} SUBCASE("3") {} // to have subcases on the same line with different names
- // clang-format on
-}
-
-using doctest::toString;
-
-#if __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ > 6)
-#pragma GCC diagnostic ignored "-Wzero-as-null-pointer-constant"
-#endif // > gcc 4.6
-
-TEST_CASE("doctest internals") {
- // string stuff
- doctest::String a(0);
- const doctest::String const_str("omgomgomg");
- a = const_str.c_str();
- CHECK(a.size() == const_str.size());
- CHECK(a.length() == const_str.length());
- CHECK(a.compare(const_str, true) == 0);
- CHECK(a.compare("omgomgomg", false) == 0);
-
- // toString
- a += toString("aaa") + toString(0.5f) + toString('c') + toString(true) +
- toString(static_cast<long double>(0.1)) //
- + toString(static_cast<unsigned char>(1)) //
- + toString(static_cast<short>(1)) //
- + toString(static_cast<long>(1)) //
- + toString(static_cast<unsigned long>(1)) //
- + toString(static_cast<unsigned short>(1));
-
- // others
- a += doctest::detail::fileForOutput("c:\\a");
- a += doctest::detail::fileForOutput("c:/a");
- a += doctest::detail::fileForOutput("a");
- CHECK(doctest::detail::rawMemoryToString(a).length() > 0u);
-}
-
-int main(int argc, char** argv) {
- doctest::Context context;
-
- context.addFilter("test-case-exclude", "*math*");
- context.setOption("no-breaks", true);
- context.setOption("sort", "name");
-
- context.applyCommandLine(argc, argv);
-
- int res = context.run();
-
- if(context.shouldExit())
- return res;
-
- return res;
-}
diff --git a/examples/code_coverage/test.cpp b/examples/code_coverage/test.cpp
deleted file mode 100644
index 79bad91..0000000
--- a/examples/code_coverage/test.cpp
+++ /dev/null
@@ -1,52 +0,0 @@
-#include "doctest.h"
-
-#include <ostream>
-
-// intentionally here so there are subcases on the same lines in different files
-TEST_CASE("subcases") {
- SUBCASE("1") {
- SUBCASE("1.1") {}
- SUBCASE("1.2") {}
- }
- SUBCASE("2") { CHECK(0); }
- SUBCASE("3") {}
-}
-
-TEST_SUITE("ts1");
-
-using doctest::Approx;
-
-static int throws(bool in) {
- if(in)
- throw false;
- return 42;
-}
-
-struct myType
-{};
-
-static std::ostream& operator<<(std::ostream& stream, const myType&) {
- stream << "myType!";
- return stream;
-}
-
-static bool operator==(const myType&, const myType&) { return false; }
-
-TEST_CASE("assertions") {
- CHECK(true);
- CHECK(1 == 0);
- CHECK_FALSE(1);
- CHECK(myType() == myType());
- CHECK(Approx(0.1) == 0.2);
-
- CHECK_THROWS(throws(true));
- CHECK_THROWS(throws(false));
- CHECK_NOTHROW(throws(false));
- CHECK_NOTHROW(throws(true));
- CHECK_THROWS_AS(throws(true), bool);
- REQUIRE_THROWS_AS(throws(false), bool);
-}
-
-TEST_CASE("throws") { throws(true); }
-
-TEST_SUITE_END();
diff --git a/examples/code_coverage/test_output/abort_after.txt b/examples/code_coverage/test_output/abort_after.txt
deleted file mode 100644
index 61e3d1a..0000000
--- a/examples/code_coverage/test_output/abort_after.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(6)
-subcases
- 2
-
-test.cpp(11) FAILED!
- CHECK( 0 )
-with expansion:
- CHECK( 0 )
-
-===============================================================================
-test.cpp(35)
-assertions
-
-test.cpp(37) FAILED!
- CHECK( 1 == 0 )
-with expansion:
- CHECK( 1 == 0 )
-
-test.cpp(38) FAILED!
- CHECK_FALSE( 1 )
-with expansion:
- CHECK_FALSE( 1 )
-
-===============================================================================
-[doctest] test cases: 4 | 2 passed | 2 failed | 1 skipped
-[doctest] assertions: 9 | 6 passed | 3 failed |
diff --git a/examples/code_coverage/test_output/count.txt b/examples/code_coverage/test_output/count.txt
deleted file mode 100644
index cae68e4..0000000
--- a/examples/code_coverage/test_output/count.txt
+++ /dev/null
@@ -1,4 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-[doctest] number of tests passing the current filters: 5
diff --git a/examples/code_coverage/test_output/filter_1.txt b/examples/code_coverage/test_output/filter_1.txt
deleted file mode 100644
index b2bcc0d..0000000
--- a/examples/code_coverage/test_output/filter_1.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(35)
-assertions
-
-test.cpp(37) FAILED!
- CHECK( 1 == 0 )
-with expansion:
- CHECK( 1 == 0 )
-
-test.cpp(38) FAILED!
- CHECK_FALSE( 1 )
-with expansion:
- CHECK_FALSE( 1 )
-
-test.cpp(39) FAILED!
- CHECK( myType() == myType() )
-with expansion:
- CHECK( myType! == myType! )
-
-test.cpp(40) FAILED!
- CHECK( Approx(0.1) == 0.2 )
-with expansion:
- CHECK( Approx( 0.1 ) == 0.2 )
-
-test.cpp(43) FAILED!
- CHECK_THROWS( throws(false) )
-
-test.cpp(45) FAILED!
- CHECK_NOTHROW( throws(true) )
-
-test.cpp(47) FAILED! (didn't throw at all)
- REQUIRE_THROWS_AS( throws(false), bool )
-
-===============================================================================
-[doctest] test cases: 1 | 0 passed | 1 failed | 4 skipped
-[doctest] assertions: 11 | 4 passed | 7 failed |
diff --git a/examples/code_coverage/test_output/filter_2.txt b/examples/code_coverage/test_output/filter_2.txt
deleted file mode 100644
index beb80d0..0000000
--- a/examples/code_coverage/test_output/filter_2.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(6)
-subcases
- 2
-
-test.cpp(11) FAILED!
- CHECK( 0 )
-with expansion:
- CHECK( 0 )
-
-===============================================================================
-test.cpp(50)
-throws
-
-TEST CASE FAILED! (threw exception)
-
-===============================================================================
-[doctest] test cases: 4 | 2 passed | 2 failed | 1 skipped
-[doctest] assertions: 6 | 5 passed | 1 failed |
diff --git a/examples/code_coverage/test_output/filter_3.txt b/examples/code_coverage/test_output/filter_3.txt
deleted file mode 100644
index f3798f8..0000000
--- a/examples/code_coverage/test_output/filter_3.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-[doctest] test cases: 0 | 0 passed | 0 failed | 5 skipped
-[doctest] assertions: 0 | 0 passed | 0 failed |
diff --git a/examples/code_coverage/test_output/filter_4.txt b/examples/code_coverage/test_output/filter_4.txt
deleted file mode 100644
index f94c9c5..0000000
--- a/examples/code_coverage/test_output/filter_4.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-[doctest] test cases: 2 | 2 passed | 0 failed | 3 skipped
-[doctest] assertions: 5 | 5 passed | 0 failed |
diff --git a/examples/code_coverage/test_output/filter_5.txt b/examples/code_coverage/test_output/filter_5.txt
deleted file mode 100644
index b5626d8..0000000
--- a/examples/code_coverage/test_output/filter_5.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(35)
-assertions
-
-test.cpp(37) FAILED!
- CHECK( 1 == 0 )
-with expansion:
- CHECK( 1 == 0 )
-
-test.cpp(38) FAILED!
- CHECK_FALSE( 1 )
-with expansion:
- CHECK_FALSE( 1 )
-
-test.cpp(39) FAILED!
- CHECK( myType() == myType() )
-with expansion:
- CHECK( myType! == myType! )
-
-test.cpp(40) FAILED!
- CHECK( Approx(0.1) == 0.2 )
-with expansion:
- CHECK( Approx( 0.1 ) == 0.2 )
-
-test.cpp(43) FAILED!
- CHECK_THROWS( throws(false) )
-
-test.cpp(45) FAILED!
- CHECK_NOTHROW( throws(true) )
-
-test.cpp(47) FAILED! (didn't throw at all)
- REQUIRE_THROWS_AS( throws(false), bool )
-
-===============================================================================
-test.cpp(50)
-throws
-
-TEST CASE FAILED! (threw exception)
-
-===============================================================================
-[doctest] test cases: 2 | 0 passed | 2 failed | 3 skipped
-[doctest] assertions: 11 | 4 passed | 7 failed |
diff --git a/examples/code_coverage/test_output/filter_6.txt b/examples/code_coverage/test_output/filter_6.txt
deleted file mode 100644
index 5660a82..0000000
--- a/examples/code_coverage/test_output/filter_6.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(6)
-subcases
- 2
-
-test.cpp(11) FAILED!
- CHECK( 0 )
-with expansion:
- CHECK( 0 )
-
-===============================================================================
-[doctest] test cases: 3 | 2 passed | 1 failed | 2 skipped
-[doctest] assertions: 6 | 5 passed | 1 failed |
diff --git a/examples/code_coverage/test_output/first_last.txt b/examples/code_coverage/test_output/first_last.txt
deleted file mode 100644
index 8e48b7a..0000000
--- a/examples/code_coverage/test_output/first_last.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(6)
-subcases
- 2
-
-test.cpp(11) FAILED!
- CHECK( 0 )
-with expansion:
- CHECK( 0 )
-
-===============================================================================
-test.cpp(35)
-assertions
-
-test.cpp(37) FAILED!
- CHECK( 1 == 0 )
-with expansion:
- CHECK( 1 == 0 )
-
-test.cpp(38) FAILED!
- CHECK_FALSE( 1 )
-with expansion:
- CHECK_FALSE( 1 )
-
-test.cpp(39) FAILED!
- CHECK( myType() == myType() )
-with expansion:
- CHECK( myType! == myType! )
-
-test.cpp(40) FAILED!
- CHECK( Approx(0.1) == 0.2 )
-with expansion:
- CHECK( Approx( 0.1 ) == 0.2 )
-
-test.cpp(43) FAILED!
- CHECK_THROWS( throws(false) )
-
-test.cpp(45) FAILED!
- CHECK_NOTHROW( throws(true) )
-
-test.cpp(47) FAILED! (didn't throw at all)
- REQUIRE_THROWS_AS( throws(false), bool )
-
-===============================================================================
-test.cpp(50)
-throws
-
-TEST CASE FAILED! (threw exception)
-
-===============================================================================
-[doctest] test cases: 5 | 2 passed | 3 failed | 0 skipped
-[doctest] assertions: 17 | 9 passed | 8 failed |
diff --git a/examples/code_coverage/test_output/help.txt b/examples/code_coverage/test_output/help.txt
deleted file mode 100644
index f3ac38d..0000000
--- a/examples/code_coverage/test_output/help.txt
+++ /dev/null
@@ -1,49 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest]
-[doctest] boolean values: "1/on/yes/true" or "0/off/no/false"
-[doctest] filter values: "str1,str2,str3" (comma separated strings)
-[doctest]
-[doctest] filters use wildcards for matching strings
-[doctest] something passes a filter if any of the strings in a filter matches
-[doctest]
-[doctest] ALL FLAGS, OPTIONS AND FILTERS ALSO AVAILABLE WITH A "dt-" PREFIX!!!
-[doctest]
-[doctest] Query flags - the program quits after them. Available:
-
- -?, --help, -h prints this message
- -v, --version prints the version
- -c, --count prints the number of matching tests
- -ltc, --list-test-cases lists all matching tests by name
- -lts, --list-test-suites lists all matching test suites
-
-[doctest] The available <int>/<string> options/filters are:
-
- -tc, --test-case=<filters> filters tests by their name
- -tce, --test-case-exclude=<filters> filters OUT tests by their name
- -sf, --source-file=<filters> filters tests by their file
- -sfe, --source-file-exclude=<filters> filters OUT tests by their file
- -ts, --test-suite=<filters> filters tests by their test suite
- -tse, --test-suite-exclude=<filters> filters OUT tests by their test suite
- -ob, --order-by=<string> how the tests should be ordered
- <string> - by [file/suite/name/rand]
- -rs, --rand-seed=<int> seed for random ordering
- -f, --first=<int> the first test passing the filters to
- execute - for range-based execution
- -l, --last=<int> the last test passing the filters to
- execute - for range-based execution
- -aa, --abort-after=<int> stop after <int> failed assertions
-
-[doctest] Bool options - can be used like flags and true is assumed. Available:
-
- -s, --success=<bool> include successful assertions in output
- -cs, --case-sensitive=<bool> filters being treated as case sensitive
- -e, --exit=<bool> exits after the tests finish
- -nt, --no-throw=<bool> skips exceptions-related assert checks
- -ne, --no-exitcode=<bool> returns (or exits) always with success
- -nr, --no-run=<bool> skips all runtime doctest operations
- -nc, --no-colors=<bool> disables colors in output
- -nb, --no-breaks=<bool> disables breakpoints in debuggers
- -npf, --no-path-filenames=<bool> only filenames and no paths in output
-
-[doctest] for more information visit the project documentation
-
diff --git a/examples/code_coverage/test_output/list_test_cases.txt b/examples/code_coverage/test_output/list_test_cases.txt
deleted file mode 100644
index 669f109..0000000
--- a/examples/code_coverage/test_output/list_test_cases.txt
+++ /dev/null
@@ -1,10 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-[doctest] listing all test case names
-subcases
-doctest internals
-subcases
-assertions
-throws
-===============================================================================
-[doctest] number of tests passing the current filters: 5
diff --git a/examples/code_coverage/test_output/list_test_suites.txt b/examples/code_coverage/test_output/list_test_suites.txt
deleted file mode 100644
index cc09fe4..0000000
--- a/examples/code_coverage/test_output/list_test_suites.txt
+++ /dev/null
@@ -1,7 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-[doctest] listing all test suites
-
-ts1
-===============================================================================
-[doctest] number of tests passing the current filters: 5
diff --git a/examples/code_coverage/test_output/order_1.txt b/examples/code_coverage/test_output/order_1.txt
deleted file mode 100644
index 8e48b7a..0000000
--- a/examples/code_coverage/test_output/order_1.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(6)
-subcases
- 2
-
-test.cpp(11) FAILED!
- CHECK( 0 )
-with expansion:
- CHECK( 0 )
-
-===============================================================================
-test.cpp(35)
-assertions
-
-test.cpp(37) FAILED!
- CHECK( 1 == 0 )
-with expansion:
- CHECK( 1 == 0 )
-
-test.cpp(38) FAILED!
- CHECK_FALSE( 1 )
-with expansion:
- CHECK_FALSE( 1 )
-
-test.cpp(39) FAILED!
- CHECK( myType() == myType() )
-with expansion:
- CHECK( myType! == myType! )
-
-test.cpp(40) FAILED!
- CHECK( Approx(0.1) == 0.2 )
-with expansion:
- CHECK( Approx( 0.1 ) == 0.2 )
-
-test.cpp(43) FAILED!
- CHECK_THROWS( throws(false) )
-
-test.cpp(45) FAILED!
- CHECK_NOTHROW( throws(true) )
-
-test.cpp(47) FAILED! (didn't throw at all)
- REQUIRE_THROWS_AS( throws(false), bool )
-
-===============================================================================
-test.cpp(50)
-throws
-
-TEST CASE FAILED! (threw exception)
-
-===============================================================================
-[doctest] test cases: 5 | 2 passed | 3 failed | 0 skipped
-[doctest] assertions: 17 | 9 passed | 8 failed |
diff --git a/examples/code_coverage/test_output/order_2.txt b/examples/code_coverage/test_output/order_2.txt
deleted file mode 100644
index 240a549..0000000
--- a/examples/code_coverage/test_output/order_2.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(35)
-assertions
-
-test.cpp(37) FAILED!
- CHECK( 1 == 0 )
-with expansion:
- CHECK( 1 == 0 )
-
-test.cpp(38) FAILED!
- CHECK_FALSE( 1 )
-with expansion:
- CHECK_FALSE( 1 )
-
-test.cpp(39) FAILED!
- CHECK( myType() == myType() )
-with expansion:
- CHECK( myType! == myType! )
-
-test.cpp(40) FAILED!
- CHECK( Approx(0.1) == 0.2 )
-with expansion:
- CHECK( Approx( 0.1 ) == 0.2 )
-
-test.cpp(43) FAILED!
- CHECK_THROWS( throws(false) )
-
-test.cpp(45) FAILED!
- CHECK_NOTHROW( throws(true) )
-
-test.cpp(47) FAILED! (didn't throw at all)
- REQUIRE_THROWS_AS( throws(false), bool )
-
-===============================================================================
-test.cpp(6)
-subcases
- 2
-
-test.cpp(11) FAILED!
- CHECK( 0 )
-with expansion:
- CHECK( 0 )
-
-===============================================================================
-test.cpp(50)
-throws
-
-TEST CASE FAILED! (threw exception)
-
-===============================================================================
-[doctest] test cases: 5 | 2 passed | 3 failed | 0 skipped
-[doctest] assertions: 17 | 9 passed | 8 failed |
diff --git a/examples/code_coverage/test_output/order_3.txt b/examples/code_coverage/test_output/order_3.txt
deleted file mode 100644
index f3798f8..0000000
--- a/examples/code_coverage/test_output/order_3.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-[doctest] test cases: 0 | 0 passed | 0 failed | 5 skipped
-[doctest] assertions: 0 | 0 passed | 0 failed |
diff --git a/examples/code_coverage/test_output/successful.txt b/examples/code_coverage/test_output/successful.txt
deleted file mode 100644
index 73d487d..0000000
--- a/examples/code_coverage/test_output/successful.txt
+++ /dev/null
@@ -1,72 +0,0 @@
-[doctest] doctest version is "1.0.0"
-[doctest] run with "--help" for options
-===============================================================================
-test.cpp(6)
-subcases
-
-===============================================================================
-test.cpp(6)
-subcases
- 2
-
-test.cpp(11) FAILED!
- CHECK( 0 )
-with expansion:
- CHECK( 0 )
-
-===============================================================================
-test.cpp(35)
-assertions
-
-test.cpp(36) PASSED!
- CHECK( true )
-with expansion:
- CHECK( true )
-
-test.cpp(37) FAILED!
- CHECK( 1 == 0 )
-with expansion:
- CHECK( 1 == 0 )
-
-test.cpp(38) FAILED!
- CHECK_FALSE( 1 )
-with expansion:
- CHECK_FALSE( 1 )
-
-test.cpp(39) FAILED!
- CHECK( myType() == myType() )
-with expansion:
- CHECK( myType! == myType! )
-
-test.cpp(40) FAILED!
- CHECK( Approx(0.1) == 0.2 )
-with expansion:
- CHECK( Approx( 0.1 ) == 0.2 )
-
-test.cpp(42) PASSED!
- CHECK_THROWS( throws(true) )
-
-test.cpp(43) FAILED!
- CHECK_THROWS( throws(false) )
-
-test.cpp(44) PASSED!
- CHECK_NOTHROW( throws(false) )
-
-test.cpp(45) FAILED!
- CHECK_NOTHROW( throws(true) )
-
-test.cpp(46) PASSED!
- CHECK_THROWS_AS( throws(true), bool )
-
-test.cpp(47) FAILED! (didn't throw at all)
- REQUIRE_THROWS_AS( throws(false), bool )
-
-===============================================================================
-test.cpp(50)
-throws
-
-TEST CASE FAILED! (threw exception)
-
-===============================================================================
-[doctest] test cases: 3 | 0 passed | 3 failed | 2 skipped
-[doctest] assertions: 12 | 4 passed | 8 failed |
diff --git a/examples/code_coverage/test_output/version.txt b/examples/code_coverage/test_output/version.txt
deleted file mode 100644
index cbb0b44..0000000
--- a/examples/code_coverage/test_output/version.txt
+++ /dev/null
@@ -1 +0,0 @@
-[doctest] doctest version is "1.0.0"