summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeng-Yu Lin <kengyu@lexical.tw>2019-01-31 16:12:44 +0100
committerKeng-Yu Lin <kengyu@lexical.tw>2019-01-31 16:12:44 +0100
commit0c8106fe5f9499561450406ff9e90c57e9b85e35 (patch)
tree3e93a46de0a2463717aba0b27b4a2baf8bbf6735
parent9d1420b3f548b11f21fde3cd8595f1796d823b68 (diff)
configure.ac_use_PIC
Gbp-Pq: Name 0001-configure.ac_use_PIC.patch
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fb3c4da..87ac45a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -417,7 +417,7 @@ if test x$use_hardening != xno; then
if test x$TARGET_OS != xwindows; then
# All windows code is PIC, forcing it on just adds useless compile warnings
- AX_CHECK_COMPILE_FLAG([-fPIE],[HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fPIE"])
+ AX_CHECK_COMPILE_FLAG([-fPIC],[HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fPIC"])
AX_CHECK_LINK_FLAG([[-pie]], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -pie"])
fi