summaryrefslogtreecommitdiff
path: root/debian-changelog-mode.el
diff options
context:
space:
mode:
authorpsg <>2010-04-28 21:20:07 +0000
committerpsg <>2010-04-28 21:20:07 +0000
commit1c16438af690299706ab3e331291e1305d1d4e3a (patch)
treecb972e593cc6acab2470856efa3b0b97ba15063f /debian-changelog-mode.el
parentbbe1f35ec60f7690cc6ed0b80cc601b941b1c0e9 (diff)
debian-changelog-mode.el: Invoke `debian-bug-build-bug-menu' with SOURCE
arg set to t. Needs debian-el 33.2 debian-bug.el: `debian-bug-build-bug-menu' now takes optional SOURCE argument. Fixes "Empty bug list", thanks to Remi Vanicat (Closes: #579394).
Diffstat (limited to 'debian-changelog-mode.el')
-rw-r--r--debian-changelog-mode.el11
1 files changed, 7 insertions, 4 deletions
diff --git a/debian-changelog-mode.el b/debian-changelog-mode.el
index 1228433..10d9e66 100644
--- a/debian-changelog-mode.el
+++ b/debian-changelog-mode.el
@@ -4,7 +4,7 @@
;; Copyright (C) 1997 Klee Dienes
;; Copyright (C) 1999 Chris Waters
;; Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005 Peter S Galbraith
-;; Copyright (C) 2006, 2007, Peter S Galbraith
+;; Copyright (C) 2006, 2007, 2009, 2010 Peter S Galbraith
;;
;; This file is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
@@ -18,8 +18,8 @@
;;
;; You should have received a copy of the GNU General Public License
;; along with your Debian installation, in /usr/share/common-licenses/GPL
-;; If not, write to the Free Software Foundation, 675 Mass Ave,
-;; Cambridge, MA 02139, USA.
+;; If not, write to the Free Software Foundation, 51 Franklin Street,
+;; Suite 500 Boston, MA 02110-1335, USA
;;; Commentary:
;;
@@ -338,6 +338,9 @@
;; debian-chagelog--rris are in the wrong order. Closes: #476271
;; V1.91 12Nov2009 Peter S Galbraith <psg@debian.org>
;; Updated URL for "Best practices".
+;; V1.92 27Apr2010 Peter S Galbraith <psg@debian.org>
+;; Invoke `debian-bug-build-bug-menu' with SOURCE arg set to t.
+;; Needs debian-el 33.2
;;
;;; Acknowledgements: (These people have contributed)
;; Roland Rosenfeld <roland@debian.org>
@@ -838,7 +841,7 @@ for the debian/changelog file to add the entry to."
(defun debian-changelog-build-open-bug-list ()
"Generate open bugs list, i.e. `debian-bug-open-alist'."
(interactive)
- (debian-bug-build-bug-menu (debian-changelog-suggest-package-name)))
+ (debian-bug-build-bug-menu (debian-changelog-suggest-package-name) t))
(defun debian-changelog-close-bug (bug-number)
"Add a new change entry to close a BUG-NUMBER."