summaryrefslogtreecommitdiff
path: root/debian-changelog-mode.el
diff options
context:
space:
mode:
authorpsg <>2007-08-08 22:35:16 +0000
committerpsg <>2007-08-08 22:35:16 +0000
commitea215acac350ff3f15c0cee1f5734e517e8a0afa (patch)
treeeb9745b2fc101242cec5c0ad5e8d1590fe27a1c2 /debian-changelog-mode.el
parent5e96342cc83331d9866614897c60e2a371a4e779 (diff)
debian-changelog-model.el:
auto-mode-alist for "/debian/*NEWS" files, thanks to Per Olofsson (Closes: #424779).
Diffstat (limited to 'debian-changelog-mode.el')
-rw-r--r--debian-changelog-mode.el4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian-changelog-mode.el b/debian-changelog-mode.el
index fc79664..1b47ec7 100644
--- a/debian-changelog-mode.el
+++ b/debian-changelog-mode.el
@@ -319,6 +319,8 @@
;; - Tighter regexp for finalisation string
;; V1.85 25Jul2007 Peter S Galbraith <psg@debian.org>
;; - Adapt patch from Luca Capello <luca@pca.it> for bug #431091
+;; V1.86 08Aug2007 Peter S Galbraith <psg@debian.org>
+;; - auto-mode-alist for "/debian/*NEWS" files (Closes: #424779)
;;; Acknowledgements: (These people have contributed)
;; Roland Rosenfeld <roland@debian.org>
@@ -1722,6 +1724,7 @@ Also set keymap."
;;; Setup auto-mode-alist
;; (in case /etc/emacs/site-start.d/50dpkg-dev.el not used)
+(add-to-list 'auto-mode-alist '("/debian/*NEWS" . debian-changelog-mode))
(add-to-list 'auto-mode-alist '("NEWS.Debian" . debian-changelog-mode))
(add-to-list 'auto-mode-alist '("NEWS.Debian.gz" . debian-changelog-mode))
(add-to-list 'auto-mode-alist
@@ -1731,6 +1734,7 @@ Also set keymap."
;; For debchange
(add-to-list 'auto-mode-alist '("changelog.dch" . debian-changelog-mode))
+;;;###autoload(add-to-list 'auto-mode-alist '("/debian/*NEWS" . debian-changelog-mode))
;;;###autoload(add-to-list 'auto-mode-alist '("NEWS.Debian" . debian-changelog-mode))
;;;###autoload(add-to-list 'auto-mode-alist '("NEWS.Debian.gz" . debian-changelog-mode))
;;;###autoload(add-to-list 'auto-mode-alist '("/debian/changelog\\'" . debian-changelog-mode))