summaryrefslogtreecommitdiff
path: root/debian/patches/auto-0.4b44-5-8544ff70a0b617566795d1e0c611e5e9d98c66a4-1411987963
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/auto-0.4b44-5-8544ff70a0b617566795d1e0c611e5e9d98c66a4-1411987963')
-rw-r--r--debian/patches/auto-0.4b44-5-8544ff70a0b617566795d1e0c611e5e9d98c66a4-141198796359
1 files changed, 59 insertions, 0 deletions
diff --git a/debian/patches/auto-0.4b44-5-8544ff70a0b617566795d1e0c611e5e9d98c66a4-1411987963 b/debian/patches/auto-0.4b44-5-8544ff70a0b617566795d1e0c611e5e9d98c66a4-1411987963
new file mode 100644
index 0000000..e3b78d7
--- /dev/null
+++ b/debian/patches/auto-0.4b44-5-8544ff70a0b617566795d1e0c611e5e9d98c66a4-1411987963
@@ -0,0 +1,59 @@
+Description: Automatically generated patch (0.4b44-5)
+ Last (up to) 3 git changes, FYI:
+ .
+ commit 8544ff70a0b617566795d1e0c611e5e9d98c66a4
+ Author: Matthew Vernon <mcv21@cam.ac.uk>
+ Date: Mon Sep 29 11:37:04 2014 +0100
+ .
+ Changelog for 0.4b44-5
+ .
+ commit 7da8aa42b8905f2f2c8644dfc148e07570a14a56
+ Author: Matthew Vernon <mcv21@cam.ac.uk>
+ Date: Mon Sep 29 11:33:54 2014 +0100
+ .
+ Patch from Ben Harris to skip directories already scheduled for deletion
+ .
+ The patch assumes that if an entry has e_ino == 0, that means it's
+ already been passed to deletino() and added to removelist. I think
+ this is true. It's certainly the case that all additions to removelist
+ have e_ino == 0, so this should stop the hangs and the panics from
+ removino(). At worst, it will leave spurious directories around after
+ a restore.
+ .
+ commit 870ae1e4acd826d692cf2c547c27ee44f9ca2eab
+ Author: Mattia Rizzolo <mattia@mapreri.org>
+ Date: Thu Sep 19 14:51:33 2013 +0100
+ .
+ dump (0.4b44-4) unstable; urgency=low
+ .
+ * QA upload.
+ * debian/postinst: drop --verbose flag from update-alternatives invocation.
+ * debian/*rm: add set -e to fix lintian warning.
+ * debian/control:
+ + add Homepage field.
+ + Update VCS fields to canonical values.
+ + Bump Standards-Version to 3.9.4. No changes required.
+ * Update to debhelper 9:
+ + debian/rules: update accordingly.
+ + debian/compat: bump compatibility level to 9.
+ + debian/control: bump debhelper versioned build-dep to >= 9.
+ + debian/docs: include docs previously manually installed.
+ + debian/examples: include previously-included examples.
+ * debian/copyright: update to DEP-5.
+ .
+ # imported from the archive
+Author: Matthew Vernon <matthew@debian.org>
+
+---
+
+--- dump-0.4b44.orig/restore/restore.c
++++ dump-0.4b44/restore/restore.c
+@@ -593,7 +593,7 @@ findunreflinks(void)
+ if (np->e_type == LEAF) {
+ removeleaf(np);
+ freeentry(np);
+- } else {
++ } else if (np->e_ino != 0){
+ np->e_flags |= TMPNAME;
+ deleteino(np->e_ino);
+ np->e_next = removelist;