summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDongyang Li <dongyangli@ddn.com>2019-03-06 22:59:55 +0000
committerTheodore Ts'o <tytso@mit.edu>2019-03-07 16:09:20 -0500
commitf72ea2deb0d8c455044eb5ab773829e5deb96f41 (patch)
tree7c59c1e584f54f555ab98dbb63e13547c043fe2d /configure.ac
parenta92fbdd9a629b32af1bc0b63e4a54f78f683fa82 (diff)
Fix autoheader warnings
autoheader complains after 1.44.6 release: autoheader: warning: missing template: HAVE_BLKID_PROBE_ENABLE_PARTITIONS autoheader: Use AC_DEFINE([HAVE_BLKID_PROBE_ENABLE_PARTITIONS], [], [Description]) autoheader: warning: missing template: HAVE_BLKID_PROBE_GET_TOPOLOGY This could fail automatic rpm builds. Fixes: 7154d97 ("Check for the newer blkid functions without adding blkid to @LIBS@") Signed-off-by: Li Dongyang <dongyangli@ddn.com> Signed-off-by: Theodore Ts'o <tytso@mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0de90573..04e19944 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1118,9 +1118,11 @@ dnl the functions added after migrating that library to util-linux
dnl
if test -n "$BLKID_CMT"; then
AC_CHECK_LIB(blkid, blkid_probe_get_topology,
- AC_DEFINE(HAVE_BLKID_PROBE_GET_TOPOLOGY, 1))
+ AC_DEFINE(HAVE_BLKID_PROBE_GET_TOPOLOGY, 1,
+ [Define to 1 if blkid has blkid_probe_get_topology]))
AC_CHECK_LIB(blkid, blkid_probe_enable_partitions,
- AC_DEFINE(HAVE_BLKID_PROBE_ENABLE_PARTITIONS, 1))
+ AC_DEFINE(HAVE_BLKID_PROBE_ENABLE_PARTITIONS, 1,
+ [Define to 1 if blkid has blkid_probe_enable_partitions]))
fi
dnl
if test -n "$DLOPEN_LIB" ; then