summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Więcek <coven@debian.org>2006-04-21 23:14:02 +0200
committerDmitry Bogatov <KAction@debian.org>2019-01-13 16:51:09 +0000
commit4e3d121e1876b832ed1c4e3d8e3d0dfa7053a375 (patch)
treeebeaf7b32abe2ff02ead2c0c5e360bf1f51c8fb7
parentad22f42ef0f1e7e9ebf65fefb032a6b91f547b70 (diff)
Import Debian changes 1:2.70-2
e3 (1:2.70-2) unstable; urgency=low * Added support for calling as 'ws', 'emacs', 'pico', 'vi' or 'nedit' (closes: #345173) * Added kfreebsd-amd64 to arch list (closes: #361628)
-rw-r--r--debian/changelog8
-rw-r--r--debian/control6
-rw-r--r--e3.asm26
3 files changed, 37 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 5fa1695..e67fcfc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+e3 (1:2.70-2) unstable; urgency=low
+
+ * Added support for calling as 'ws', 'emacs', 'pico', 'vi' or 'nedit'
+ (closes: #345173)
+ * Added kfreebsd-amd64 to arch list (closes: #361628)
+
+ -- Paweł Więcek <coven@debian.org> Fri, 21 Apr 2006 23:14:02 +0200
+
e3 (1:2.70-1) unstable; urgency=low
* New upstream version
diff --git a/debian/control b/debian/control
index 4aba7cb..7052e7f 100644
--- a/debian/control
+++ b/debian/control
@@ -1,12 +1,12 @@
Source: e3
Section: editors
Priority: optional
-Maintainer: Pawel Wiecek <coven@debian.org>
-Build-Depends: debhelper (>> 4.0.0), nasm, upx-ucl
+Maintainer: Paweł Więcek <coven@debian.org>
+Build-Depends: debhelper (>= 4.0.0), nasm, upx-ucl
Standards-Version: 3.6.2
Package: e3
-Architecture: i386 kfreebsd-i386 amd64
+Architecture: i386 kfreebsd-i386 amd64 kfreebsd-amd64
Depends: ${shlibs:Depends}
Description: A very small editor
This package contains an editor you can call via the following links:
diff --git a/e3.asm b/e3.asm
index 06887cf..efa79bc 100644
--- a/e3.asm
+++ b/e3.asm
@@ -3663,6 +3663,32 @@ NoPi: cmp ecx,'e3vi'
mov byte [eax],VI
ret
NoVi: cmp ecx,'e3ws'
+ jnz NoWs
+ mov byte [eax],WS
+ ret
+NoWs: cmp ecx,'edit'
+ jnz NoNe2
+ mov byte [eax],NE
+ ret
+NoNe2: cmp ecx,'macs'
+ jnz NoEm2
+ mov byte [eax],EM
+ ret
+NoEm2: cmp ecx,'pico'
+ jnz NoPi2
+ mov byte [eax],PI
+ ret
+NoPi2: push cx
+ mov cx,'__'
+ cmp ecx,'__vi'
+ pop cx
+ jnz NoVi2
+ mov byte [eax],VI
+ ret
+NoVi2: push cx
+ mov cx,'__'
+ cmp ecx,'__ws'
+ pop cx
jnz modeOK
mov byte [eax],WS
modeOK: ret