summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Schubert <erich@debian.org>2018-08-22 01:19:02 +0200
committerAndrej Shadura <andrewsh@debian.org>2019-03-09 22:30:53 +0000
commitce5b295d9af8654de836d227ef73dd4d064f7c50 (patch)
tree90ccd82e95cad5db10c62a4d04de9734ff08a047
parent03818a8bcc3e128b7db2af8687f8bad2bd8c5687 (diff)
Import Debian changes 0.7.1-9
elki (0.7.1-9) unstable; urgency=low * Try making the build reproducible by enforcing a sort order in auto-generated documentation (also upstream in next release).
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/reproducible-builds.patch32
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules5
4 files changed, 41 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index c28387ec..c4154cec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+elki (0.7.1-9) unstable; urgency=low
+
+ * Try making the build reproducible by enforcing a sort order in
+ auto-generated documentation (also upstream in next release).
+
+ -- Erich Schubert <erich@debian.org> Wed, 22 Aug 2018 01:19:02 +0200
+
elki (0.7.1-8) unstable; urgency=low
* Force build with OpenJDK 8 only. (Closes: #906354)
diff --git a/debian/patches/reproducible-builds.patch b/debian/patches/reproducible-builds.patch
new file mode 100644
index 00000000..d794fa6c
--- /dev/null
+++ b/debian/patches/reproducible-builds.patch
@@ -0,0 +1,32 @@
+--- a/elki/src/main/java/de/lmu/ifi/dbs/elki/application/internal/DocumentParameters.java
++++ b/elki/src/main/java/de/lmu/ifi/dbs/elki/application/internal/DocumentParameters.java
+@@ -32,6 +32,7 @@
+ import java.io.PrintStream;
+ import java.lang.reflect.Constructor;
+ import java.util.ArrayList;
++import java.util.Arrays;
+ import java.util.Collections;
+ import java.util.Comparator;
+ import java.util.HashMap;
+@@ -985,7 +986,9 @@
+ p.appendChild(htmldoc.createTextNode(HEADER_KNOWN_IMPLEMENTATIONS));
+ elemdd.appendChild(p);
+ Element ul = htmldoc.createElement(HTMLUtil.HTML_UL_TAG);
+- for(Class<?> c : iter) {
++ Class<?>[] sorted = iter.toArray(new Class<?>[iter.size()]);
++ Arrays.sort(sorted, new ELKIServiceScanner.ClassSorter());
++ for(Class<?> c : sorted) {
+ Element li = htmldoc.createElement(HTMLUtil.HTML_LI_TAG);
+ Element defa = htmldoc.createElement(HTMLUtil.HTML_A_TAG);
+ defa.setAttribute(HTMLUtil.HTML_HREF_ATTRIBUTE, linkForClassName(c.getName()));
+@@ -1014,7 +1017,9 @@
+ }
+ out.println(HEADER_KNOWN_IMPLEMENTATIONS);
+ out.indent++;
+- for(Class<?> c : implementations) {
++ Class<?>[] sorted = implementations.toArray(new Class<?>[implementations.size()]);
++ Arrays.sort(sorted, new ELKIServiceScanner.ClassSorter());
++ for(Class<?> c : sorted) {
+ out.printitem("* ");
+ out.javadocLink(c, restriction);
+ out.println();
diff --git a/debian/patches/series b/debian/patches/series
index 6f06da7a..730eeb6b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,3 +6,4 @@ clipping-batik18.patch
batik-performance.patch
java9-classloader.patch
java9-lookandfeel.patch
+reproducible-builds.patch
diff --git a/debian/rules b/debian/rules
index 9db7157b..96329ad4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,7 +14,4 @@ override_dh_auto_configure:
dh_auto_configure -O--buildsystem=maven
override_dh_auto_test:
-
-#build:
-# mh_patchpoms -pelki
-# $(MVN) --offline -Psvg,svm -DskipTests=true package
+ # Disable tests, as some will time-out on slow build hosts and then unexpectedly fail