summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2014-12-25 11:41:06 -0500
committerDave Reisner <dreisner@archlinux.org>2014-12-25 11:43:26 -0500
commit0a7f0fcc79772d257e0c42358ad472a37a8ab151 (patch)
treee8b3db9898c3f7476b770af90bfb1fa384a2dfe6
parentb7a4d8de9273fab20e1e32e4846b6a866884e07a (diff)
configure.ac: keep posix compat for string tests
'==' and '=' are equivalent in /bin/bash, but POSIX compliant shells do not understand '==.'
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2348dac6e..1df3a18d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -566,7 +566,7 @@ AM_CONDITIONAL(HAVE_XZ, [test "$have_xz" = "yes"])
# ------------------------------------------------------------------------------
have_lz4=no
AC_ARG_ENABLE(lz4, AS_HELP_STRING([--enable-lz4], [Enable optional LZ4 support]))
-AS_IF([test "x$enable_lz4" == "xyes"], [
+AS_IF([test "x$enable_lz4" = "xyes"], [
AC_CHECK_HEADERS(lz4.h,
[AC_DEFINE(HAVE_LZ4, 1, [Define in LZ4 is available]) have_lz4=yes],
[AC_MSG_ERROR([*** LZ4 support requested but headers not found])])