summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-06-25 14:24:56 +0200
committerLennart Poettering <lennart@poettering.net>2012-06-25 14:28:50 +0200
commit0e0320e04500d1e68630b3973714f14cfb7b3450 (patch)
tree3539fd7fb20ee672bbf6f096b74a6def5c5df7b0
parent93a1d735aca5584a005d851f12cb0b8c7bb5e5ca (diff)
units: rename halt/hibernate/kexec/poweroff/reboot/suspend to systed-xxx
These service units also execute our own code, hence rename the accordingly and prefix them with systemd-
-rw-r--r--Makefile.am32
-rw-r--r--man/bootup.xml52
-rw-r--r--man/systemd.special.xml6
-rw-r--r--units/.gitignore74
-rw-r--r--units/halt.target4
-rw-r--r--units/hibernate.target5
-rw-r--r--units/kexec.target4
-rw-r--r--units/poweroff.target4
-rw-r--r--units/reboot.target4
-rw-r--r--units/suspend.target4
-rw-r--r--units/systemd-halt.service.in (renamed from units/halt.service.in)0
-rw-r--r--units/systemd-hibernate.service.in (renamed from units/hibernate.service.in)0
-rw-r--r--units/systemd-kexec.service.in (renamed from units/kexec.service.in)0
-rw-r--r--units/systemd-poweroff.service.in (renamed from units/poweroff.service.in)0
-rw-r--r--units/systemd-random-seed-load.service.in5
-rw-r--r--units/systemd-random-seed-save.service.in5
-rw-r--r--units/systemd-reboot.service.in (renamed from units/reboot.service.in)0
-rw-r--r--units/systemd-suspend.service.in (renamed from units/suspend.service.in)0
-rw-r--r--units/systemd-update-utmp-runlevel.service.in6
-rw-r--r--units/systemd-update-utmp-shutdown.service.in6
-rw-r--r--units/user/.gitignore2
-rw-r--r--units/user/exit.target4
-rw-r--r--units/user/systemd-exit.service.in (renamed from units/user/exit.service.in)0
23 files changed, 107 insertions, 110 deletions
diff --git a/Makefile.am b/Makefile.am
index c3e3ad280..7193c86f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -328,17 +328,17 @@ nodist_systemunit_DATA = \
units/systemd-ask-password-wall.service \
units/systemd-ask-password-console.service \
units/systemd-sysctl.service \
- units/halt.service \
units/emergency.service \
- units/hibernate.service \
- units/poweroff.service \
- units/reboot.service \
- units/kexec.service \
- units/systemd-fsck@.service \
- units/systemd-fsck-root.service \
units/rescue.service \
- units/suspend.service \
units/user@.service \
+ units/systemd-hibernate.service \
+ units/systemd-suspend.service \
+ units/systemd-halt.service \
+ units/systemd-poweroff.service \
+ units/systemd-reboot.service \
+ units/systemd-kexec.service \
+ units/systemd-fsck@.service \
+ units/systemd-fsck-root.service \
units/systemd-udev.service \
units/systemd-udev-trigger.service \
units/systemd-udev-settle.service \
@@ -349,7 +349,7 @@ dist_userunit_DATA = \
units/user/exit.target
nodist_userunit_DATA = \
- units/user/exit.service
+ units/user/systemd-exit.service
EXTRA_DIST += \
units/getty@.service.m4 \
@@ -369,11 +369,11 @@ EXTRA_DIST += \
units/systemd-ask-password-console.service.in \
units/systemd-sysctl.service.in \
units/emergency.service.in \
- units/halt.service.in \
- units/poweroff.service.in \
- units/reboot.service.in \
- units/kexec.service.in \
- units/user/exit.service.in \
+ units/systemd-halt.service.in \
+ units/systemd-poweroff.service.in \
+ units/systemd-reboot.service.in \
+ units/systemd-kexec.service.in \
+ units/user/systemd-exit.service.in \
units/systemd-fsck@.service.in \
units/systemd-fsck-root.service.in \
units/user@.service.in \
@@ -381,8 +381,8 @@ EXTRA_DIST += \
units/systemd-udev-trigger.service \
units/systemd-udev-settle.service \
units/systemd-debug-shell.service.in \
- units/hibernate.service.in \
- units/suspend.service.in \
+ units/systemd-hibernate.service.in \
+ units/systemd-suspend.service.in \
introspect.awk \
man/custom-html.xsl
diff --git a/man/bootup.xml b/man/bootup.xml
index ae84cff0b..69f9a273b 100644
--- a/man/bootup.xml
+++ b/man/bootup.xml
@@ -183,32 +183,32 @@
-<programlisting> (conflicts with (conflicts with
- all system all file system
- services) mounts, swaps,
- | cryptsetup
- | devices, ...)
- | |
- v v
- shutdown.target umount.target
- | |
- \_______ ______/
- \ /
- v
- (various low-level
- services)
- |
- v
- final.target
- |
- __________________________/ \_____________________
- / | | \
- | | | |
- v v v v
-reboot.service poweroff.service halt.service kexec.service
- | | | |
- v v v v
-<emphasis>reboot.target</emphasis> <emphasis>poweroff.target</emphasis> <emphasis>halt.target</emphasis> <emphasis>kexec.target</emphasis></programlisting>
+<programlisting> (conflicts with (conflicts with
+ all system all file system
+ services) mounts, swaps,
+ | cryptsetup
+ | devices, ...)
+ | |
+ v v
+ shutdown.target umount.target
+ | |
+ \_______ ______/
+ \ /
+ v
+ (various low-level
+ services)
+ |
+ v
+ final.target
+ |
+ _____________________________________/ \_________________________________
+ / | | \
+ | | | |
+ v v v v
+systemd-reboot.service systemd-poweroff.service systemd-halt.service systemd-kexec.service
+ | | | |
+ v v v v
+ <emphasis>reboot.target</emphasis> <emphasis>poweroff.target</emphasis> <emphasis>halt.target</emphasis> <emphasis>kexec.target</emphasis></programlisting>
<para>Commonly used system shutdown targets are <emphasis>emphasized</emphasis>.</para>
</refsect1>
diff --git a/man/systemd.special.xml b/man/systemd.special.xml
index 4321f5469..fdb202037 100644
--- a/man/systemd.special.xml
+++ b/man/systemd.special.xml
@@ -57,8 +57,8 @@
<filename>default.target</filename>,
<filename>display-manager.service</filename>,
<filename>emergency.target</filename>,
- <filename>exit.service</filename>,
- <filename>final.service</filename>,
+ <filename>exit.target</filename>,
+ <filename>final.target</filename>,
<filename>getty.target</filename>,
<filename>graphical.target</filename>,
<filename>hibernate.target</filename>,
@@ -813,7 +813,7 @@
<variablelist>
<varlistentry>
- <term><filename>exit.service</filename></term>
+ <term><filename>exit.target</filename></term>
<listitem>
<para>A special service unit
for shutting down the
diff --git a/units/.gitignore b/units/.gitignore
index 6808d1c82..2193bedf6 100644
--- a/units/.gitignore
+++ b/units/.gitignore
@@ -1,48 +1,44 @@
-/hibernate.service
-/suspend.service
+/systemd-hibernate.service
+/systemd-suspend.service
/console-getty.service
/systemd-journald.service
-user@.service
-systemd-logind.service
-systemd-localed.service
-systemd-timedated.service
-systemd-hostnamed.service
-console-shell.service
-systemd-sysctl.service
-systemd-ask-password-console.service
-rescue.service
-systemd-ask-password-wall.service
+/user@.service
+/systemd-logind.service
+/systemd-localed.service
+/systemd-timedated.service
+/systemd-hostnamed.service
+/console-shell.service
+/systemd-sysctl.service
+/systemd-ask-password-console.service
+/rescue.service
+/systemd-ask-password-wall.service
/systemd-quotacheck.service
/systemd-fsck@.service
/systemd-fsck-root.service
-systemd-tmpfiles-clean.service
-systemd-tmpfiles-setup.service
-halt.service
-poweroff.service
-reboot.service
-kexec.service
-systemd-user-sessions.service
-systemd-readahead-done.service
-systemd-tmpfiles.service
-systemd-readahead-collect.service
-systemd-readahead-replay.service
-serial-getty@.service
-systemd-kmsg-syslogd.service
-systemd-modules-load.service
+/systemd-tmpfiles-clean.service
+/systemd-tmpfiles-setup.service
+/systemd-halt.service
+/systemd-poweroff.service
+/systemd-reboot.service
+/systemd-kexec.service
+/systemd-user-sessions.service
+/systemd-readahead-done.service
+/systemd-tmpfiles.service
+/systemd-readahead-collect.service
+/systemd-readahead-replay.service
+/serial-getty@.service
+/systemd-modules-load.service
/systemd-remount-fs.service
-systemd-vconsole-setup.service
-systemd-auto-serial-getty.service
-systemd-shutdownd.service
-systemd-random-seed-load.service
-systemd-random-seed-save.service
-systemd-initctl.service
-systemd-stdout-syslog-bridge.service
-getty@.service
-systemd-update-utmp-runlevel.service
-systemd-update-utmp-shutdown.service
-test-env-replace
-systemd-binfmt.service
-emergency.service
+/systemd-vconsole-setup.service
+/systemd-shutdownd.service
+/systemd-random-seed-load.service
+/systemd-random-seed-save.service
+/systemd-initctl.service
+/getty@.service
+/systemd-update-utmp-runlevel.service
+/systemd-update-utmp-shutdown.service
+/systemd-binfmt.service
+/emergency.service
/systemd-udev-settle.service
/systemd-udev-trigger.service
/systemd-udev.service
diff --git a/units/halt.target b/units/halt.target
index 41266b96f..a21d984b2 100644
--- a/units/halt.target
+++ b/units/halt.target
@@ -9,8 +9,8 @@
Description=Halt
Documentation=man:systemd.special(7)
DefaultDependencies=no
-Requires=halt.service
-After=halt.service
+Requires=systemd-halt.service
+After=systemd-halt.service
AllowIsolate=yes
[Install]
diff --git a/units/hibernate.target b/units/hibernate.target
index fc8493c20..c56460237 100644
--- a/units/hibernate.target
+++ b/units/hibernate.target
@@ -9,6 +9,5 @@
Description=Hibernate
Documentation=man:systemd.special(7)
DefaultDependencies=no
-BindTo=hibernate.service
-After=hibernate.service
-StopWhenUnneeded=yes
+BindTo=systemd-hibernate.service
+After=systemd-hibernate.service
diff --git a/units/kexec.target b/units/kexec.target
index be8eafcf1..90795d0c5 100644
--- a/units/kexec.target
+++ b/units/kexec.target
@@ -9,8 +9,8 @@
Description=Reboot via kexec
Documentation=man:systemd.special(7)
DefaultDependencies=no
-Requires=kexec.service
-After=kexec.service
+Requires=systemd-kexec.service
+After=systemd-kexec.service
AllowIsolate=yes
[Install]
diff --git a/units/poweroff.target b/units/poweroff.target
index bb60c33dd..71871033a 100644
--- a/units/poweroff.target
+++ b/units/poweroff.target
@@ -9,8 +9,8 @@
Description=Power-Off
Documentation=man:systemd.special(7)
DefaultDependencies=no
-Requires=poweroff.service
-After=poweroff.service
+Requires=systemd-poweroff.service
+After=systemd-poweroff.service
AllowIsolate=yes
[Install]
diff --git a/units/reboot.target b/units/reboot.target
index 9faeb1800..dec8f5679 100644
--- a/units/reboot.target
+++ b/units/reboot.target
@@ -9,8 +9,8 @@
Description=Reboot
Documentation=man:systemd.special(7)
DefaultDependencies=no
-Requires=reboot.service
-After=reboot.service
+Requires=systemd-reboot.service
+After=systemd-reboot.service
AllowIsolate=yes
[Install]
diff --git a/units/suspend.target b/units/suspend.target
index eaf79bed1..83f69f1b5 100644
--- a/units/suspend.target
+++ b/units/suspend.target
@@ -9,5 +9,5 @@
Description=Suspend
Documentation=man:systemd.special(7)
DefaultDependencies=no
-BindTo=suspend.service
-After=suspend.service
+BindTo=systemd-suspend.service
+After=systemd-suspend.service
diff --git a/units/halt.service.in b/units/systemd-halt.service.in
index b746d1ea3..b746d1ea3 100644
--- a/units/halt.service.in
+++ b/units/systemd-halt.service.in
diff --git a/units/hibernate.service.in b/units/systemd-hibernate.service.in
index 6dba653d3..6dba653d3 100644
--- a/units/hibernate.service.in
+++ b/units/systemd-hibernate.service.in
diff --git a/units/kexec.service.in b/units/systemd-kexec.service.in
index 17d034497..17d034497 100644
--- a/units/kexec.service.in
+++ b/units/systemd-kexec.service.in
diff --git a/units/poweroff.service.in b/units/systemd-poweroff.service.in
index 851a0f945..851a0f945 100644
--- a/units/poweroff.service.in
+++ b/units/systemd-poweroff.service.in
diff --git a/units/systemd-random-seed-load.service.in b/units/systemd-random-seed-load.service.in
index 8ea575035..e9156ef08 100644
--- a/units/systemd-random-seed-load.service.in
+++ b/units/systemd-random-seed-load.service.in
@@ -9,10 +9,9 @@
Description=Load Random Seed
Documentation=man:systemd-random-seed-load.service(8) man:random(4)
DefaultDependencies=no
-Conflicts=shutdown.target
-After=systemd-readahead-collect.service systemd-readahead-replay.service systemd-remount-fs.service
-Before=sysinit.target shutdown.target
RequiresMountsFor=@RANDOM_SEED@
+After=systemd-readahead-collect.service systemd-readahead-replay.service systemd-remount-fs.service
+Before=sysinit.target final.target
[Service]
Type=oneshot
diff --git a/units/systemd-random-seed-save.service.in b/units/systemd-random-seed-save.service.in
index 05b3c6147..3444d4ce7 100644
--- a/units/systemd-random-seed-save.service.in
+++ b/units/systemd-random-seed-save.service.in
@@ -9,10 +9,9 @@
Description=Save Random Seed
Documentation=man:systemd-random-seed-load.service(8) man:random(4)
DefaultDependencies=no
-After=systemd-random-seed-load.service
-Before=shutdown.target
-Conflicts=systemd-random-seed-load.service
RequiresMountsFor=@RANDOM_SEED@
+After=systemd-remount-fs.service systemd-random-seed-load.service
+Before=final.target
[Service]
Type=oneshot
diff --git a/units/reboot.service.in b/units/systemd-reboot.service.in
index e6a8aabd9..e6a8aabd9 100644
--- a/units/reboot.service.in
+++ b/units/systemd-reboot.service.in
diff --git a/units/suspend.service.in b/units/systemd-suspend.service.in
index 3cf819e47..3cf819e47 100644
--- a/units/suspend.service.in
+++ b/units/systemd-suspend.service.in
diff --git a/units/systemd-update-utmp-runlevel.service.in b/units/systemd-update-utmp-runlevel.service.in
index 6666dbd79..7b6fbadf1 100644
--- a/units/systemd-update-utmp-runlevel.service.in
+++ b/units/systemd-update-utmp-runlevel.service.in
@@ -9,8 +9,10 @@
Description=Update UTMP about System Runlevel Changes
Documentation=man:utmp(5)
DefaultDependencies=no
-After=local-fs.target sysinit.target auditd.service runlevel1.target runlevel2.target runlevel3.target runlevel4.target runlevel5.target systemd-tmpfiles-setup.service
-Before=poweroff.service reboot.service halt.service
+RequiresMountsFor=/var/log/wtmp
+After=systemd-remount-fs.service systemd-tmpfiles-setup.service auditd.service
+After=runlevel1.target runlevel2.target runlevel3.target runlevel4.target runlevel5.target
+Before=final.target
[Service]
Type=oneshot
diff --git a/units/systemd-update-utmp-shutdown.service.in b/units/systemd-update-utmp-shutdown.service.in
index 5b726c368..8615d150b 100644
--- a/units/systemd-update-utmp-shutdown.service.in
+++ b/units/systemd-update-utmp-shutdown.service.in
@@ -9,8 +9,10 @@
Description=Update UTMP about System Shutdown
Documentation=man:utmp(5)
DefaultDependencies=no
-After=local-fs.target sysinit.target auditd.service systemd-update-utmp-runlevel.service
-Before=poweroff.service reboot.service halt.service
+RequiresMountsFor=/var/log/wtmp
+After=systemd-remount-fs.service systemd-tmpfiles-setup.service auditd.service
+After=systemd-update-utmp-runlevel.service
+Before=final.target
[Service]
Type=oneshot
diff --git a/units/user/.gitignore b/units/user/.gitignore
index eeb62b32b..41a74f546 100644
--- a/units/user/.gitignore
+++ b/units/user/.gitignore
@@ -1 +1 @@
-exit.service
+/systemd-exit.service
diff --git a/units/user/exit.target b/units/user/exit.target
index 539e03a9a..b0ad24c48 100644
--- a/units/user/exit.target
+++ b/units/user/exit.target
@@ -9,8 +9,8 @@
Description=Exit the Session
Documentation=man:systemd.special(7)
DefaultDependencies=no
-Requires=exit.service
-After=exit.service
+Requires=systemd-exit.service
+After=systemd-exit.service
AllowIsolate=yes
[Install]
diff --git a/units/user/exit.service.in b/units/user/systemd-exit.service.in
index a114f6c1b..a114f6c1b 100644
--- a/units/user/exit.service.in
+++ b/units/user/systemd-exit.service.in