summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-06-26 00:21:13 +0200
committerLennart Poettering <lennart@poettering.net>2012-06-26 00:21:13 +0200
commit11901ad59689002aa7bbf598e76617f1cfeebd34 (patch)
tree6d4350980f5320260658ffec56e40295026a353d
parentf59e0b64351adec735d06ccf0d0ff0eb31c902c0 (diff)
man: document systemd-shutdownd
-rw-r--r--Makefile.am7
-rw-r--r--man/systemd-shutdownd.service.xml75
-rw-r--r--units/systemd-shutdownd.service.in1
3 files changed, 81 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e3a179b31..751511bc4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -490,7 +490,8 @@ MANPAGES = \
man/systemd-inhibit.1 \
man/systemd-remount-fs.service.8 \
man/systemd-update-utmp-runlevel.service.8 \
- man/systemd-initctl.service.8
+ man/systemd-initctl.service.8 \
+ man/systemd-shutdownd.service.8
MANPAGES_ALIAS = \
man/reboot.8 \
@@ -502,7 +503,8 @@ MANPAGES_ALIAS = \
man/systemd-remount-fs.8 \
man/systemd-update-utmp-shutdown.service.8 \
man/systemd-update-utmp.8 \
- man/systemd-initctl.8
+ man/systemd-initctl.8 \
+ man/systemd-shutdownd.8
man/reboot.8: man/halt.8
man/poweroff.8: man/halt.8
@@ -514,6 +516,7 @@ man/systemd-remount-fs.8: man/systemd-remount-fs.service.8
man/systemd-update-utmp-shutdown.service.8: man/systemd-update-utmp-runlevel.service.8
man/systemd-update-utmp.8: man/systemd-update-utmp-runlevel.service.8
man/systemd-initctl.8: man/systemd-initctl.service.8
+man/systemd-shutdownd.8: man/systemd-shutdownd.service.8
XML_FILES = \
${patsubst %.1,%.xml,${patsubst %.3,%.xml,${patsubst %.5,%.xml,${patsubst %.7,%.xml,${patsubst %.8,%.xml,$(MANPAGES)}}}}}
diff --git a/man/systemd-shutdownd.service.xml b/man/systemd-shutdownd.service.xml
new file mode 100644
index 000000000..146495a0b
--- /dev/null
+++ b/man/systemd-shutdownd.service.xml
@@ -0,0 +1,75 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2012 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="systemd-shutdownd.service">
+
+ <refentryinfo>
+ <title>systemd-shutdownd.service</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>systemd-shutdownd.service</refentrytitle>
+ <manvolnum>8</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>systemd-shutdownd.service</refname>
+ <refname>systemd-shutdownd</refname>
+ <refpurpose>systemd scheduled shutdown daemon</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <para><filename>systemd-shutdownd.service</filename></para>
+ <para><filename>/usr/lib/systemd/systemd-shutdownd</filename></para>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><filename>systemd-shutdownd.service</filename> is a
+ system service that implements scheduled shutdowns, as
+ exposed by
+ <citerefentry><refentrytitle>shutdown</refentrytitle><manvolnum>8</manvolnum></citerefentry>.
+ <filename>systemd-shutdownd.service</filename> is automatically activated on request and terminates
+ itself when it is unused.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>shutdown</refentrytitle><manvolnum>8</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/units/systemd-shutdownd.service.in b/units/systemd-shutdownd.service.in
index b9e271f0f..f51417f58 100644
--- a/units/systemd-shutdownd.service.in
+++ b/units/systemd-shutdownd.service.in
@@ -7,6 +7,7 @@
[Unit]
Description=Delayed Shutdown Service
+Documentation=man:systemd-shutdown.service(8)
DefaultDependencies=no
[Service]