summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-22 00:29:53 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-22 00:29:53 +0200
commit11c3a4eeb7e65eccd6fc0870bb1cda315fa33ba5 (patch)
tree139deea916d530f19dda6a2c0f6e1ac28f626314
parente962f5c34f8e292090fa8c7cb265106a621c8735 (diff)
kmod: automatically load a few kernel modules we need for normal operation before udev is active
-rw-r--r--Makefile.am1
-rw-r--r--fixme2
-rw-r--r--src/automount.c14
-rw-r--r--src/kmod-setup.c107
-rw-r--r--src/kmod-setup.h27
-rw-r--r--src/main.c2
6 files changed, 140 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 8313e57ff..194e3737d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -188,6 +188,7 @@ COMMON_SOURCES = \
src/mount-setup.c \
src/hostname-setup.c \
src/loopback-setup.c \
+ src/kmod-setup.c \
src/utmp-wtmp.c \
src/specifier.c \
src/unit-name.c \
diff --git a/fixme b/fixme
index 4c45633a7..d15e0db62 100644
--- a/fixme
+++ b/fixme
@@ -63,7 +63,7 @@
* Add code to systemctl to wait for an operation to finish
-* kmod-setup.c
+* update to new libudev/tags
Regularly:
diff --git a/src/automount.c b/src/automount.c
index 730b1572c..32680461c 100644
--- a/src/automount.c
+++ b/src/automount.c
@@ -276,18 +276,8 @@ static int open_dev_autofs(Manager *m) {
return m->dev_autofs_fd;
if ((m->dev_autofs_fd = open("/dev/autofs", O_CLOEXEC|O_RDONLY)) < 0) {
-
- if (errno == ENOENT || errno == ENODEV) {
- log_error("Your kernel apparently lacks built-in autofs4 support. Please fix that. "
- "We'll now try to work around this by calling 'modprobe autofs4'...");
- system("/sbin/modprobe -q -- autofs4");
- m->dev_autofs_fd = open("/dev/autofs", O_CLOEXEC|O_RDONLY);
- }
-
- if (m->dev_autofs_fd < 0) {
- log_error("Failed to open /dev/autofs: %s", strerror(errno));
- return -errno;
- }
+ log_error("Failed to open /dev/autofs: %s", strerror(errno));
+ return -errno;
}
init_autofs_dev_ioctl(&param);
diff --git a/src/kmod-setup.c b/src/kmod-setup.c
new file mode 100644
index 000000000..fa856c9a6
--- /dev/null
+++ b/src/kmod-setup.c
@@ -0,0 +1,107 @@
+/*-*- Mode: C; c-basic-offset: 8 -*-*/
+
+/***
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#include <sys/wait.h>
+#include <unistd.h>
+#include <string.h>
+#include <errno.h>
+
+#include "macro.h"
+#include "execute.h"
+
+#include "kmod-setup.h"
+
+static const char * const kmod_table[] = {
+ "autofs4", "/sys/class/misc/autofs",
+ "ipv6", "/sys/module/ipv6"
+};
+
+int kmod_setup(void) {
+ unsigned i, n = 0;
+ const char * cmdline[3 + ELEMENTSOF(kmod_table) + 1];
+ ExecCommand command;
+ ExecContext context;
+ pid_t pid;
+ int status, r;
+
+ for (i = 0; i < ELEMENTSOF(kmod_table); i += 2) {
+
+ if (access(kmod_table[i+1], F_OK) >= 0)
+ continue;
+
+ log_info("Your kernel apparently lacks built-in %s support. Please fix that. "
+ "We'll now try to work around this by calling '/sbin/modprobe %s'...",
+ kmod_table[i], kmod_table[i]);
+
+ cmdline[3 + n++] = kmod_table[i];
+ }
+
+ if (n <= 0)
+ return 0;
+
+ cmdline[0] = "/sbin/modprobe";
+ cmdline[1] = "-qab";
+ cmdline[2] = "--";
+ cmdline[3 + n] = NULL;
+
+ zero(command);
+ zero(context);
+
+ command.path = (char*) cmdline[0];
+ command.argv = (char**) cmdline;
+
+ exec_context_init(&context);
+ r = exec_spawn(&command, NULL, &context, NULL, 0, NULL, false, false, false, NULL, &pid);
+ exec_context_done(&context);
+
+ if (r < 0)
+ return r;
+
+ for (;;) {
+ if (waitpid(pid, &status, 0) < 0) {
+
+ if (errno == EINTR)
+ continue;
+
+ return -errno;
+ }
+
+ break;
+ }
+
+ if (WIFEXITED(status)) {
+ if (WEXITSTATUS(status) != 0) {
+ log_warning("/sbin/modprobe failed with error code %i.", WEXITSTATUS(status));
+ return -EPROTO;
+ }
+
+ log_debug("/sbin/modprobe succeeded.");
+ return 0;
+ }
+
+ if (WIFSIGNALED(status)) {
+ log_warning("/sbin/modprobe terminated by signal %s.", strsignal(WTERMSIG(status)));
+ return -EPROTO;
+ }
+
+ log_warning("/sbin/modprobe failed due to unknown reason.");
+ return -EPROTO;
+}
diff --git a/src/kmod-setup.h b/src/kmod-setup.h
new file mode 100644
index 000000000..c102b5264
--- /dev/null
+++ b/src/kmod-setup.h
@@ -0,0 +1,27 @@
+/*-*- Mode: C; c-basic-offset: 8 -*-*/
+
+#ifndef fookmodsetuphfoo
+#define fookmodsetuphfoo
+
+/***
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+int kmod_setup(void);
+
+#endif
diff --git a/src/main.c b/src/main.c
index 2e754fe6e..95d211523 100644
--- a/src/main.c
+++ b/src/main.c
@@ -37,6 +37,7 @@
#include "mount-setup.h"
#include "hostname-setup.h"
#include "loopback-setup.h"
+#include "kmod-setup.h"
#include "load-fragment.h"
#include "fdset.h"
@@ -639,6 +640,7 @@ int main(int argc, char *argv[]) {
log_debug("systemd running in %s mode.", manager_running_as_to_string(running_as));
if (running_as == MANAGER_INIT) {
+ kmod_setup();
hostname_setup();
loopback_setup();
}