summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Giokas <1007380@gmail.com>2013-07-30 19:05:31 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-08-02 10:44:14 -0400
commit1272ff850ac65557f3cc06e00d5ddbd2588ff8b0 (patch)
tree9c55d1de2b6f8ca805eb21020c991ae6673d8b44
parent4a8fa990693edc47ac2192bf088a6e22e2390b41 (diff)
zsh_completion: Split out zsh _systemd-tmpfiles
You can choose to have systemd-tmpfiles at configuration time, so only install the completion for this if configured to do so.
-rw-r--r--Makefile.am3
-rw-r--r--shell-completion/zsh/_systemd12
-rw-r--r--shell-completion/zsh/_systemd-tmpfiles10
3 files changed, 14 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 3713d0dd6..e35eaeb73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1565,6 +1565,9 @@ SYSINIT_TARGET_WANTS += \
systemd-tmpfiles-setup-dev.service \
systemd-tmpfiles-setup.service
+dist_zshcompletion_DATA += \
+ shell-completion/zsh/_systemd-tmpfiles
+
TIMERS_TARGET_WANTS += \
systemd-tmpfiles-clean.timer
diff --git a/shell-completion/zsh/_systemd b/shell-completion/zsh/_systemd
index 1addfa587..7aab52d5b 100644
--- a/shell-completion/zsh/_systemd
+++ b/shell-completion/zsh/_systemd
@@ -1,4 +1,4 @@
-#compdef systemd-cat systemd-ask-password systemd-cgls systemd-cgtop systemd-delta systemd-detect-virt systemd-machine-id-setup systemd-notify systemd-tmpfiles systemd-tty-ask-password-agent
+#compdef systemd-cat systemd-ask-password systemd-cgls systemd-cgtop systemd-delta systemd-detect-virt systemd-machine-id-setup systemd-notify systemd-tty-ask-password-agent
_ctls()
{
@@ -77,16 +77,6 @@ _ctls()
'--booted[Returns 0 if the system was booted up with systemd]' \
'--readahead=[Controls disk read-ahead operations]:arguments:(cancel done noreply)'
;;
- systemd-tmpfiles)
- _arguments \
- '--create[Create, set ownership/permissions based on the config files.]' \
- '--clean[Clean up all files and directories with an age parameter configured.]' \
- '--remove[All files and directories marked with r, R in the configuration files are removed.]' \
- '--prefix=[Only apply rules that apply to paths with the specified prefix.]' \
- '--exclude-prefix=[Ignore rules that apply to paths with the specified prefix.]' \
- '--help[Prints a short help text and exits.]' \
- '*::files:_files'
- ;;
systemd-tty-ask-password-agent)
_arguments \
{-h,--help}'[Prints a short help text and exits.]' \
diff --git a/shell-completion/zsh/_systemd-tmpfiles b/shell-completion/zsh/_systemd-tmpfiles
new file mode 100644
index 000000000..4913dedd2
--- /dev/null
+++ b/shell-completion/zsh/_systemd-tmpfiles
@@ -0,0 +1,10 @@
+#compdef systemd-tmpfiles
+
+_arguments \
+ '--create[Create, set ownership/permissions based on the config files.]' \
+ '--clean[Clean up all files and directories with an age parameter configured.]' \
+ '--remove[All files and directories marked with r, R in the configuration files are removed.]' \
+ '--prefix=[Only apply rules that apply to paths with the specified prefix.]' \
+ '--exclude-prefix=[Ignore rules that apply to paths with the specified prefix.]' \
+ '--help[Prints a short help text and exits.]' \
+ '*::files:_files'