summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2015-01-09 21:23:48 +0100
committerKay Sievers <kay@vrfy.org>2015-01-09 21:39:31 +0100
commit1401ec2d34bcde406ced531a72dc46ebaf332594 (patch)
treed8b5af3521521de780f09af874c60ae4c1c8b725
parentfa607802f332e06f4044c3eb38dbea41076c803d (diff)
push xorg information to the systemd --user instance
-rw-r--r--Makefile.am4
-rwxr-xr-xxorg/50-systemd-user.sh3
2 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e024748a6..aa5580b82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,6 +84,7 @@ sysvrcnddir=$(SYSTEM_SYSVRCND_PATH)
varlogdir=$(localstatedir)/log
systemdstatedir=$(localstatedir)/lib/systemd
catalogstatedir=$(systemdstatedir)/catalog
+xinitrcdir=$(sysconfdir)/X11/xinit/xinitrc.d
# Our own, non-special dirs
pkgsysconfdir=$(sysconfdir)/systemd
@@ -2474,6 +2475,9 @@ dbus1-generator-install-hook:
dbus1-generator-uninstall-hook:
rm -f $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
+dist_xinitrc_SCRIPTS = \
+ xorg/50-systemd-user.sh
+
INSTALL_EXEC_HOOKS += dbus1-generator-install-hook
UNINSTALL_EXEC_HOOKS += dbus1-generator-uninstall-hook
endif
diff --git a/xorg/50-systemd-user.sh b/xorg/50-systemd-user.sh
new file mode 100755
index 000000000..f4df13b61
--- /dev/null
+++ b/xorg/50-systemd-user.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+systemctl --user import-environment DISPLAY XAUTHORITY