summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-09-01 11:54:25 +0200
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:15:07 +0100
commit2777c31cfc09d736ea37b0449d2baf52db07567e (patch)
tree9ae7dbb66f115c8597d6d76af04b24b09ae0fc51
parent24aa8c70860838af5c1dbfc81131888a4865d16c (diff)
Fix the login monitor
* src/login/logind.c (main): Create /run/systemd/machines, so that the login monitor works. * configure.ac: v219.10.
-rw-r--r--src/login/logind.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/login/logind.c b/src/login/logind.c
index bcf23d225..7acc03c1d 100644
--- a/src/login/logind.c
+++ b/src/login/logind.c
@@ -1026,6 +1026,7 @@ int main(int argc, char *argv[]) {
mkdir_label("/run/systemd/seats", 0755);
mkdir_label("/run/systemd/users", 0755);
mkdir_label("/run/systemd/sessions", 0755);
+ mkdir_label("/run/systemd/machines", 0755);
m = manager_new();
if (!m) {