summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-06-23 01:49:57 +0200
committerLennart Poettering <lennart@poettering.net>2010-06-23 01:49:57 +0200
commit359957ee23e8dad97f6c75969d7ecfe4d3c4369f (patch)
treed7dd4e21fc389204a13d8bbed4968918ac83169a
parentf9378423b9758861850748aeb49ae0d3300e56e6 (diff)
man: document runlevel and systemd-install
-rw-r--r--.gitignore1
-rw-r--r--Makefile.am18
-rw-r--r--man/runlevel.xml149
-rw-r--r--man/systemd-install.xml165
4 files changed, 330 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 7e44eaa1b..1632e3f19 100644
--- a/.gitignore
+++ b/.gitignore
@@ -16,6 +16,7 @@ systemd-logger
systemctl
systemadm
.dirstamp
+*.1
*.3
*.5
*.7
diff --git a/Makefile.am b/Makefile.am
index 0f9ef8eab..68b1bd14c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -313,7 +313,9 @@ dist_man_MANS = \
man/sd_booted.3 \
man/sd_listen_fds.3 \
man/sd_is_fifo.3 \
- man/sd-daemon.7
+ man/sd-daemon.7 \
+ man/runlevel.8 \
+ man/systemd-install.1
nodist_man_MANS = \
man/systemd.special.7
@@ -327,7 +329,9 @@ dist_noinst_DATA = \
man/sd_booted.html \
man/sd_listen_fds.html \
man/sd_is_fifo.html \
- man/sd-daemon.html
+ man/sd-daemon.html \
+ man/runlevel.html \
+ man/systemd-install.html
nodist_noinst_DATA = \
man/systemd.special.html
@@ -344,7 +348,9 @@ EXTRA_DIST += \
man/sd_booted.xml \
man/sd_listen_fds.xml \
man/sd_is_fifo.xml \
- man/sd-daemon.xml
+ man/sd-daemon.xml \
+ man/runlevel.xml \
+ man/systemd-install.xml
systemd_SOURCES = \
src/main.c
@@ -594,6 +600,12 @@ man/%.3: man/%.xml
man/%.3.in: man/%.xml.in
$(XSLTPROC_PROCESS_MAN)
+man/%.1: man/%.xml
+ $(XSLTPROC_PROCESS_MAN)
+
+man/%.1.in: man/%.xml.in
+ $(XSLTPROC_PROCESS_MAN)
+
man/%.5: man/%.xml
$(XSLTPROC_PROCESS_MAN)
diff --git a/man/runlevel.xml b/man/runlevel.xml
new file mode 100644
index 000000000..1404ff6d2
--- /dev/null
+++ b/man/runlevel.xml
@@ -0,0 +1,149 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="systemd">
+
+ <refentryinfo>
+ <title>runlevel</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>runlevel</refentrytitle>
+ <manvolnum>8</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>runlevel</refname>
+ <refpurpose>Print previous and current SysV runlevel</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>runlevel <arg choice="opt" rep="repeat">options</arg></command>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><command>runlevel</command> prints the previous
+ and current SysV runlevel if they are known.</para>
+
+ <para>The two runlevel characters are seperated by a
+ single space character. If a runlevel cannot be
+ determined N is printed instead. If neither can be
+ determined the word "unknown" is printed.</para>
+
+ <para>Unless overriden in the environment this will
+ check the utmp database for recent runlevel
+ changes.</para>
+
+ <para>The following option is understood:</para>
+
+ <variablelist>
+ <varlistentry>
+ <term>--help</term>
+
+ <listitem><para>Prints a short help
+ text and exits.</para></listitem>
+ </varlistentry>
+ </variablelist>
+
+ </refsect1>
+
+ <refsect1>
+ <title>Exit status</title>
+
+ <para>If one or both runlevels could be determined, 0
+ is returned, a non-zero failure code otherwise.</para>
+
+ </refsect1>
+
+ <refsect1>
+ <title>Environment</title>
+
+ <variablelist>
+ <varlistentry>
+ <term><varname>$RUNLEVEL</varname></term>
+
+ <listitem><para>If
+ <varname>$RUNLEVEL</varname> is set,
+ <command>runlevel</command> will print
+ this value as current runlevel and
+ ignore utmp.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term><varname>$PREVLEVEL</varname></term>
+
+ <listitem><para>If
+ <varname>$PREVLEVEL</varname> is set
+ <command>runlevel</command> will print
+ this value as previous runlevel and
+ ignore utmp.</para></listitem>
+ </varlistentry>
+ </variablelist>
+ </refsect1>
+
+ <refsect1>
+ <title>Files</title>
+
+ <variablelist>
+ <varlistentry>
+ <term><varname>/var/run/utmp</varname></term>
+
+ <listitem><para>The utmp database
+ <command>runlevel</command> reads the
+ previous and current runlevel
+ from.</para></listitem>
+
+ </varlistentry>
+ </variablelist>
+ </refsect1>
+
+ <refsect1>
+ <title>Notes</title>
+
+ <para>This is a legacy call available for compatbility
+ only. It should not be used anymore, as the concept of
+ runlevels is obselete.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>systemctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/man/systemd-install.xml b/man/systemd-install.xml
new file mode 100644
index 000000000..9881e9819
--- /dev/null
+++ b/man/systemd-install.xml
@@ -0,0 +1,165 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="systemd">
+
+ <refentryinfo>
+ <title>systemd-install</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>systemd-install</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>systemd-install</refname>
+ <refpurpose>Enable or disable a systemd unit
+ definition file</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>systemd-install <arg choice="opt" rep="repeat">options</arg> <option>enable</option> <arg choice="opt" rep="repeat">name</arg></command>
+ </cmdsynopsis>
+ <cmdsynopsis>
+ <command>systemd-install <arg choice="opt" rep="repeat">options</arg> <option>disable</option> <arg choice="opt" rep="repeat">name</arg></command>
+ </cmdsynopsis>
+ <cmdsynopsis>
+ <command>systemd-install <arg choice="opt" rep="repeat">options</arg> <option>test</option> <arg choice="opt" rep="repeat">name</arg></command>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><command>systemd-install</command> enables or
+ disables systemd units, or checks whether they are
+ enabled.</para>
+
+ <para>The following options are understood:</para>
+
+ <variablelist>
+ <varlistentry>
+ <term>--help</term>
+
+ <listitem><para>Prints a short help
+ text and exits.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term>--force</term>
+
+ <listitem><para>Enable/disable a
+ service even if it conflicts
+ with/contradicts another service. This
+ might have the effect of disabling
+ another service that was
+ enabled.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term>--system</term>
+
+ <listitem><para>Enable/disable a
+ system service.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term>--session</term>
+
+ <listitem><para>Enable/disable a
+ session service for the calling
+ user.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term>--global</term>
+
+ <listitem><para>Enable/disable a
+ session service for all
+ users.</para></listitem>
+ </varlistentry>
+ </variablelist>
+
+ <para>The following verbs are understood:</para>
+
+ <variablelist>
+ <varlistentry>
+ <term>enable</term>
+
+ <listitem><para>Enable a unit. This
+ will create a number of symlinks as
+ encoded in the [Install] section of a
+ unit file.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term>disable</term>
+
+ <listitem><para>Disable a unit. This
+ will removed a number of symlinks as
+ encoded in the [Install] section of a
+ unit file.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term>test</term>
+
+ <listitem><para>Checks whether any of
+ the units specified are
+ installed. This will check for the
+ existance of a number of symlinks as
+ encoded in the [Install] section of a
+ unit file.</para></listitem>
+ </varlistentry>
+ </variablelist>
+
+ </refsect1>
+
+ <refsect1>
+ <title>Exit status</title>
+
+ <para>On success 0 is returned, a non-zero failure
+ code otherwise.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>systemctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>systemd.unit</refentrytitle><manvolnum>5</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>