summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2013-04-22 21:57:39 +0200
committerTom Gundersen <teg@jklm.no>2013-04-22 21:57:39 +0200
commit3e8037f17c985a99b26fff92917e8567480ab246 (patch)
tree603b9ead4ee8471268acab6c78980dd157009278
parentbf83067c1ded45c1ba1d9d679e6190a5de51f960 (diff)
units: rename systemd-static-nodes -> systemd-tmpfiles-setup-dev
This is really just a special case of systemd-tmpfiles-setup, moreover it could easily create more than static nodes.
-rw-r--r--Makefile.am8
-rw-r--r--units/.gitignore2
-rw-r--r--units/systemd-tmpfiles-setup-dev.service.in (renamed from units/systemd-static-nodes.service.in)0
3 files changed, 4 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d594a3d93..1e155d5ab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -416,6 +416,7 @@ nodist_systemunit_DATA = \
units/systemd-remount-fs.service \
units/systemd-update-utmp-runlevel.service \
units/systemd-update-utmp-shutdown.service \
+ units/systemd-tmpfiles-setup-dev.service \
units/systemd-tmpfiles-setup.service \
units/systemd-tmpfiles-clean.service \
units/systemd-ask-password-wall.service \
@@ -433,7 +434,6 @@ nodist_systemunit_DATA = \
units/systemd-kexec.service \
units/systemd-fsck@.service \
units/systemd-fsck-root.service \
- units/systemd-static-nodes.service \
units/systemd-udevd.service \
units/systemd-udev-trigger.service \
units/systemd-udev-settle.service \
@@ -461,6 +461,7 @@ EXTRA_DIST += \
units/systemd-remount-fs.service.in \
units/systemd-update-utmp-runlevel.service.in \
units/systemd-update-utmp-shutdown.service.in \
+ units/systemd-tmpfiles-setup-dev.service.in \
units/systemd-tmpfiles-setup.service.in \
units/systemd-tmpfiles-clean.service.in \
units/systemd-ask-password-wall.service.in \
@@ -475,7 +476,6 @@ EXTRA_DIST += \
units/systemd-fsck@.service.in \
units/systemd-fsck-root.service.in \
units/user@.service.in \
- units/systemd-static-nodes.service \
units/systemd-udevd.service \
units/systemd-udev-trigger.service \
units/systemd-udev-settle.service \
@@ -1952,13 +1952,11 @@ CLEANFILES += \
src/udev/udev.pc
EXTRA_DIST += \
- units/systemd-static-nodes.service.in \
units/systemd-udevd.service.in \
units/systemd-udev-trigger.service.in \
units/systemd-udev-settle.service.in
CLEANFILES += \
- units/systemd-static-nodes.service \
units/systemd-udevd.service \
units/systemd-udev-trigger.service \
units/systemd-udev-settle.service
@@ -1967,7 +1965,6 @@ SOCKETS_TARGET_WANTS += \
systemd-udevd-control.socket \
systemd-udevd-kernel.socket
SYSINIT_TARGET_WANTS += \
- systemd-static-nodes.service \
systemd-udevd.service \
systemd-udev-trigger.service
@@ -4021,6 +4018,7 @@ SYSINIT_TARGET_WANTS += \
sys-kernel-config.mount \
sys-kernel-debug.mount \
sys-fs-fuse-connections.mount \
+ systemd-tmpfiles-setup-dev.service \
systemd-tmpfiles-setup.service \
systemd-sysctl.service \
systemd-ask-password-console.path
diff --git a/units/.gitignore b/units/.gitignore
index 6c9582e02..d2f3eb40d 100644
--- a/units/.gitignore
+++ b/units/.gitignore
@@ -26,6 +26,7 @@
/systemd-fsck-root.service
/systemd-tmpfiles-clean.service
/systemd-tmpfiles-setup.service
+/systemd-tmpfiles-setup-dev.service
/systemd-halt.service
/systemd-poweroff.service
/systemd-reboot.service
@@ -43,7 +44,6 @@
/systemd-random-seed-load.service
/systemd-random-seed-save.service
/systemd-initctl.service
-/systemd-static-nodes.service
/getty@.service
/systemd-update-utmp-runlevel.service
/systemd-update-utmp-shutdown.service
diff --git a/units/systemd-static-nodes.service.in b/units/systemd-tmpfiles-setup-dev.service.in
index 3553226c6..3553226c6 100644
--- a/units/systemd-static-nodes.service.in
+++ b/units/systemd-tmpfiles-setup-dev.service.in