summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-07-13 19:00:48 +0200
committerLennart Poettering <lennart@poettering.net>2012-07-13 19:00:48 +0200
commit4171a6676c74846c9c189f3a92b97bbcd4a11a13 (patch)
tree696bcd61f433e1eb8e3fbddcaae07d15dd6e44b2
parent67c3cf4f9ea35c1f789526b24a4d052d071902c0 (diff)
man: document sd_journal_get_data() and friends
-rw-r--r--Makefile.am15
-rw-r--r--man/sd_journal_get_data.xml199
-rw-r--r--man/sd_journal_next.xml18
-rw-r--r--src/systemd/sd-journal.h1
4 files changed, 231 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 119d96888..b54c21b37 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -502,7 +502,8 @@ MANPAGES = \
man/sd_journal_print.3 \
man/sd_journal_stream_fd.3 \
man/sd_journal_open.3 \
- man/sd_journal_next.3
+ man/sd_journal_next.3 \
+ man/sd_journal_get_data.3
MANPAGES_ALIAS = \
man/reboot.8 \
@@ -547,7 +548,12 @@ MANPAGES_ALIAS = \
man/sd_journal_close.3 \
man/sd_journal_previous.3 \
man/sd_journal_next_skip.3 \
- man/sd_journal_previous_skip.3
+ man/sd_journal_previous_skip.3 \
+ man/SD_JOURNAL_FOREACH.3 \
+ man/SD_JOURNAL_FOREACH_BACKWARDS.3 \
+ man/sd_journal_enumerate_data.3 \
+ man/sd_journal_restart_data.3 \
+ man/SD_JOURNAL_FOREACH_DATA.3
man/reboot.8: man/halt.8
man/poweroff.8: man/halt.8
@@ -592,6 +598,11 @@ man/sd_journal_close.3: man/sd_journal_open.3
man/sd_journal_previous.3: man/sd_journal_next.3
man/sd_journal_next_skip.3: man/sd_journal_next.3
man/sd_journal_previous_skip.3: man/sd_journal_next.3
+man/SD_JOURNAL_FOREACH.3: man/sd_journal_next.3
+man/SD_JOURNAL_FOREACH_BACKWARDS.3: man/sd_journal_next.3
+man/sd_journal_enumerate_data.3: man/sd_journal_get_data.3
+man/sd_journal_restart_data.3: man/sd_journal_get_data.3
+man/SD_JOURNAL_FOREACH_DATA.3: man/sd_journal_get_data.3
XML_FILES = \
${patsubst %.1,%.xml,${patsubst %.3,%.xml,${patsubst %.5,%.xml,${patsubst %.7,%.xml,${patsubst %.8,%.xml,$(MANPAGES)}}}}}
diff --git a/man/sd_journal_get_data.xml b/man/sd_journal_get_data.xml
new file mode 100644
index 000000000..9d8a4a222
--- /dev/null
+++ b/man/sd_journal_get_data.xml
@@ -0,0 +1,199 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2012 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="sd_journal_get_data">
+
+ <refentryinfo>
+ <title>sd_journal_get_data</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>sd_journal_get_data</refentrytitle>
+ <manvolnum>3</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>sd_journal_get_data</refname>
+ <refname>sd_journal_enumerate_data</refname>
+ <refname>sd_journal_restart_data</refname>
+ <refname>SD_JOURNAL_FOREACH_DATA</refname>
+ <refpurpose>Read data fields from the current journal entry</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <funcsynopsis>
+ <funcsynopsisinfo>#include &lt;systemd/sd-journal.h&gt;</funcsynopsisinfo>
+
+ <funcprototype>
+ <funcdef>int <function>sd_journal_get_data</function></funcdef>
+ <paramdef>sd_journal* <parameter>j</parameter></paramdef>
+ <paramdef>const char* <parameter>field</parameter></paramdef>
+ <paramdef>const void** <parameter>data</parameter></paramdef>
+ <paramdef>size_t* <parameter>length</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef>int <function>sd_journal_enumerate_data</function></funcdef>
+ <paramdef>sd_journal* <parameter>j</parameter></paramdef>
+ <paramdef>const void** <parameter>data</parameter></paramdef>
+ <paramdef>size_t* <parameter>length</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef>int <function>sd_journal_restart_data</function></funcdef>
+ <paramdef>sd_journal* <parameter>j</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef><function>SD_JOURNAL_FOREACH_DATA</function></funcdef>
+ <paramdef>sd_journal* <parameter>j</parameter></paramdef>
+ <paramdef>const void* <parameter>data</parameter></paramdef>
+ <paramdef>size_t <parameter>length</parameter></paramdef>
+ </funcprototype>
+
+ </funcsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><function>sd_journal_get_data()</function> gets
+ the data object associated with a specific field from
+ the current journal entry. It takes four arguments:
+ the journal context object, a string with the field
+ name to request, plus a pair of pointers to
+ pointer/size variables where the data object and its
+ size shall be stored in. The field name should be an
+ entry field name. Well-known field names are listed in
+ <citerefentry><refentrytitle>systemd.journal-fields</refentrytitle><manvolnum>7</manvolnum></citerefentry>. The
+ returned data is in a read-only memory map and is only
+ valid until the next invocation of
+ <function>sd_journal_get_data()</function> or
+ <function>sd_journal_enumerate_data()</function>, or
+ the read pointer is altered. Note that the data
+ returned will be prefixed with the field name and
+ '='.</para>
+
+ <para><function>sd_journal_enumerate_data()</function>
+ may be used to iterate through all fields of the
+ current entry. On each invocation the data for the
+ next field is returned. The order of these fields is
+ not defined. The data returned is in the same format
+ as with <function>sd_journal_get_data()</function> and
+ also follows the same life-time semantics.</para>
+
+ <para><function>sd_journal_restart_data()</function>
+ resets the data enumeration index to the beginning of
+ the entry. The next invocation of
+ <function>sd_journal_enumerate_data()</function> will return the first
+ field of the entry again.</para>
+
+ <para>Note that the
+ <function>SD_JOURNAL_FOREACH_DATA()</function> macro
+ may be used as a wrapper around
+ <function>sd_journal_restart_data()</function> and
+ <function>sd_journal_enumerate_data()</function>.</para>
+
+ <para>Note that these functions will not work before
+ <citerefentry><refentrytitle>sd_journal_next</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ (or related call) has not been called at least
+ once.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Return Value</title>
+
+ <para><function>sd_journal_get_data()</function>
+ returns 0 on success or a negative errno-style error
+ code. If the current entry does not include the
+ specified field -ENOENT is returned. If
+ <citerefentry><refentrytitle>sd_journal_next</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ has not been called at least once -EADDRNOTAVAIL is
+ returned. <function>sd_journal_enumerate_data()</function>
+ returns a positive integer if the next field has been
+ read, 0 when no more fields are known, or a negative
+ errno-style error
+ code. <function>sd_journal_restart_data()</function>
+ returns nothing.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Notes</title>
+
+ <para>The <function>sd_journal_get_data()</function>,
+ <function>sd_journal_enumerate_data()</function> and
+ <function>sd_journal_restart_data()</function>
+ interfaces are available as shared library, which can
+ be compiled and linked to with the
+ <literal>libsystemd-journal</literal>
+ <citerefentry><refentrytitle>pkg-config</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+ file.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Examples</title>
+
+ <para>See
+ <citerefentry><refentrytitle>sd_journal_next</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ for a complete example how to use
+ <function>sd_journal_get_data()</function>.</para>
+
+ <para>Use the
+ <function>SD_JOURNAL_FOREACH_DATA</function> macro to
+ iterate through all fields of the current journal
+ entry:</para>
+
+ <programlisting>...
+int print_fields(sd_journal *j) {
+ const void *data;
+ size_t l;
+ SD_JOURNAL_FOREACH_DATA(j, data, length)
+ printf("%.*s\n", (int) length, data);
+}
+...</programlisting>
+
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>systemd.journal-fields</refentrytitle><manvolnum>7</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd-journal</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_journal_open</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_journal_next</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/man/sd_journal_next.xml b/man/sd_journal_next.xml
index f55ee1574..90fcecb10 100644
--- a/man/sd_journal_next.xml
+++ b/man/sd_journal_next.xml
@@ -47,6 +47,8 @@
<refname>sd_journal_previous</refname>
<refname>sd_journal_next_skip</refname>
<refname>sd_journal_previous_skip</refname>
+ <refname>SD_JOURNAL_FOREACH</refname>
+ <refname>SD_JOURNAL_FOREACH_BACKWARDS</refname>
<refpurpose>Advance or set back the read pointer in the journal</refpurpose>
</refnamediv>
@@ -76,6 +78,15 @@
<paramdef>uint64_t <parameter>skip</parameter></paramdef>
</funcprototype>
+ <funcprototype>
+ <funcdef><function>SD_JOURNAL_FOREACH</function></funcdef>
+ <paramdef>sd_journal* <parameter>j</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef><function>SD_JOURNAL_FOREACH_BACKWARDS</function></funcdef>
+ <paramdef>sd_journal* <parameter>j</parameter></paramdef>
+ </funcprototype>
</funcsynopsis>
</refsynopsisdiv>
@@ -105,6 +116,13 @@
that the entry then pointing to is later in time than
then previous one, or has the same timestamp.</para>
+ <para>Note that
+ <citerefentry><refentrytitle>sd_journal_get_data</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ and related calls will fail unless
+ <function>sd_journal_next()</function> has been
+ invoked at least once in order to position the read
+ pointer on a journal entry.</para>
+
<para>Note that the
<function>SD_JOURNAL_FOREACH()</function> macro may be used
as a wrapper around
diff --git a/src/systemd/sd-journal.h b/src/systemd/sd-journal.h
index 935b0452b..e70f575ce 100644
--- a/src/systemd/sd-journal.h
+++ b/src/systemd/sd-journal.h
@@ -85,6 +85,7 @@ int sd_journal_next_skip(sd_journal *j, uint64_t skip);
int sd_journal_get_realtime_usec(sd_journal *j, uint64_t *ret);
int sd_journal_get_monotonic_usec(sd_journal *j, uint64_t *ret, sd_id128_t *ret_boot_id);
+
int sd_journal_get_data(sd_journal *j, const char *field, const void **data, size_t *l);
int sd_journal_enumerate_data(sd_journal *j, const void **data, size_t *l);
void sd_journal_restart_data(sd_journal *j);