summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2012-11-09 15:35:11 +0100
committerTom Gundersen <teg@jklm.no>2012-11-09 15:36:25 +0100
commit43f9cc65c2caa679019c3cfbd1aff66c6c59d410 (patch)
tree536caac42e9882c891d652bc8a46c3b2c7883f8a
parent09d8f5d757515122d7b726218e249621e564157c (diff)
hwdb: change pci.ids location
According to pciutils' TODO, the sourceforge location is scheduled for removal, use the new one instead.
-rw-r--r--Makefile.am2
-rw-r--r--hwdb/20-pci-classes.hwdb2
-rw-r--r--hwdb/20-pci-vendor-product.hwdb2
-rwxr-xr-xhwdb/ids-update.pl4
4 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c84fe1c7..452de152d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4009,7 +4009,7 @@ endif
hwdb-update:
( cd hwdb && \
wget -N http://www.linux-usb.org/usb.ids && \
- wget -N http://pciids.sourceforge.net/v2.2/pci.ids && \
+ wget -N http://pci-ids.ucw.cz/v2.2/pci.ids && \
wget -N http://standards.ieee.org/develop/regauth/oui/oui.txt && \
./ids-update.pl )
diff --git a/hwdb/20-pci-classes.hwdb b/hwdb/20-pci-classes.hwdb
index fc086a5b5..0541eb73e 100644
--- a/hwdb/20-pci-classes.hwdb
+++ b/hwdb/20-pci-classes.hwdb
@@ -1,6 +1,6 @@
# This file is part of systemd.
#
-# Data imported and updated from: http://pciids.sourceforge.net/v2.2/pci.ids
+# Data imported and updated from: http://pci-ids.ucw.cz/v2.2/pci.ids
pci:v*d*sv*sd*bc00*
ID_PCI_CLASS_FROM_DATABASE=Unclassified device
diff --git a/hwdb/20-pci-vendor-product.hwdb b/hwdb/20-pci-vendor-product.hwdb
index 19c178565..eb842b8d2 100644
--- a/hwdb/20-pci-vendor-product.hwdb
+++ b/hwdb/20-pci-vendor-product.hwdb
@@ -1,6 +1,6 @@
# This file is part of systemd.
#
-# Data imported and updated from: http://pciids.sourceforge.net/v2.2/pci.ids
+# Data imported and updated from: http://pci-ids.ucw.cz/v2.2/pci.ids
pci:v00000010*
ID_VENDOR_FROM_DATABASE=Allied Telesis, Inc
diff --git a/hwdb/ids-update.pl b/hwdb/ids-update.pl
index c96c95fd3..b21a3d8f5 100755
--- a/hwdb/ids-update.pl
+++ b/hwdb/ids-update.pl
@@ -113,7 +113,7 @@ sub pci_vendor {
open(OUT, ">", "20-pci-vendor-product.hwdb");
print(OUT "# This file is part of systemd.\n" .
"#\n" .
- "# Data imported and updated from: http://pciids.sourceforge.net/v2.2/pci.ids\n");
+ "# Data imported and updated from: http://pci-ids.ucw.cz/v2.2/pci.ids\n");
while (my $line = <IN>) {
$line =~ s/\s+$//;
@@ -162,7 +162,7 @@ sub pci_classes {
open(OUT, ">", "20-pci-classes.hwdb");
print(OUT "# This file is part of systemd.\n" .
"#\n" .
- "# Data imported and updated from: http://pciids.sourceforge.net/v2.2/pci.ids\n");
+ "# Data imported and updated from: http://pci-ids.ucw.cz/v2.2/pci.ids\n");
while (my $line = <IN>) {
$line =~ s/\s+$//;