summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-06-26 18:16:00 +0200
committerLennart Poettering <lennart@poettering.net>2012-06-26 18:16:00 +0200
commit56a379a97e91380630653b85e5cb3612bf22ecf4 (patch)
tree25c800056275aeda978b774157e7533dc6ccf204
parent0127336c01198ef210882207d24257cb3752718b (diff)
man: document the readahead services
-rw-r--r--Makefile.am15
-rw-r--r--man/systemd-readahead-replay.service.xml113
-rw-r--r--units/systemd-readahead-collect.service.in1
-rw-r--r--units/systemd-readahead-done.service.in1
-rw-r--r--units/systemd-readahead-done.timer1
-rw-r--r--units/systemd-readahead-replay.service.in1
6 files changed, 131 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b8710b0c..a3d5a181b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2461,7 +2461,20 @@ EXTRA_DIST += \
MANPAGES += \
man/sd_readahead.3 \
- man/sd-readahead.7
+ man/sd-readahead.7 \
+ man/systemd-readahead-replay.service.8
+
+MANPAGES_ALIAS += \
+ man/systemd-readahead-collect.service.8 \
+ man/systemd-readahead-done.service.8 \
+ man/systemd-readahead-done.timer.8 \
+ man/systemd-readahead.8
+
+man/systemd-readahead-collect.service.8: man/systemd-readahead-replay.service.8
+man/systemd-readahead-done.service.8: man/systemd-readahead-replay.service.8
+man/systemd-readahead-done.timer.8: man/systemd-readahead-replay.service.8
+man/systemd-readahead.8: man/systemd-readahead-replay.service.8
+
endif
# ------------------------------------------------------------------------------
diff --git a/man/systemd-readahead-replay.service.xml b/man/systemd-readahead-replay.service.xml
new file mode 100644
index 000000000..e37b1a9ed
--- /dev/null
+++ b/man/systemd-readahead-replay.service.xml
@@ -0,0 +1,113 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="systemd-readahead-replay.service">
+
+ <refentryinfo>
+ <title>systemd-readahead-replay.service</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>systemd-readahead-replay.service</refentrytitle>
+ <manvolnum>8</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>systemd-readahead-replay.service</refname>
+ <refname>systemd-readahead-collect.service</refname>
+ <refname>systemd-readahead-done.service</refname>
+ <refname>systemd-readahead-done.timer</refname>
+ <refname>systemd-readahead</refname>
+ <refpurpose>systemd Disk Read Ahead Logic</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <para><filename>systemd-readahead-replay.service</filename></para>
+ <para><filename>systemd-readahead-collect.service</filename></para>
+ <para><filename>systemd-readahead-done.service</filename></para>
+ <para><filename>systemd-readahead-done.timer</filename></para>
+ <para><filename>/usr/lib/systemd/systemd-readahead</filename></para>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><filename>systemd-readahead-collect.service</filename>
+ is a service that collects disk usage patterns at boot
+ time. <filename>systemd-readahead-replay.service</filename>
+ is a service that replays this access data collected
+ at the subsequent boot. Since disks tend to be
+ magnitudes slower than RAM this is intended to improve
+ boot speeds by pre-loading early at boot all data on
+ disk that is known to be read for the complete boot
+ process.</para>
+
+ <para><filename>systemd-readahead-done.service</filename>
+ is executed a short while after boot completed and signals
+ <filename>systemd-readahead-collect.service</filename>
+ to end data collection. On this signal this service
+ will then sort the collected disk accesses and store
+ information about them disk in
+ <filename>/.readahead</filename>.</para>
+
+ <para>Normally, both
+ <filename>systemd-readahead-collect.service</filename>
+ and
+ <filename>systemd-readahead-replay.service</filename>
+ are activated at boot so that access patterns from the
+ preceeding boot are replayed and new data collected
+ for the subsequent boot. However, on read-only media
+ where the collected data cannot be stored it might
+ be a good idea to disable
+ <filename>systemd-readahead-collect.service</filename>.</para>
+
+ <para>On rotating media, when replaying disk accesses
+ at early boot
+ <filename>systemd-readahead-replay.service</filename>
+ will order read requests by their location on disk. On
+ non-rotating media, they will be ordered by their
+ original access timestamp. If the file system supports
+ it
+ <filename>systemd-readahead-collect.service</filename>
+ will also defragment and rearrange files on disk to
+ optimize subsequent boot times.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/units/systemd-readahead-collect.service.in b/units/systemd-readahead-collect.service.in
index c597cdc5a..d4b8e6793 100644
--- a/units/systemd-readahead-collect.service.in
+++ b/units/systemd-readahead-collect.service.in
@@ -7,6 +7,7 @@
[Unit]
Description=Collect Read-Ahead Data
+Documentation=man:systemd-readahead-replay.service(8)
DefaultDependencies=no
Wants=systemd-readahead-done.timer
Conflicts=shutdown.target
diff --git a/units/systemd-readahead-done.service.in b/units/systemd-readahead-done.service.in
index 893a819a7..c3b2ac506 100644
--- a/units/systemd-readahead-done.service.in
+++ b/units/systemd-readahead-done.service.in
@@ -7,6 +7,7 @@
[Unit]
Description=Stop Read-Ahead Data Collection
+Documentation=man:systemd-readahead-replay.service(8)
DefaultDependencies=no
Conflicts=shutdown.target
After=default.target
diff --git a/units/systemd-readahead-done.timer b/units/systemd-readahead-done.timer
index c64e6ea34..2828d198a 100644
--- a/units/systemd-readahead-done.timer
+++ b/units/systemd-readahead-done.timer
@@ -7,6 +7,7 @@
[Unit]
Description=Stop Read-Ahead Data Collection 10s After Completed Startup
+Documentation=man:systemd-readahead-replay.service(8)
DefaultDependencies=no
Conflicts=shutdown.target
After=default.target
diff --git a/units/systemd-readahead-replay.service.in b/units/systemd-readahead-replay.service.in
index eddf36df9..c64a533e4 100644
--- a/units/systemd-readahead-replay.service.in
+++ b/units/systemd-readahead-replay.service.in
@@ -7,6 +7,7 @@
[Unit]
Description=Replay Read-Ahead Data
+Documentation=man:systemd-readahead-replay.service(8)
DefaultDependencies=no
Conflicts=shutdown.target
Before=sysinit.target shutdown.target