summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Giokas <1007380@gmail.com>2013-07-29 14:12:15 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-08-02 10:43:55 -0400
commit67e654f83021a1b3ed55f4b75936d03591bf80c1 (patch)
tree754f187267ff3489616c928791f9694605f18e33
parent30fd4d1eb13a200ebcc852d3ce28f3cb30197957 (diff)
zsh_completion: Split out zsh _systemd-inhibit
-rw-r--r--Makefile.am3
-rw-r--r--shell-completion/zsh/_systemd30
-rw-r--r--shell-completion/zsh/_systemd-inhibit27
3 files changed, 30 insertions, 30 deletions
diff --git a/Makefile.am b/Makefile.am
index 24e4fa4bd..a4443fba9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3730,7 +3730,8 @@ dist_bashcompletion_DATA += \
shell-completion/bash/loginctl
dist_zshcompletion_DATA += \
- shell-completion/zsh/_loginctl
+ shell-completion/zsh/_loginctl \
+ shell-completion/zsh/_systemd-inhibit
systemd_inhibit_SOURCES = \
src/login/inhibit.c
diff --git a/shell-completion/zsh/_systemd b/shell-completion/zsh/_systemd
index bacf1795b..690872504 100644
--- a/shell-completion/zsh/_systemd
+++ b/shell-completion/zsh/_systemd
@@ -1,4 +1,4 @@
-#compdef systemd-analyze systemd-cat systemd-ask-password systemd-cgls systemd-cgtop systemd-delta systemd-detect-virt systemd-inhibit systemd-machine-id-setup systemd-notify systemd-tmpfiles systemd-tty-ask-password-agent machinectl
+#compdef systemd-analyze systemd-cat systemd-ask-password systemd-cgls systemd-cgtop systemd-delta systemd-detect-virt systemd-machine-id-setup systemd-notify systemd-tmpfiles systemd-tty-ask-password-agent machinectl
_ctls()
{
@@ -70,17 +70,6 @@ _ctls()
{-v,--vm}'[Only detect whether we are run in a VM]' \
{-q,--quiet}"[Don't output anything, just set return value]"
;;
- systemd-inhibit)
- _arguments \
- {-h,--help}'[Show this help]' \
- '--version[Show package version]' \
- '--what=[Operations to inhibit]:options:(shutdown sleep idle handle-power-key handle-suspend-key handle-hibernate-key handle-lid-switch)' \
- '--who=[A descriptive string who is inhibiting]' \
- '--why=[A descriptive string why is being inhibited]' \
- '--mode=[One of block or delay]' \
- '--list[List active inhibitors]' \
- '*:commands:_systemd_inhibit_command'
- ;;
systemd-machine-id-setup)
_arguments \
{-h,--help}'[Show this help]' \
@@ -136,23 +125,6 @@ _ctls()
esac
}
-_systemd_inhibit_command(){
- if (( CURRENT == 1 )); then
- compset -q
- _normal
- else
- local n=${words[(b:2:i)[^-]*]}
- if (( n <= CURRENT )); then
- compset -n $n
- _alternative \
- 'files:file:_files' \
- 'commands:command:_normal' && return 0
- fi
- _default
- fi
-
-}
-
_systemd_analyze_command(){
local -a _systemd_analyze_cmds
# Descriptions taken from systemd-analyze --help.
diff --git a/shell-completion/zsh/_systemd-inhibit b/shell-completion/zsh/_systemd-inhibit
new file mode 100644
index 000000000..7953455d4
--- /dev/null
+++ b/shell-completion/zsh/_systemd-inhibit
@@ -0,0 +1,27 @@
+#compdef systemd-inhibit
+
+_systemd_inhibit_command(){
+ if (( CURRENT == 1 )); then
+ compset -q
+ _normal
+ else
+ local n=${words[(b:2:i)[^-]*]}
+ if (( n <= CURRENT )); then
+ compset -n $n
+ _alternative \
+ 'files:file:_files' \
+ 'commands:command:_normal' && return 0
+ fi
+ _default
+ fi
+}
+
+_arguments \
+ {-h,--help}'[Show this help]' \
+ '--version[Show package version]' \
+ '--what=[Operations to inhibit]:options:(shutdown sleep idle handle-power-key handle-suspend-key handle-hibernate-key handle-lid-switch)' \
+ '--who=[A descriptive string who is inhibiting]' \
+ '--why=[A descriptive string why is being inhibited]' \
+ '--mode=[One of block or delay]' \
+ '--list[List active inhibitors]' \
+ '*:commands:_systemd_inhibit_command'