summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Hoyer <harald@redhat.com>2013-04-24 16:44:44 +0200
committerHarald Hoyer <harald@redhat.com>2013-04-24 16:49:33 +0200
commit83cb95b530ca5ae17bd9249774940840a4bbb667 (patch)
tree413bc65e3f0f2fc17a16d83c70351edd40b705a2
parent4470d8413749af1c29c3769c7159493ccd77e000 (diff)
add bash completion for systemd-analyze
-rw-r--r--Makefile.am1
-rw-r--r--shell-completion/bash/systemd-analyze70
2 files changed, 71 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e155d5ab..ff7022339 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -331,6 +331,7 @@ systemd_analyze_LDADD = \
dist_bashcompletion_DATA = \
shell-completion/bash/journalctl \
shell-completion/bash/systemctl \
+ shell-completion/bash/systemd-analyze \
shell-completion/bash/udevadm
dist_tmpfiles_DATA = \
diff --git a/shell-completion/bash/systemd-analyze b/shell-completion/bash/systemd-analyze
new file mode 100644
index 000000000..8a4453d40
--- /dev/null
+++ b/shell-completion/bash/systemd-analyze
@@ -0,0 +1,70 @@
+# systemd-analyze(1) completion -*- shell-script -*-
+#
+# This file is part of systemd.
+#
+# Copyright 2010 Ran Benita
+# Copyright 2013 Harald Hoyer
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+__contains_word () {
+ local word=$1; shift
+ for w in $*; do [[ $w = $word ]] && return 0; done
+ return 1
+}
+
+_systemd_analyze() {
+ local i verb comps
+ local cur=${COMP_WORDS[COMP_CWORD]} prev=${COMP_WORDS[COMP_CWORD-1]}
+ local OPTS='--help --version --system --user --from-pattern --to-pattern --order --require'
+
+ local -A VERBS=(
+ [NO_OPTION]='time blame plot'
+ [DOT]='dot'
+ )
+
+ _init_completion || return
+
+ for ((i=0; $i <= $COMP_CWORD; i++)); do
+ if __contains_word "${COMP_WORDS[i]}" ${VERBS[*]} &&
+ ! __contains_word "${COMP_WORDS[i-1]}" ${OPTS[ARG]}; then
+ verb=${COMP_WORDS[i]}
+ break
+ fi
+ done
+
+ if [[ -z $verb && $cur = -* ]]; then
+ COMPREPLY=( $(compgen -W '${OPTS[*]}' -- "$cur") )
+ return 0
+ fi
+
+ if [[ -z $verb ]]; then
+ comps=${VERBS[*]}
+
+ elif __contains_word "$verb" ${VERBS[NO_OPTION]}; then
+ if [[ $cur = -* ]]; then
+ comps='--help --version --system --user'
+ fi
+
+ elif __contains_word "$verb" ${VERBS[DOT]}; then
+ if [[ $cur = -* ]]; then
+ comps='--help --version --system --user --from-pattern --to-pattern --order --require'
+ fi
+ fi
+
+ COMPREPLY=( $(compgen -W '$comps' -- "$cur") )
+ return 0
+}
+
+complete -F _systemd_analyze systemd-analyze