summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAuke Kok <auke-jan.h.kok@intel.com>2012-07-05 17:20:02 -0700
committerLennart Poettering <lennart@poettering.net>2012-07-09 16:37:46 +0200
commit8401e9f91d65c3d8d49cf0d2e35d03146354e957 (patch)
treeee63f1a6634eb13c375f4505bd9a83d3e3331599
parent6aae0ed2d5915c28b27857fe0cf16e01b21a1882 (diff)
MeeGo: Remove build support for MeeGo distribution.
The MeeGo distribution is still a supported distribution, but will probably not see an updated version of systemd anymore. Most of the development is focussing on Tizen now, and the generic support for building --with-distro=other is more than adequate enough. This patch removes the support as a custom configuration build target in systemd. People who are still building this for the MeeGo distribution should build as "other" distro.
-rw-r--r--Makefile.am21
-rw-r--r--configure.ac9
-rw-r--r--src/core/hostname-setup.c4
-rw-r--r--src/core/locale-setup.c4
-rw-r--r--src/systemctl/systemctl.c2
-rw-r--r--src/vconsole/vconsole-setup.c2
-rw-r--r--units/rescue.service.m4.in5
7 files changed, 8 insertions, 39 deletions
diff --git a/Makefile.am b/Makefile.am
index 6cf776031..70b8b091e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -173,12 +173,6 @@ AM_CPPFLAGS += \
-DKBD_SETFONT=\"/bin/setfont\" \
-DDEFAULT_FONT=\"LatArCyrHeb-16\"
else
-if TARGET_MEEGO
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/bin/loadkeys\" \
- -DKBD_SETFONT=\"/bin/setfont\" \
- -DDEFAULT_FONT=\"LatArCyrHeb-16\"
-else
if TARGET_ANGSTROM
AM_CPPFLAGS += \
-DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
@@ -201,7 +195,6 @@ endif
endif
endif
endif
-endif
# ------------------------------------------------------------------------------
rootbin_PROGRAMS = \
@@ -3396,20 +3389,6 @@ systemd-install-data-hook:
( cd $(DESTDIR)$(dbussessionservicedir) && \
rm -f org.freedesktop.systemd1.service && \
$(LN_S) ../system-services/org.freedesktop.systemd1.service org.freedesktop.systemd1.service )
-if TARGET_MEEGO
- $(MKDIR_P) -m 0755 $(DESTDIR)$(systemunitdir)/final.target.wants
- ( cd $(DESTDIR)$(systemunitdir)/multi-user.target.wants && \
- rm -f network.target && \
- $(LN_S) $(systemunitdir)/network.target network.target )
- ( cd $(DESTDIR)$(pkgsysconfdir)/system/sysinit.target.wants && \
- rm -f * )
- ( cd $(DESTDIR)$(pkgsysconfdir)/system/local-fs.target.wants && \
- rm -f * )
- ( cd $(DESTDIR)$(pkgsysconfdir)/system/multi-user.target.wants && \
- rm -f * )
- ( cd $(DESTDIR)$(pkgsysconfdir)/system/getty.target.wants && \
- rm -f * )
-endif
if TARGET_FEDORA
( cd $(DESTDIR)$(systemunitdir) && \
diff --git a/configure.ac b/configure.ac
index dfa34c8dd..bb60ecc16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -500,7 +500,7 @@ AM_CONDITIONAL(ENABLE_MANPAGES, [test "$have_manpages" = "yes"])
AC_PATH_PROG([XSLTPROC], [xsltproc])
AM_CONDITIONAL(HAVE_XSLTPROC, test x"$XSLTPROC" != x)
-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO],[Specify the distribution to target: One of fedora, suse, debian, ubuntu, arch, gentoo, slackware, altlinux, mandriva, meego, mageia, angstrom or other]))
+AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO],[Specify the distribution to target: One of fedora, suse, debian, ubuntu, arch, gentoo, slackware, altlinux, mandriva, mageia, angstrom or other]))
if test "z$with_distro" = "z"; then
if test "$cross_compiling" = yes; then
AC_MSG_WARN([Target distribution cannot be reliably detected when cross-compiling. You should specify it with --with-distro (see $0 --help for recognized distros)])
@@ -573,12 +573,6 @@ case $with_distro in
AC_DEFINE(TARGET_MANDRIVA, [], [Target is Mandriva])
M4_DEFINES=-DTARGET_MANDRIVA=1
;;
- meego)
- SYSTEM_SYSVINIT_PATH=
- SYSTEM_SYSVRCND_PATH=
- AC_DEFINE(TARGET_MEEGO, [], [Target is MeeGo])
- M4_DEFINES=-DTARGET_MEEGO=1
- ;;
angstrom)
SYSTEM_SYSVRCND_PATH=/etc
AC_DEFINE(TARGET_ANGSTROM, [], [Target is Ångström])
@@ -639,7 +633,6 @@ AM_CONDITIONAL(TARGET_SLACKWARE, test x"$with_distro" = xslackware)
AM_CONDITIONAL(TARGET_FRUGALWARE, test x"$with_distro" = xfrugalware)
AM_CONDITIONAL(TARGET_ALTLINUX, test x"$with_distro" = xaltlinux)
AM_CONDITIONAL(TARGET_MANDRIVA, test x"$with_distro" = xmandriva)
-AM_CONDITIONAL(TARGET_MEEGO, test x"$with_distro" = xmeego)
AM_CONDITIONAL(TARGET_ANGSTROM, test x"$with_distro" = xangstrom)
AM_CONDITIONAL(TARGET_MAGEIA, test x"$with_distro" = xmageia)
diff --git a/src/core/hostname-setup.c b/src/core/hostname-setup.c
index e3ea5fe76..25ea09c73 100644
--- a/src/core/hostname-setup.c
+++ b/src/core/hostname-setup.c
@@ -30,7 +30,7 @@
#include "util.h"
#include "log.h"
-#if defined(TARGET_FEDORA) || defined(TARGET_ALTLINUX) || defined(TARGET_MANDRIVA) || defined(TARGET_MEEGO) || defined(TARGET_MAGEIA)
+#if defined(TARGET_FEDORA) || defined(TARGET_ALTLINUX) || defined(TARGET_MANDRIVA) || defined(TARGET_MAGEIA)
#define FILENAME "/etc/sysconfig/network"
#elif defined(TARGET_SUSE) || defined(TARGET_SLACKWARE)
#define FILENAME "/etc/HOSTNAME"
@@ -65,7 +65,7 @@ static int read_and_strip_hostname(const char *path, char **hn) {
static int read_distro_hostname(char **hn) {
-#if defined(TARGET_FEDORA) || defined(TARGET_ARCH) || defined(TARGET_GENTOO) || defined(TARGET_ALTLINUX) || defined(TARGET_MANDRIVA) || defined(TARGET_MEEGO) || defined(TARGET_MAGEIA)
+#if defined(TARGET_FEDORA) || defined(TARGET_ARCH) || defined(TARGET_GENTOO) || defined(TARGET_ALTLINUX) || defined(TARGET_MANDRIVA) || defined(TARGET_MAGEIA)
int r;
FILE *f;
diff --git a/src/core/locale-setup.c b/src/core/locale-setup.c
index aab454e83..25eb13474 100644
--- a/src/core/locale-setup.c
+++ b/src/core/locale-setup.c
@@ -74,7 +74,7 @@ int locale_setup(void) {
if (detect_container(NULL) <= 0)
if ((r = parse_env_file("/proc/cmdline", WHITESPACE,
-#if defined(TARGET_FEDORA) || defined(TARGET_MEEGO)
+#if defined(TARGET_FEDORA)
"LANG", &variables[VARIABLE_LANG],
#endif
"locale.LANG", &variables[VARIABLE_LANG],
@@ -121,7 +121,7 @@ int locale_setup(void) {
log_warning("Failed to read /etc/locale.conf: %s", strerror(-r));
}
-#if defined(TARGET_FEDORA) || defined(TARGET_ALTLINUX) || defined(TARGET_MEEGO)
+#if defined(TARGET_FEDORA) || defined(TARGET_ALTLINUX)
if (r <= 0 &&
(r = parse_env_file("/etc/sysconfig/i18n", NEWLINE,
"LANG", &variables[VARIABLE_LANG],
diff --git a/src/systemctl/systemctl.c b/src/systemctl/systemctl.c
index 8279f08d5..c89920bcc 100644
--- a/src/systemctl/systemctl.c
+++ b/src/systemctl/systemctl.c
@@ -3921,7 +3921,7 @@ finish:
static int enable_sysv_units(char **args) {
int r = 0;
-#if defined (HAVE_SYSV_COMPAT) && (defined(TARGET_FEDORA) || defined(TARGET_MANDRIVA) || defined(TARGET_SUSE) || defined(TARGET_MEEGO) || defined(TARGET_ALTLINUX) || defined(TARGET_MAGEIA))
+#if defined (HAVE_SYSV_COMPAT) && (defined(TARGET_FEDORA) || defined(TARGET_MANDRIVA) || defined(TARGET_SUSE) || defined(TARGET_ALTLINUX) || defined(TARGET_MAGEIA))
const char *verb = args[0];
unsigned f = 1, t = 1;
LookupPaths paths;
diff --git a/src/vconsole/vconsole-setup.c b/src/vconsole/vconsole-setup.c
index aa5fa1852..7679d446e 100644
--- a/src/vconsole/vconsole-setup.c
+++ b/src/vconsole/vconsole-setup.c
@@ -253,7 +253,7 @@ int main(int argc, char **argv) {
}
if (r <= 0) {
-#if defined(TARGET_FEDORA) || defined(TARGET_MEEGO)
+#if defined(TARGET_FEDORA)
r = parse_env_file("/etc/sysconfig/i18n", NEWLINE,
"SYSFONT", &vc_font,
"SYSFONTACM", &vc_font_map,
diff --git a/units/rescue.service.m4.in b/units/rescue.service.m4.in
index 9d09062b1..2c6e0ec67 100644
--- a/units/rescue.service.m4.in
+++ b/units/rescue.service.m4.in
@@ -27,10 +27,7 @@ ExecStart=-/bin/bash -c "exec ${SINGLE}"',
m4_ifdef(`TARGET_MAGEIA',
`EnvironmentFile=/etc/sysconfig/init
ExecStart=-/bin/bash -c "exec ${SINGLE}"',
-m4_ifdef(`TARGET_MEEGO',
-`EnvironmentFile=/etc/sysconfig/init
-ExecStart=-/bin/bash -c "exec ${SINGLE}"',
-`ExecStart=-/sbin/sulogin'))))
+`ExecStart=-/sbin/sulogin')))
ExecStopPost=-@SYSTEMCTL@ --fail --no-block default
Type=idle
StandardInput=tty-force