summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-12 17:22:19 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-12 23:57:46 -0400
commita0b8045be2206aec3558fdb11dad052cb590bf74 (patch)
treec4bc7fb6403788617850c11ea649f062b16e34f0
parentee465038ce86bd3a0f21d5e2723393ff9d78855d (diff)
man: strip the comments in man page headers
They contained the date, which creates a problem with multiarch packages, since the generated file would be different each time.
-rw-r--r--Makefile.am12
-rw-r--r--man/custom-man.xsl31
2 files changed, 37 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 96262ec06..25e0ab430 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3686,25 +3686,25 @@ XSLTPROC_FLAGS = \
XSLTPROC_PROCESS_MAN = \
$(AM_V_XSLT)$(MKDIR_P) $(dir $@) && \
- $(XSLTPROC) -o $@ $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+ $(XSLTPROC) -o $@ $(XSLTPROC_FLAGS) $(srcdir)/man/custom-man.xsl $<
XSLTPROC_PROCESS_HTML = \
$(AM_V_XSLT)$(MKDIR_P) $(dir $@) && \
$(XSLTPROC) -o $@ $(XSLTPROC_FLAGS) $(srcdir)/man/custom-html.xsl $<
-man/%.1: man/%.xml
+man/%.1: man/%.xml man/custom-man.xsl
$(XSLTPROC_PROCESS_MAN)
-man/%.3: man/%.xml
+man/%.3: man/%.xml man/custom-man.xsl
$(XSLTPROC_PROCESS_MAN)
-man/%.5: man/%.xml
+man/%.5: man/%.xml man/custom-man.xsl
$(XSLTPROC_PROCESS_MAN)
-man/%.7: man/%.xml
+man/%.7: man/%.xml man/custom-man.xsl
$(XSLTPROC_PROCESS_MAN)
-man/%.8: man/%.xml
+man/%.8: man/%.xml man/custom-man.xsl
$(XSLTPROC_PROCESS_MAN)
man/%.html: man/%.xml man/custom-html.xsl
diff --git a/man/custom-man.xsl b/man/custom-man.xsl
new file mode 100644
index 000000000..4d9d08e00
--- /dev/null
+++ b/man/custom-man.xsl
@@ -0,0 +1,31 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2013 Zbigniew Jędrzejewski-Szmek
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
+ xmlns:exsl="http://exslt.org/common"
+ extension-element-prefixes="exsl"
+ version="1.0">
+
+<xsl:import href="http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"/>
+
+<xsl:template name="top.comment" />
+
+</xsl:stylesheet>