summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-07-13 22:55:52 +0200
committerLennart Poettering <lennart@poettering.net>2012-07-13 22:55:52 +0200
commita4023a43d0312568f0b81b39b4bc6fd9b64880eb (patch)
treee7d2892f51e574edcad348000657b677029dca92
parent9a1d54166307bbe51b33018a93e77688311eab14 (diff)
man: Split sd_randomize(3) from sd_id128_get_{machine,boot}(3)
They have too little to do with each other...
-rw-r--r--Makefile.am4
-rw-r--r--man/sd-id128.xml6
-rw-r--r--man/sd_id128_get_machine.xml138
-rw-r--r--man/sd_id128_randomize.xml55
4 files changed, 152 insertions, 51 deletions
diff --git a/Makefile.am b/Makefile.am
index 3dfe8a25e..3dda9b85f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -498,6 +498,7 @@ MANPAGES = \
man/sd-id128.3 \
man/sd_id128_to_string.3 \
man/sd_id128_randomize.3 \
+ man/sd_id128_get_machine.3 \
man/sd-journal.3 \
man/sd_journal_print.3 \
man/sd_journal_stream_fd.3 \
@@ -604,8 +605,7 @@ man/SD_ID128_FORMAT_STR.3: man/sd-id128.3
man/SD_ID128_FORMAT_VAL.3: man/sd-id128.3
man/sd_id128_equal.3: man/sd-id128.3
man/sd_id128_from_string.3: man/sd_id128_to_string.3
-man/sd_id128_get_machine.3: man/sd_id128_randomize.3
-man/sd_id128_get_boot.3: man/sd_id128_randomize.3
+man/sd_id128_get_boot.3: man/sd_id128_get_machine.3
man/sd_journal_printv.3: man/sd_journal_print.3
man/sd_journal_send.3: man/sd_journal_print.3
man/sd_journal_sendv.3: man/sd_journal_print.3
diff --git a/man/sd-id128.xml b/man/sd-id128.xml
index d3f995e00..d45339043 100644
--- a/man/sd-id128.xml
+++ b/man/sd-id128.xml
@@ -78,8 +78,9 @@
</para>
<para>See
- <citerefentry><refentrytitle>sd_id128_to_string</refentrytitle><manvolnum>3</manvolnum></citerefentry> and
- <citerefentry><refentrytitle>sd_id128_randomize</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ <citerefentry><refentrytitle>sd_id128_to_string</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_id128_randomize</refentrytitle><manvolnum>3</manvolnum></citerefentry> and
+ <citerefentry><refentrytitle>sd_id128_get_machine</refentrytitle><manvolnum>3</manvolnum></citerefentry>
for more information about the implemented
functions.</para>
@@ -157,6 +158,7 @@
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>sd_id128_to_string</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
<citerefentry><refentrytitle>sd_id128_randomize</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_id128_get_machine</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
<citerefentry><refentrytitle>printf</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
<citerefentry><refentrytitle>journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>sd-journal</refentrytitle><manvolnum>7</manvolnum></citerefentry>,
diff --git a/man/sd_id128_get_machine.xml b/man/sd_id128_get_machine.xml
new file mode 100644
index 000000000..039c1dd64
--- /dev/null
+++ b/man/sd_id128_get_machine.xml
@@ -0,0 +1,138 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2012 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="sd_id128_get_machine">
+
+ <refentryinfo>
+ <title>sd_id128_get_machine</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>sd_id128_get_machine</refentrytitle>
+ <manvolnum>3</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>sd_id128_get_machine</refname>
+ <refname>sd_id128_get_boot</refname>
+ <refpurpose>Retrieve 128 bit IDs</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <funcsynopsis>
+ <funcsynopsisinfo>#include &lt;systemd/sd-id128.h&gt;</funcsynopsisinfo>
+
+ <funcprototype>
+ <funcdef>int <function>sd_id128_get_machine</function></funcdef>
+ <paramdef>sd_id128_t* <parameter>ret</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef>int <function>sd_id128_get_boot</function></funcdef>
+ <paramdef>sd_id128_t* <parameter>ret</parameter></paramdef>
+ </funcprototype>
+
+ </funcsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><function>sd_id128_get_machine()</function>
+ returns the machine ID of the executing host. This
+ reads and parses the
+ <citerefentry><refentrytitle>machine-id</refentrytitle><manvolnum>5</manvolnum></citerefentry>
+ file. This function caches the machine ID internally
+ to make retrieving the machine ID a cheap
+ operation.</para>
+
+ <para><function>sd_id128_get_boot()</function> returns
+ the boot ID of the executing kernel. This reads and
+ parses the
+ <filename>/proc/sys/kernel/random/boot_id</filename>
+ file exposed by the kernel. It is randomly generated
+ early at boot and is unique for every running kernel
+ instance. See
+ <citerefentry><refentrytitle>random</refentrytitle><manvolnum>4</manvolnum></citerefentry>
+ for more information. This function also internally
+ caches the returned ID to make this call a cheap
+ operation.</para>
+
+ <para>Note that
+ <function>sd_id128_get_boot()</function> always returns
+ a UUID v4 compatible
+ ID. <function>sd_id128_get_machine()</function> will
+ also return a UUID v4 compatible ID on new
+ installations, but might not on older. It is possible
+ to convert the machine ID into an UUID v4 compatible
+ one. For more information see
+ <citerefentry><refentrytitle>machine-id</refentrytitle><manvolnum>5</manvolnum></citerefentry>.</para>
+
+ <para>For more information about the
+ <literal>sd_id128_t</literal> type see
+ <citerefentry><refentrytitle>sd-id128</refentrytitle><manvolnum>3</manvolnum></citerefentry>.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Return Value</title>
+
+ <para>The two calls return 0 on success (in which
+ case <parameter>ret</parameter> is filled in), or a
+ negative errno-style error code.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Notes</title>
+
+ <para>The <function>sd_id128_get_machine()</function>
+ and <function>sd_id128_get_boot()</function>
+ interfaces are available as shared library, which can
+ be compiled and linked to with the
+ <literal>libsystemd-id128</literal>
+ <citerefentry><refentrytitle>pkg-config</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+ file.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd-id128</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>machine-id</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>random</refentrytitle><manvolnum>4</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_id128_randomize</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/man/sd_id128_randomize.xml b/man/sd_id128_randomize.xml
index cb3741966..be74937dd 100644
--- a/man/sd_id128_randomize.xml
+++ b/man/sd_id128_randomize.xml
@@ -44,9 +44,7 @@
<refnamediv>
<refname>sd_id128_randomize</refname>
- <refname>sd_id128_get_machine</refname>
- <refname>sd_id128_get_boot</refname>
- <refpurpose>Generate or retrieve 128 bit IDs</refpurpose>
+ <refpurpose>Generate 128 bit IDs</refpurpose>
</refnamediv>
<refsynopsisdiv>
@@ -58,16 +56,6 @@
<paramdef>sd_id128_t* <parameter>ret</parameter></paramdef>
</funcprototype>
- <funcprototype>
- <funcdef>int <function>sd_id128_get_machine</function></funcdef>
- <paramdef>sd_id128_t* <parameter>ret</parameter></paramdef>
- </funcprototype>
-
- <funcprototype>
- <funcdef>int <function>sd_id128_get_boot</function></funcdef>
- <paramdef>sd_id128_t* <parameter>ret</parameter></paramdef>
- </funcprototype>
-
</funcsynopsis>
</refsynopsisdiv>
@@ -81,36 +69,10 @@
<filename>/dev/urandom</filename> kernel random number
generator.</para>
- <para><function>sd_id128_get_machine()</function>
- returns the machine ID of the executing host. This
- reads and parses the
- <citerefentry><refentrytitle>machine-id</refentrytitle><manvolnum>5</manvolnum></citerefentry>
- file. This function caches the machine ID internally
- to make retrieving the machine ID a cheap
- operation.</para>
-
- <para><function>sd_id128_get_boot()</function> returns
- the boot ID of the executing kernel. This reads and
- parses the
- <filename>/proc/sys/kernel/random/boot_id</filename>
- file exposed by the kernel. It is randomly generated
- early at boot and is unique for every running kernel
- instance. See
- <citerefentry><refentrytitle>random</refentrytitle><manvolnum>4</manvolnum></citerefentry>
- for more information. This function also internally
- caches the returned ID to make this call a cheap
- operation.</para>
-
<para>Note that
- <function>sd_id128_randomize()</function> and
- <function>sd_id128_get_boot()</function> always return
+ <function>sd_id128_randomize()</function> always returns
a UUID v4 compatible
- ID. <function>sd_id128_get_machine()</function> will
- also return a UUID v4 compatible ID on new
- installations, but might not on older. It is possible
- to convert the machine ID into an UUID v4 compatible
- one. For more information see
- <citerefentry><refentrytitle>machine-id</refentrytitle><manvolnum>5</manvolnum></citerefentry>.</para>
+ ID.</para>
<para>For more information about the
<literal>sd_id128_t</literal> type see
@@ -125,7 +87,7 @@
<refsect1>
<title>Return Value</title>
- <para>The three calls return 0 on success (in which
+ <para>The call returns 0 on success (in which
case <parameter>ret</parameter> is filled in), or a
negative errno-style error code.</para>
</refsect1>
@@ -133,10 +95,8 @@
<refsect1>
<title>Notes</title>
- <para>The <function>sd_id128_randomize()</function>,
- <function>sd_id128_get_machine()</function> and
- <function>sd_id128_get_boot()</function> interfaces
- are available as shared library, which can be compiled
+ <para>The <function>sd_id128_randomize()</function> interface
+ is available as shared library, which can be compiled
and linked to with the
<literal>libsystemd-id128</literal>
<citerefentry><refentrytitle>pkg-config</refentrytitle><manvolnum>1</manvolnum></citerefentry>
@@ -150,7 +110,8 @@
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>sd-id128</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
<citerefentry><refentrytitle>machine-id</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
- <citerefentry><refentrytitle>random</refentrytitle><manvolnum>4</manvolnum></citerefentry>
+ <citerefentry><refentrytitle>random</refentrytitle><manvolnum>4</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_id128_get_machine</refentrytitle><manvolnum>3</manvolnum></citerefentry>
</para>
</refsect1>