summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@joshtriplett.org>2014-11-29 01:07:21 -0800
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-11-29 13:55:32 -0500
commitbe795898c0d2fa21e3389b89793dcd45c47f8b9f (patch)
tree3e92c674e76a94e8b7e9b11b487ca0b543a3f698
parentf2dacc96b25528ca1b0caca6364a69d656cf1569 (diff)
timesyncd: Support timesyncd.conf.d directories in the usual search paths
-rw-r--r--Makefile-man.am7
-rw-r--r--man/timesyncd.conf.xml17
-rw-r--r--src/timesync/timesyncd-conf.c9
-rw-r--r--src/timesync/timesyncd.conf.in3
4 files changed, 25 insertions, 11 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 36e0ebbb6..e3c43b269 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -1244,11 +1244,16 @@ MANPAGES += \
man/systemd-timesyncd.service.8 \
man/timesyncd.conf.5
MANPAGES_ALIAS += \
- man/systemd-timesyncd.8
+ man/systemd-timesyncd.8 \
+ man/timesyncd.conf.d.5
man/systemd-timesyncd.8: man/systemd-timesyncd.service.8
+man/timesyncd.conf.d.5: man/timesyncd.conf.5
man/systemd-timesyncd.html: man/systemd-timesyncd.service.html
$(html-alias)
+man/timesyncd.conf.d.html: man/timesyncd.conf.html
+ $(html-alias)
+
endif
if ENABLE_VCONSOLE
diff --git a/man/timesyncd.conf.xml b/man/timesyncd.conf.xml
index aeb7182f9..1a56c2c5c 100644
--- a/man/timesyncd.conf.xml
+++ b/man/timesyncd.conf.xml
@@ -22,7 +22,8 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="timesyncd.conf" conditional='ENABLE_TIMESYNCD'>
+<refentry id="timesyncd.conf" conditional='ENABLE_TIMESYNCD'
+ xmlns:xi="http://www.w3.org/2001/XInclude">
<refentryinfo>
<title>timesyncd.conf</title>
<productname>systemd</productname>
@@ -44,24 +45,28 @@
<refnamediv>
<refname>timesyncd.conf</refname>
- <refpurpose>Network Time Synchronization configuration file</refpurpose>
+ <refname>timesyncd.conf.d</refname>
+ <refpurpose>Network Time Synchronization configuration files</refpurpose>
</refnamediv>
<refsynopsisdiv>
<para><filename>/etc/systemd/timesyncd.conf</filename></para>
+ <para><filename>/etc/systemd/timesyncd.conf.d/*.conf</filename></para>
+ <para><filename>/run/systemd/timesyncd.conf.d/*.conf</filename></para>
+ <para><filename>/usr/lib/systemd/timesyncd.conf.d/*.conf</filename></para>
</refsynopsisdiv>
<refsect1>
<title>Description</title>
- <para>When starting, systemd-timesyncd will read the
- configuration file
- <filename>timesyncd.conf</filename>. This
- configuration file controls NTP network time
+ <para>These configuration files control NTP network time
synchronization.</para>
</refsect1>
+ <xi:include href="standard-conf.xml" xpointer="confd" />
+ <xi:include href="standard-conf.xml" xpointer="conf" />
+
<refsect1>
<title>Options</title>
diff --git a/src/timesync/timesyncd-conf.c b/src/timesync/timesyncd-conf.c
index 4c2dcdb62..be1f4bb15 100644
--- a/src/timesync/timesyncd-conf.c
+++ b/src/timesync/timesyncd-conf.c
@@ -97,8 +97,9 @@ int config_parse_servers(
int manager_parse_config_file(Manager *m) {
assert(m);
- return config_parse(NULL, "/etc/systemd/timesyncd.conf", NULL,
- "Time\0",
- config_item_perf_lookup, timesyncd_gperf_lookup,
- false, false, true, m);
+ return config_parse_many("/etc/systemd/timesyncd.conf",
+ CONF_DIRS_NULSTR("systemd/timesyncd.conf"),
+ "Time\0",
+ config_item_perf_lookup, timesyncd_gperf_lookup,
+ false, m);
}
diff --git a/src/timesync/timesyncd.conf.in b/src/timesync/timesyncd.conf.in
index 674a51dbd..fc3c6c49c 100644
--- a/src/timesync/timesyncd.conf.in
+++ b/src/timesync/timesyncd.conf.in
@@ -5,6 +5,9 @@
# the Free Software Foundation; either version 2.1 of the License, or
# (at your option) any later version.
#
+# You can override the directives in this file by creating files in
+# /etc/systemd/timesyncd.conf.d/*.conf.
+#
# See timesyncd.conf(5) for details
[Time]