summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-19 15:47:35 +0200
committerAndy Wingo <wingo@pobox.com>2015-04-19 15:47:35 +0200
commitc1bf4024a16291b4371333db2b86bd1e1d227e13 (patch)
tree41c5a3cccb38e012ba1b544cd067f03bee830d21
parent3b6314feba82f4924281b34b3c459297c0c57f16 (diff)
Remove gnutls check
-rw-r--r--configure.ac13
-rw-r--r--src/shared/build.h7
2 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 18f2669e0..6924e01a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -486,18 +486,6 @@ fi
AM_CONDITIONAL([HAVE_SMACK], [test "x$have_smack" = "xyes"])
# ------------------------------------------------------------------------------
-have_gnutls=no
-AC_ARG_ENABLE(gnutls, AS_HELP_STRING([--disable-gnutls], [disable gnutls support]))
-if test "x$enable_gnutls" != "xno"; then
- PKG_CHECK_MODULES(GNUTLS, [gnutls >= 3.1.4],
- [AC_DEFINE(HAVE_GNUTLS, 1, [Define if gnutls is available]) have_gnutls=yes], have_gnutls=no)
- if test "x$have_gnutls" = xno -a "x$enable_gnutls" = xyes; then
- AC_MSG_ERROR([*** gnutls support requested but libraries not found])
- fi
-fi
-AM_CONDITIONAL(HAVE_GNUTLS, [test "$have_gnutls" = "yes"])
-
-# ------------------------------------------------------------------------------
have_libcurl=no
AC_ARG_ENABLE(libcurl, AS_HELP_STRING([--disable-libcurl], [disable libcurl support]))
if test "x$enable_libcurl" != "xno"; then
@@ -1067,7 +1055,6 @@ AC_MSG_RESULT([
SECCOMP: ${have_seccomp}
SMACK: ${have_smack}
ACL: ${have_acl}
- GNUTLS: ${have_gnutls}
libcurl: ${have_libcurl}
libidn: ${have_libidn}
binfmt: ${have_binfmt}
diff --git a/src/shared/build.h b/src/shared/build.h
index cdb6bdfad..42b34933c 100644
--- a/src/shared/build.h
+++ b/src/shared/build.h
@@ -45,12 +45,6 @@
#define _SMACK_FEATURE_ "-SMACK"
#endif
-#ifdef HAVE_GNUTLS
-#define _GNUTLS_FEATURE_ "+GNUTLS"
-#else
-#define _GNUTLS_FEATURE_ "-GNUTLS"
-#endif
-
#ifdef HAVE_ACL
#define _ACL_FEATURE_ "+ACL"
#else
@@ -80,7 +74,6 @@
_SELINUX_FEATURE_ " " \
_APPARMOR_FEATURE_ " " \
_SMACK_FEATURE_ " " \
- _GNUTLS_FEATURE_ " " \
_ACL_FEATURE_ " " \
_SECCOMP_FEATURE_ " " \
_BLKID_FEATURE_ " " \