summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-12-03 04:27:03 +0100
committerLennart Poettering <lennart@poettering.net>2013-12-03 04:28:02 +0100
commitcde360cd5de39fb910ebfcc0839f8c3fa465ef8b (patch)
tree96e835d318cda8bfffc8956c1300be19d5c1eece
parenta6e9f2b911ce13618b3f0fcd3d23ecb6471e07ba (diff)
units: ship busname units for the bus activated services we ship
-rw-r--r--Makefile.am35
-rw-r--r--units/org.freedesktop.hostname1.busname14
-rw-r--r--units/org.freedesktop.locale1.busname14
-rw-r--r--units/org.freedesktop.login1.busname15
-rw-r--r--units/org.freedesktop.machine1.busname14
-rw-r--r--units/org.freedesktop.timedate1.busname14
6 files changed, 103 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f238d8520..7c6241440 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -219,6 +219,7 @@ LOCAL_FS_TARGET_WANTS =
MULTI_USER_TARGET_WANTS =
SYSINIT_TARGET_WANTS =
SOCKETS_TARGET_WANTS =
+BUSNAMES_TARGET_WANTS =
TIMERS_TARGET_WANTS =
SYSTEM_UNIT_ALIASES =
@@ -237,6 +238,7 @@ install-target-wants-hook:
what="$(MULTI_USER_TARGET_WANTS)" && wants=multi-user.target && $(add-wants)
what="$(SYSINIT_TARGET_WANTS)" && wants=sysinit.target && $(add-wants)
what="$(SOCKETS_TARGET_WANTS)" && wants=sockets.target && $(add-wants)
+ what="$(BUSNAMES_TARGET_WANTS)" && wants=busnames.target && $(add-wants)
what="$(TIMERS_TARGET_WANTS)" && wants=timers.target && $(add-wants)
what="$(SLICES_TARGET_WANTS)" && wants=slices.target && $(add-wants)
@@ -3615,6 +3617,9 @@ rootlibexec_PROGRAMS += \
nodist_systemunit_DATA += \
units/systemd-hostnamed.service
+dist_systemunit_DATA += \
+ units/org.freedesktop.hostname1.busname
+
dist_dbuspolicy_DATA += \
src/hostname/org.freedesktop.hostname1.conf
@@ -3627,6 +3632,9 @@ polkitpolicy_files += \
SYSTEM_UNIT_ALIASES += \
systemd-hostnamed.service dbus-org.freedesktop.hostname1.service
+BUSNAMES_TARGET_WANTS += \
+ org.freedesktop.hostname1.busname
+
hostnamectl_SOURCES = \
src/hostname/hostnamectl.c
@@ -3668,6 +3676,9 @@ systemd_localed_LDADD = \
nodist_systemunit_DATA += \
units/systemd-localed.service
+dist_systemunit_DATA += \
+ units/org.freedesktop.locale1.busname
+
rootlibexec_PROGRAMS += \
systemd-localed
@@ -3683,6 +3694,9 @@ polkitpolicy_files += \
SYSTEM_UNIT_ALIASES += \
systemd-localed.service dbus-org.freedesktop.locale1.service
+BUSNAMES_TARGET_WANTS += \
+ org.freedesktop.locale1.busname
+
dist_pkgdata_DATA += \
src/locale/kbd-model-map
@@ -3742,6 +3756,9 @@ dist_dbuspolicy_DATA += \
nodist_systemunit_DATA += \
units/systemd-timedated.service
+dist_systemunit_DATA += \
+ units/org.freedesktop.timedate1.busname
+
polkitpolicy_files += \
src/timedate/org.freedesktop.timedate1.policy
@@ -3752,6 +3769,9 @@ INSTALL_DIRS += \
SYSTEM_UNIT_ALIASES += \
systemd-timedated.service dbus-org.freedesktop.timedate1.service
+BUSNAMES_TARGET_WANTS += \
+ org.freedesktop.timedate1.busname
+
timedatectl_SOURCES = \
src/timedate/timedatectl.c
@@ -3850,7 +3870,8 @@ nodist_systemunit_DATA += \
units/systemd-machined.service
dist_systemunit_DATA += \
- units/machine.slice
+ units/machine.slice \
+ units/org.freedesktop.machine1.busname
dist_dbussystemservice_DATA += \
src/machine/org.freedesktop.machine1.service
@@ -3864,6 +3885,9 @@ dist_zshcompletion_DATA += \
SYSTEM_UNIT_ALIASES += \
systemd-machined.service dbus-org.freedesktop.machine1.service
+BUSNAMES_TARGET_WANTS += \
+ org.freedesktop.machine1.busname
+
EXTRA_DIST += \
units/systemd-machined.service.in
@@ -4137,7 +4161,8 @@ nodist_systemunit_DATA += \
units/systemd-user-sessions.service
dist_systemunit_DATA += \
- units/user.slice
+ units/user.slice \
+ units/org.freedesktop.login1.busname
dist_dbussystemservice_DATA += \
src/login/org.freedesktop.login1.service
@@ -4173,6 +4198,9 @@ MULTI_USER_TARGET_WANTS += \
SYSTEM_UNIT_ALIASES += \
systemd-logind.service dbus-org.freedesktop.login1.service
+BUSNAMES_TARGET_WANTS += \
+ org.freedesktop.login1.busname
+
if ENABLE_MULTI_SEAT_X
systemd_multi_seat_x_SOURCES = \
@@ -4675,7 +4703,8 @@ DISTCHECK_CONFIGURE_FLAGS = \
--with-pamlibdir=$$dc_install_base/$(pamlibdir) \
--with-pamconfdir=$$dc_install_base/$(pamconfdir) \
--with-rootprefix=$$dc_install_base \
- --disable-split-usr
+ --disable-split-usr \
+ --enable-kdbus
if HAVE_SYSV_COMPAT
DISTCHECK_CONFIGURE_FLAGS += \
diff --git a/units/org.freedesktop.hostname1.busname b/units/org.freedesktop.hostname1.busname
new file mode 100644
index 000000000..fb75a0791
--- /dev/null
+++ b/units/org.freedesktop.hostname1.busname
@@ -0,0 +1,14 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Hostname Service Bus Name
+Documentation=man:systemd-hostnamed.service(8) man:hostname(5) man:machine-info(5)
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/hostnamed
+
+[BusName]
+Service=systemd-hostnamed.service
diff --git a/units/org.freedesktop.locale1.busname b/units/org.freedesktop.locale1.busname
new file mode 100644
index 000000000..5af2ee7b0
--- /dev/null
+++ b/units/org.freedesktop.locale1.busname
@@ -0,0 +1,14 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Locale Service Bus Name
+Documentation=man:systemd-localed.service(8) man:locale.conf(5) man:vconsole.conf(5)
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/localed
+
+[BusName]
+Service=systemd-localed.service
diff --git a/units/org.freedesktop.login1.busname b/units/org.freedesktop.login1.busname
new file mode 100644
index 000000000..f3b52ed72
--- /dev/null
+++ b/units/org.freedesktop.login1.busname
@@ -0,0 +1,15 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Login Service Bus Name
+Documentation=man:systemd-logind.service(8) man:logind.conf(5)
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/logind
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/multiseat
+
+[BusName]
+Service=systemd-logind.service
diff --git a/units/org.freedesktop.machine1.busname b/units/org.freedesktop.machine1.busname
new file mode 100644
index 000000000..e6b83025a
--- /dev/null
+++ b/units/org.freedesktop.machine1.busname
@@ -0,0 +1,14 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Virtual Machine and Container Registration Service Bus Name
+Documentation=man:systemd-machined.service(8)
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/machined
+
+[BusName]
+Service=systemd-machined.service
diff --git a/units/org.freedesktop.timedate1.busname b/units/org.freedesktop.timedate1.busname
new file mode 100644
index 000000000..ee50e3df1
--- /dev/null
+++ b/units/org.freedesktop.timedate1.busname
@@ -0,0 +1,14 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Time & Date Service Bus Name
+Documentation=man:systemd-timedated.service(8) man:localtime(5)
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/timedated
+
+[BusName]
+Service=systemd-timedated.service