summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2013-03-04 23:20:16 +0100
committerMichael Biebl <biebl@debian.org>2013-03-04 23:23:06 +0100
commitd51167c6268d11f02c2676693a8e9dc1b628cdbb (patch)
tree88436f2b2f06cd7c8323402d9f6bc8de7cc67d99
parent135b5212d4234f5b75c9b86c9f924047c8d07589 (diff)
build-sys: build and install systemd-coredumpctl conditionally
If coredump support is disabled via --disable-coredump, do not build and install the systemd-coredumpctl binary and man page.
-rw-r--r--Makefile-man.am9
-rw-r--r--Makefile.am22
-rw-r--r--man/systemd-coredumpctl.xml2
3 files changed, 22 insertions, 11 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index e095c3e76..8d48ee05e 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -50,7 +50,6 @@ MANPAGES += \
man/systemd-cat.1 \
man/systemd-cgls.1 \
man/systemd-cgtop.1 \
- man/systemd-coredumpctl.1 \
man/systemd-delta.1 \
man/systemd-detect-virt.1 \
man/systemd-fsck@.service.8 \
@@ -303,6 +302,14 @@ MANPAGES_ALIAS += \
endif
+if ENABLE_COREDUMP
+MANPAGES += \
+ man/systemd-coredumpctl.1
+MANPAGES_ALIAS += \
+ #
+
+endif
+
if ENABLE_HOSTNAMED
MANPAGES += \
man/hostnamectl.1 \
diff --git a/Makefile.am b/Makefile.am
index e23a6b448..3d3f2652f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -318,7 +318,6 @@ systemd_analyze_LDADD = \
dist_bashcompletion_DATA = \
shell-completion/bash/journalctl \
shell-completion/bash/systemctl \
- shell-completion/bash/systemd-coredumpctl \
shell-completion/bash/udevadm
dist_tmpfiles_DATA = \
@@ -2376,13 +2375,6 @@ journalctl_LDADD += \
$(QRENCODE_LIBS)
endif
-systemd_coredumpctl_SOURCES = \
- src/journal/coredumpctl.c
-
-systemd_coredumpctl_LDADD = \
- libsystemd-shared.la \
- libsystemd-journal.la
-
test_journal_SOURCES = \
src/journal/test-journal.c
@@ -2627,7 +2619,6 @@ rootbin_PROGRAMS += \
journalctl
bin_PROGRAMS += \
- systemd-coredumpctl \
systemd-cat
dist_systemunit_DATA += \
@@ -2719,6 +2710,19 @@ endif
rootlibexec_PROGRAMS += \
systemd-coredump
+systemd_coredumpctl_SOURCES = \
+ src/journal/coredumpctl.c
+
+systemd_coredumpctl_LDADD = \
+ libsystemd-shared.la \
+ libsystemd-journal.la
+
+bin_PROGRAMS += \
+ systemd-coredumpctl
+
+dist_bashcompletion_DATA += \
+ shell-completion/bash/systemd-coredumpctl
+
sysctl_DATA = \
sysctl.d/coredump.conf
diff --git a/man/systemd-coredumpctl.xml b/man/systemd-coredumpctl.xml
index ce40404da..02b688606 100644
--- a/man/systemd-coredumpctl.xml
+++ b/man/systemd-coredumpctl.xml
@@ -21,7 +21,7 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="systemd-coredumpctl">
+<refentry id="systemd-coredumpctl" conditional='ENABLE_COREDUMP'>
<refentryinfo>
<title>systemd-coredumpctl</title>