summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-12-19 01:48:05 +0100
committerLennart Poettering <lennart@poettering.net>2014-12-19 02:07:42 +0100
commitdca59f62666c2d37d1a68ed332ba7985c1141f82 (patch)
tree0a9620113533d344a2c77ea11b417c6da16ff258
parente02d225b1eaead537243293a9c02f6baa8aaf55d (diff)
util: add generalization of verb parsing for command line tools
We should move loginctl, timedatectl, machinectl over to use this new API instead of a manual one.
-rw-r--r--Makefile.am4
-rw-r--r--src/shared/verbs.c77
-rw-r--r--src/shared/verbs.h34
3 files changed, 114 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c9c5e304..5a41ba647 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -895,7 +895,9 @@ libsystemd_shared_la_SOURCES = \
src/shared/uid-range.h \
src/shared/nss-util.h \
src/shared/btrfs-util.c \
- src/shared/btrfs-util.h
+ src/shared/btrfs-util.h \
+ src/shared/verbs.c \
+ src/shared/verbs.h
if HAVE_UTMP
libsystemd_shared_la_SOURCES += \
diff --git a/src/shared/verbs.c b/src/shared/verbs.c
new file mode 100644
index 000000000..ead2ff60f
--- /dev/null
+++ b/src/shared/verbs.c
@@ -0,0 +1,77 @@
+/*-*- Mode: C; c-basic-offset: 8; indent-tabs-mode: nil -*-*/
+
+/***
+ This file is part of systemd.
+
+ Copyright 2014 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#include "util.h"
+#include "verbs.h"
+
+int dispatch_verb(int argc, char *argv[], const Verb verbs[], void *userdata) {
+ const Verb *verb;
+ const char *name;
+ unsigned i;
+ int left;
+
+ assert(verbs);
+ assert(verbs[0].dispatch);
+ assert(argc >= 0);
+ assert(argv);
+ assert(argc >= optind);
+
+ left = argc - optind;
+ name = argv[optind];
+
+ for (i = 0;; i++) {
+ bool found;
+
+ /* At the end of the list? */
+ if (!verbs[i].dispatch) {
+ if (name)
+ log_error("Unknown operation %s.", name);
+ else
+ log_error("Requires operation parameter.");
+ return -EINVAL;
+ }
+
+
+ if (!name)
+ found = !!(verbs[i].flags & VERB_DEFAULT);
+ else
+ found = streq(name, verbs[i].verb);
+
+ if (found) {
+ verb = &verbs[i];
+ break;
+ }
+ }
+
+ if (verb->min_args != VERB_ANY &&
+ (unsigned) left < verb->min_args) {
+ log_error("Too few arguments.");
+ return -EINVAL;
+ }
+
+ if (verb->max_args != VERB_ANY &&
+ (unsigned) left > verb->max_args) {
+ log_error("Too many argument.s");
+ return -EINVAL;
+ }
+
+ return verb->dispatch(left, argv + optind, userdata);
+}
diff --git a/src/shared/verbs.h b/src/shared/verbs.h
new file mode 100644
index 000000000..d59e4d59b
--- /dev/null
+++ b/src/shared/verbs.h
@@ -0,0 +1,34 @@
+/*-*- Mode: C; c-basic-offset: 8; indent-tabs-mode: nil -*-*/
+
+#pragma once
+
+/***
+ This file is part of systemd.
+
+ Copyright 2014 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#define VERB_ANY ((unsigned) -1)
+#define VERB_DEFAULT 1
+
+typedef struct {
+ const char *verb;
+ unsigned min_args, max_args;
+ unsigned flags;
+ int (* const dispatch)(int argc, char *argv[], void *userdata);
+} Verb;
+
+int dispatch_verb(int argc, char *argv[], const Verb verbs[], void *userdata);