summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-04-19 00:41:24 +0200
committerLennart Poettering <lennart@poettering.net>2013-04-19 00:41:24 +0200
commitef3b5246879094e29cc99c4d24cbfeb19b7da49b (patch)
treeab322836a724b0c5867edc33ee22dcb39cd40777
parenta3e6f050de81a9830e52af09d5d38dad9a356e3b (diff)
build-sys: prepare release 202
-rw-r--r--Makefile.am14
-rw-r--r--NEWS60
-rw-r--r--TODO3
-rw-r--r--configure.ac2
4 files changed, 71 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index a9f72c1e1..d594a3d93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,28 +32,28 @@ SUBDIRS = . po
.SECONDARY:
LIBUDEV_CURRENT=4
-LIBUDEV_REVISION=2
+LIBUDEV_REVISION=3
LIBUDEV_AGE=3
LIBGUDEV_CURRENT=1
LIBGUDEV_REVISION=3
LIBGUDEV_AGE=1
-LIBSYSTEMD_LOGIN_CURRENT=5
+LIBSYSTEMD_LOGIN_CURRENT=6
LIBSYSTEMD_LOGIN_REVISION=0
-LIBSYSTEMD_LOGIN_AGE=5
+LIBSYSTEMD_LOGIN_AGE=6
LIBSYSTEMD_DAEMON_CURRENT=0
-LIBSYSTEMD_DAEMON_REVISION=9
+LIBSYSTEMD_DAEMON_REVISION=10
LIBSYSTEMD_DAEMON_AGE=0
LIBSYSTEMD_ID128_CURRENT=0
-LIBSYSTEMD_ID128_REVISION=20
+LIBSYSTEMD_ID128_REVISION=21
LIBSYSTEMD_ID128_AGE=0
-LIBSYSTEMD_JOURNAL_CURRENT=9
+LIBSYSTEMD_JOURNAL_CURRENT=10
LIBSYSTEMD_JOURNAL_REVISION=0
-LIBSYSTEMD_JOURNAL_AGE=9
+LIBSYSTEMD_JOURNAL_AGE=10
# Dirs of external packages
dbuspolicydir=@dbuspolicydir@
diff --git a/NEWS b/NEWS
index 9ea3eee77..e8b7b392c 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,65 @@
systemd System and Service Manager
+CHANGES WITH 202:
+
+ * The output of 'systemctl list-jobs' got some polishing. The
+ '--type=' argument may now be passed more than once. A new
+ command 'systemctl list-sockets' has been added which shows
+ a list of kernel sockets systemd is listening on with the
+ socket units they belong to, plus the units these socket
+ units activate.
+
+ * The experimental libsystemd-bus library got substantial
+ updates to work in conjunction with the (also experimental)
+ kdbus kernel project. It works well enough to exchange
+ messages with some sophistication. Note that kdbus is not
+ ready yet, and the library is mostly an elaborate test case
+ for now, and not installable.
+
+ * systemd gained a new unit 'systemd-static-nodes.service'
+ that generates static device nodes earlier during boot, and
+ can run in conjunction with udev.
+
+ * libsystemd-login gained a new call sd_pid_get_user_unit()
+ to retrieve the user systemd unit a process is running
+ in. This is useful for systems where systemd is used as
+ session manager.
+
+ * systemd-nspawn now places all containers in the new /machine
+ top-level cgroup directory in the name=systemd
+ hierarchy. libvirt will soon do the same, so that we get a
+ uniform separation of /system, /user and /machine for system
+ services, user processes and containers/virtual
+ machines. This new cgroup hierarchy is also useful to stick
+ stable names to specific container instances, which can be
+ recognized later on this way (this name may be controlled
+ via systemd-nspawn's new -M switch). libsystemd-login also
+ gained a new call sd_pid_get_machine_name() to retrieve the
+ name of the container/VM a specific process belongs to.
+
+ * bootchart can now store its data in the journal.
+
+ * libsystemd-journal gained a new call
+ sd_journal_add_conjunction() for AND expressions to the
+ matching logic. This can be used to express more complex
+ logical expressions.
+
+ * journactl can now take multiple --unit= and --user-unit=
+ switches.
+
+ * The cryptsetup logic now understands the "luks.key=" kernel
+ command line switch for specifying a file to read the
+ decryption key from. Also, if a configured keyfile is now
+ found the tool will now automatically fall back to prompting
+ the user.
+
+ Contributions from: Anatol Pomozov, Auke Kok, Harald Hoyer,
+ Henrik Grindal Bakken, Josh Triplett, Kay Sievers, Lennart
+ Poettering, Lukas Nykryn, Mantas MikulÄ—nas Marius Vollmer,
+ Martin Jansa, Martin Pitt, Michael Biebl, Michal Schmidt,
+ Mirco Tischler, Pali Rohar, Simon Peeters, Steven Hiscocks,
+ Tom Gundersen, Zbigniew Jędrzejewski-Szmek
+
CHANGES WITH 201:
* journalctl --update-catalog now understands a new --root=
diff --git a/TODO b/TODO
index cd66914b5..7f42dedf1 100644
--- a/TODO
+++ b/TODO
@@ -32,6 +32,9 @@ Fedora 19:
Features:
+* see if we can fix https://bugs.freedesktop.org/show_bug.cgi?id=63672
+ without dropping the location cache entirely.
+
* truncate whitespace of var names the same way as values in parse_env_file_internal()
* dbus: when a unit failed to load (i.e. is in UNIT_ERROR state), we
diff --git a/configure.ac b/configure.ac
index aec85ea61..517378394 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@
AC_PREREQ([2.64])
AC_INIT([systemd],
- [201],
+ [202],
[http://bugs.freedesktop.org/enter_bug.cgi?product=systemd],
[systemd],
[http://www.freedesktop.org/wiki/Software/systemd])