summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-08-15 12:54:54 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-08-15 12:59:36 -0400
commitf5853dafa1b3486f3ac77fccee3cbf377baa8d95 (patch)
tree58a2171a045fff18a861c350a5e7cda0c4052d78
parent31f49d022aee9bbb356e52e5483f182d7ffa8d2f (diff)
build-sys: add clean-python target
Building for a different version of Python requires removing all build products for the old version. There's no nice way to do it, short of doing 'make clean'. The new 'clean-python' target is a bit hacky, but seems to work: ./configure PYTHON=python2 && make && make install make clean-python ./configure PYTHON=python3 --disable-gtk-doc --disable-man-pages && make && make install should install modules for both versions of Python.
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d3599386..fdfdd6515 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4136,6 +4136,11 @@ CLEAN_LOCAL_HOOKS += clean-sphinx
clean-sphinx:
-rm -rf docs/html/python-systemd/
+# Remove Python stuff, e.g. to force rebuilding for a different Python version.
+clean-python:
+ -rm -rf src/python-systemd/.libs src/python-systemd/*.l[ao]
+ -rm -f _daemon.la id128.la _journal.la login.la _reader.la
+
# ------------------------------------------------------------------------------
substitutions = \
'|rootlibexecdir=$(rootlibexecdir)|' \