summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-11-07 17:51:09 +0100
committerLennart Poettering <lennart@poettering.net>2013-11-07 17:51:09 +0100
commitfa57130d35dd8fd8c3f2f2126dd7fc6930a08e35 (patch)
tree139a8db9922a2d484e2a6b8e78760481bd06783c
parenta27e222b58824c08fa0da18106cf28a02b6c5e23 (diff)
man: add docs for sd_is_special() and some man page symlinks
-rw-r--r--Makefile-man.am17
-rw-r--r--Makefile.am2
-rw-r--r--man/sd_is_fifo.xml17
-rw-r--r--man/sd_seat_get_active.xml2
4 files changed, 36 insertions, 2 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 54798450f..0939bc528 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -66,9 +66,9 @@ MANPAGES += \
man/systemd-nspawn.1 \
man/systemd-remount-fs.service.8 \
man/systemd-run.1 \
- man/systemd-socket-proxyd.1 \
man/systemd-shutdownd.service.8 \
man/systemd-sleep.conf.5 \
+ man/systemd-socket-proxyd.1 \
man/systemd-suspend.service.8 \
man/systemd-sysctl.service.8 \
man/systemd-system-update-generator.8 \
@@ -139,6 +139,7 @@ MANPAGES_ALIAS += \
man/sd_is_socket.3 \
man/sd_is_socket_inet.3 \
man/sd_is_socket_unix.3 \
+ man/sd_is_special.3 \
man/sd_journal.3 \
man/sd_journal_add_conjunction.3 \
man/sd_journal_add_disjunction.3 \
@@ -239,6 +240,7 @@ man/sd_is_mq.3: man/sd_is_fifo.3
man/sd_is_socket.3: man/sd_is_fifo.3
man/sd_is_socket_inet.3: man/sd_is_fifo.3
man/sd_is_socket_unix.3: man/sd_is_fifo.3
+man/sd_is_special.3: man/sd_is_fifo.3
man/sd_journal.3: man/sd_journal_open.3
man/sd_journal_add_conjunction.3: man/sd_journal_add_match.3
man/sd_journal_add_disjunction.3: man/sd_journal_add_match.3
@@ -411,6 +413,9 @@ man/sd_is_socket_inet.html: man/sd_is_fifo.html
man/sd_is_socket_unix.html: man/sd_is_fifo.html
$(html-alias)
+man/sd_is_special.html: man/sd_is_fifo.html
+ $(html-alias)
+
man/sd_journal.html: man/sd_journal_open.html
$(html-alias)
@@ -856,7 +861,9 @@ MANPAGES_ALIAS += \
man/sd_pid_get_slice.3 \
man/sd_pid_get_unit.3 \
man/sd_pid_get_user_unit.3 \
+ man/sd_seat_can_graphical.3 \
man/sd_seat_can_multi_session.3 \
+ man/sd_seat_can_tty.3 \
man/sd_seat_get_sessions.3 \
man/sd_session_get_class.3 \
man/sd_session_get_display.3 \
@@ -885,7 +892,9 @@ man/sd_pid_get_owner_uid.3: man/sd_pid_get_session.3
man/sd_pid_get_slice.3: man/sd_pid_get_session.3
man/sd_pid_get_unit.3: man/sd_pid_get_session.3
man/sd_pid_get_user_unit.3: man/sd_pid_get_session.3
+man/sd_seat_can_graphical.3: man/sd_seat_get_active.3
man/sd_seat_can_multi_session.3: man/sd_seat_get_active.3
+man/sd_seat_can_tty.3: man/sd_seat_get_active.3
man/sd_seat_get_sessions.3: man/sd_seat_get_active.3
man/sd_session_get_class.3: man/sd_session_is_active.3
man/sd_session_get_display.3: man/sd_session_is_active.3
@@ -942,9 +951,15 @@ man/sd_pid_get_unit.html: man/sd_pid_get_session.html
man/sd_pid_get_user_unit.html: man/sd_pid_get_session.html
$(html-alias)
+man/sd_seat_can_graphical.html: man/sd_seat_get_active.html
+ $(html-alias)
+
man/sd_seat_can_multi_session.html: man/sd_seat_get_active.html
$(html-alias)
+man/sd_seat_can_tty.html: man/sd_seat_get_active.html
+ $(html-alias)
+
man/sd_seat_get_sessions.html: man/sd_seat_get_active.html
$(html-alias)
diff --git a/Makefile.am b/Makefile.am
index 86baae0e7..df552e3a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4576,7 +4576,7 @@ valgrind-tests: $(TESTS)
[ "$$f" == "$${f/.pl/}" ] && libtool --mode=execute valgrind --leak-check=full --error-exitcode=55 $(builddir)/$$f ; \
done
-check-api-docs: $(lib_LTLIBRARIES)
+check-api-docs: $(lib_LTLIBRARIES) man
for symbol in `for f in $(lib_LTLIBRARIES) ; do nm -g --defined-only $(builddir)/.libs/"$${f/.la/.so}" 2>&1 /dev/null | grep " T " | cut -d" " -f3 ; done` ; do \
if test -f $(builddir)/man/$$symbol.html ; then \
echo " Symbol $$symbol() is documented." ; \
diff --git a/man/sd_is_fifo.xml b/man/sd_is_fifo.xml
index 2bc860c37..4d9cd7960 100644
--- a/man/sd_is_fifo.xml
+++ b/man/sd_is_fifo.xml
@@ -48,6 +48,7 @@
<refname>sd_is_socket_inet</refname>
<refname>sd_is_socket_unix</refname>
<refname>sd_is_mq</refname>
+ <refname>sd_is_special</refname>
<refpurpose>Check the type of a file descriptor</refpurpose>
</refnamediv>
@@ -93,6 +94,12 @@
<paramdef>const char *<parameter>path</parameter></paramdef>
</funcprototype>
+ <funcprototype>
+ <funcdef>int <function>sd_is_special</function></funcdef>
+ <paramdef>int <parameter>fd</parameter></paramdef>
+ <paramdef>const char *<parameter>path</parameter></paramdef>
+ </funcprototype>
+
</funcsynopsis>
</refsynopsisdiv>
@@ -153,6 +160,16 @@
<parameter>path</parameter> parameter is not
<constant>NULL</constant>, it is checked whether the
message queue is bound to the specified name.</para>
+
+ <para><function>sd_is_special()</function> may be
+ called to check whether the specified file descriptor
+ refers to a special file. If the
+ <parameter>path</parameter> parameter is not
+ <constant>NULL</constant>, it is checked whether file
+ descriptor is bound to the specified file
+ name. Special files in this context are character
+ device nodes and files in <filename>/proc</filename>
+ or <filename>/sys</filename>.</para>
</refsect1>
<refsect1>
diff --git a/man/sd_seat_get_active.xml b/man/sd_seat_get_active.xml
index 1610d3efe..cd8769698 100644
--- a/man/sd_seat_get_active.xml
+++ b/man/sd_seat_get_active.xml
@@ -46,6 +46,8 @@
<refname>sd_seat_get_active</refname>
<refname>sd_seat_get_sessions</refname>
<refname>sd_seat_can_multi_session</refname>
+ <refname>sd_seat_can_tty</refname>
+ <refname>sd_seat_can_graphical</refname>
<refpurpose>Determine state of a specific seat</refpurpose>
</refnamediv>