summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2015-01-28 14:05:01 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2015-01-29 13:06:04 +1000
commit001a247324b44c0e0b8fdba41a6fc66e7465b8b6 (patch)
tree03259f0ea25736b4af378b1610f52d7a3e0eb355 /Makefile.am
parent3e495a6651609d0a45b62aab5c3ed5a3b40e11ab (diff)
hwdb: add a touchpad hwdb
Currently used to tag devices in the new Lenovo *50 series and the X1 Carbon 3rd. These laptops re-introduced the physical trackpoint buttons that were missing from the *40 series but those buttons are now wired up to the touchpad. The touchpad now sends BTN_0, BTN_1 and BTN_2 for the trackpoint. The same button codes were used in older touchpads that had dedicated scroll up/down buttons. Input drivers need to work around this and thus know what they're dealing with. For the previous gen we introduced INPUT_PROP_TOPBUTTONPAD in the kernel, but the resulting mess showed that these per-device quirks should really live in userspace. The list currently includes the X1 Carbon 3rd PNPID, others will be added as get to know which PNPID they have.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 80c41615e..e3ba11c8c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3560,6 +3560,7 @@ dist_udevrules_DATA += \
rules/60-persistent-storage.rules \
rules/64-btrfs.rules \
rules/70-mouse.rules \
+ rules/70-touchpad.rules \
rules/75-net-description.rules \
rules/75-tty-description.rules \
rules/78-sound-card.rules \
@@ -3751,7 +3752,8 @@ dist_udevhwdb_DATA = \
hwdb/20-OUI.hwdb \
hwdb/20-net-ifname.hwdb \
hwdb/60-keyboard.hwdb \
- hwdb/70-mouse.hwdb
+ hwdb/70-mouse.hwdb \
+ hwdb/70-touchpad.hwdb
EXTRA_DIST += \
units/systemd-hwdb-update.service.in