summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2015-02-08 17:18:30 +0100
committerKay Sievers <kay@vrfy.org>2015-02-17 14:36:59 +0100
commit0974a682d155a5874123ba7de9c1e314c6681e0f (patch)
tree51f29d68e54371b323de64a9ede67fa4ea54fdb6 /Makefile.am
parent0fa2cac4f0cdefaf1addd7f1fe0fd8113db9360b (diff)
bootctl: add sd-boot support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 12 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d739445e8..5a17642f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2479,15 +2479,21 @@ systemd_efi_boot_generator_LDADD = \
# ------------------------------------------------------------------------------
bootctl_SOURCES = \
- src/boot/boot.h \
- src/boot/boot-loader.h \
- src/boot/bootctl.c \
- src/boot/boot-loader.c \
- src/boot/boot-efi.c
+ src/boot/bootctl.c
+
+bootctl_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DEFI_MACHINE_TYPE_NAME=\"$(EFI_MACHINE_TYPE_NAME)\" \
+ -DSD_BOOTLIBDIR=\"$(sd_bootlibdir)\"
+
+bootctl_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(BLKID_CFLAGS)
bootctl_LDADD = \
libsystemd-shared.la \
- libsystemd-internal.la
+ libsystemd-internal.la \
+ $(BLKID_LIBS)
bin_PROGRAMS += \
bootctl