summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Marineau <michael.marineau@coreos.com>2014-06-19 19:07:05 -0700
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-20 00:10:47 -0400
commit09e00c524fd4d21a3508c27d01d265b8a6c9ae30 (patch)
tree00dec5230c3fc4b922120d31852bfed86d19f101 /Makefile.am
parentcba2ef02722114da2b730d57f1e3bb43013d8921 (diff)
test: ensure conf_files_list returns absolute paths
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fd3205d5e..bd26780a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1243,7 +1243,8 @@ tests += \
test-xml \
test-architecture \
test-socket-util \
- test-fdset
+ test-fdset \
+ test-conf-files
EXTRA_DIST += \
test/sched_idle_bad.service \
@@ -1600,6 +1601,12 @@ test_sched_prio_LDADD = \
libsystemd-core.la \
$(RT_LIBS)
+test_conf_files_SOURCES = \
+ src/test/test-conf-files.c
+
+test_conf_files_LDADD = \
+ libsystemd-shared.la
+
# ------------------------------------------------------------------------------
## .PHONY so it always rebuilds it
.PHONY: coverage lcov-run lcov-report coverage-sync