summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-01-26 19:12:56 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-01-26 23:56:34 -0500
commit10bc4cd469fc677892b07748ec85804ca120825f (patch)
tree662c8f72ce1bb03c0be25e6469e357fd183b254f /Makefile.am
parent4a84f3e61434cdc52f91477d7fd937600159e4f1 (diff)
build-sys: unbundle unifont
We should prefer the unifont.hex file from the system, instead of our own. Upstream has made a few releases since our version was included, and we should follow upstream changes. But adding 2.6MB to our source repo every time upstream releases is not nice.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index c463f2353..f42f13255 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3326,7 +3326,7 @@ noinst_PROGRAMS += \
systemd-subterm
dist_pkgdata_DATA += \
- src/libsystemd-terminal/unifont-glyph-array.bin
+ src/libsystemd-terminal/unifont-glyph-array.bin
nodist_userunit_DATA += \
units/user/systemd-consoled.service
@@ -3454,12 +3454,8 @@ test_unifont_LDADD = \
libsystemd-internal.la \
libsystemd-shared.la
-.PHONY: update-unifont
-update-unifont: tools/compile-unifont.py
- $(AM_V_GEN)$(PYTHON) $< \
- <$(top_srcdir)/src/libsystemd-terminal/unifont.hex \
- >$(top_srcdir)/src/libsystemd-terminal/unifont-glyph-array.bin
- @echo "unifont-glyph-array.bin has been regenerated"
+src/libsystemd-terminal/unifont-glyph-array.bin: tools/compile-unifont.py $(UNIFONT)
+ $(AM_V_GEN)$(PYTHON) $< <$(UNIFONT) >$@
# ------------------------------------------------------------------------------
if ENABLE_GTK_DOC