summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2015-02-24 17:23:53 +0100
committerLennart Poettering <lennart@poettering.net>2015-02-24 17:27:53 +0100
commit113b3fc1a8061f4a24dd0db74e9a3cd0083b2251 (patch)
tree603c98f39bdc563151446157e37400505f2b94ff /Makefile.am
parent15e80c7b75c3a3188bfaaa0baddccf31ae661a7a (diff)
importd: create a loopback btrfs file system for /var/lib/machines, if necessary
When manipulating container and VM images we need efficient and atomic directory snapshots and file copies, as well as disk quota. btrfs provides this, legacy file systems do not. Hence, implicitly create a loopback file system in /var/lib/machines.raw and mount it to /var/lib/machines, if that directory is not on btrfs anyway. This is done implicitly and transparently the first time the user invokes "machinectl import-xyz". This allows us to take benefit of btrfs features for container management without actually having the rest of the system use btrfs. The loopback is sized 500M initially. Patches to grow it dynamically are to follow.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f01668c3..93c050985 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -499,6 +499,7 @@ dist_systemunit_DATA = \
units/sys-kernel-debug.mount \
units/sys-fs-fuse-connections.mount \
units/tmp.mount \
+ units/var-lib-machines.mount \
units/printer.target \
units/sound.target \
units/bluetooth.target \
@@ -6586,7 +6587,8 @@ SYSINIT_TARGET_WANTS += \
LOCAL_FS_TARGET_WANTS += \
systemd-remount-fs.service \
- tmp.mount
+ tmp.mount \
+ var-lib-machines.mount
MULTI_USER_TARGET_WANTS += \
getty.target \