summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-09-01 11:30:38 +0200
committerAndy Wingo <wingo@pobox.com>2015-09-01 11:30:38 +0200
commit1716aac43107fcd96cd9105d44a2f8a02d307447 (patch)
tree0ce94aea0029e38e16a9e486e4ee21f824eb9775 /Makefile.am
parent488fb26bc81e9a41c048e94be484676e968018d5 (diff)
PKTTYAGENT make variable
* Makefile.am (PKTTYAGENT): Define as a variable so that users can make PKTTYAGENT=/whatever to select a specific pkttyagent path.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 84e15e9e5..710eb7c98 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,8 @@ systemshutdowndir=$(pkglibexecdir)/shutdown.d
udevrulesdir=@udevrulesdir@
udevbindir=@udevbindir@
+PKTTYAGENT=$(bindir)/pkttyagent
+
# Our own, non-special dirs
pkgsysconfdir=$(sysconfdir)/elogind
pkgincludedir=$(includedir)/elogind
@@ -115,12 +117,10 @@ CLEANFILES = $(BUILT_SOURCES) \
$(INSTALL_DATA_HOOKS) $(UNINSTALL_DATA_HOOKS) \
$(DISTCLEAN_LOCAL_HOOKS) $(CLEAN_LOCAL_HOOKS)
-# FIXME a different pkttyagent path...
-
AM_CPPFLAGS = \
-include $(top_builddir)/config.h \
-DPKGSYSCONFDIR=\"$(pkgsysconfdir)\" \
- -DPOLKIT_AGENT_BINARY_PATH=\"$(bindir)/pkttyagent\" \
+ -DPOLKIT_AGENT_BINARY_PATH=\"$(PKTTYAGENT)\" \
-DSYSTEM_CONFIG_UNIT_PATH=\"$(pkgsysconfdir)/system\" \
-DSYSTEM_DATA_UNIT_PATH=\"$(systemunitdir)\" \
-DUSER_CONFIG_UNIT_PATH=\"$(pkgsysconfdir)/user\" \