summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-07-17 15:03:10 +0200
committerSven Eden <yamakuzure@gmx.net>2017-07-17 17:58:43 +0200
commit1981059eaccd58a641074a7c78c0dcec52eabfb2 (patch)
tree58a7298d7f59dcd1620f0e0dda8c632390616e5b /Makefile.am
parent8663dfee3cb8d22899105729180d446cb48cfc5c (diff)
Prep v233: Add missing files from upstream and rename formats-util.[hc]
Some functionality has been exported to the following files: - src/basic/env-util.[hc] - src/basic/exec-util.[hc] - src/shared/nsflags.[hc] The content of these files is now needed in elogind, and the files have been added as-is. Cleanup is done later. Further the header src/basic/formats-util.h has been renamed to src/basic/format-util.h
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 011740149..9340eaf98 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,6 +133,7 @@ AM_CPPFLAGS = \
-DPKGSYSCONFDIR=\"$(pkgsysconfdir)\" \
-DSYSTEMD_CGROUP_CONTROLLER=\"_$(CGROUP_CONTROLLER)\" \
-DSYSTEMD_CGROUP_CONTROLLER_LEGACY=\"name=$(CGROUP_CONTROLLER)\" \
+ -DSYSTEMD_CGROUP_CONTROLLER_HYBRID=\"name=$(CGROUP_CONTROLLER)\" \
-DSYSTEMD_CGROUP_AGENT_PATH=\"$(rootlibexecdir)/elogind-cgroups-agent\" \
-DUDEVLIBEXECDIR=\"$(udevlibexecdir)\" \
-DPOLKIT_AGENT_BINARY_PATH=\"$(PKTTYAGENT)\" \
@@ -363,10 +364,14 @@ libbasic_la_SOURCES = \
src/basic/prioq.h \
src/basic/strv.c \
src/basic/strv.h \
+ src/basic/env-util.c \
+ src/basic/env-util.h \
src/basic/log.c \
src/basic/log.h \
src/basic/bus-label.c \
src/basic/bus-label.h \
+ src/basic/exec-util.c \
+ src/basic/exec-util.h \
src/basic/virt.c \
src/basic/virt.h \
src/basic/smack-util.c \
@@ -411,7 +416,10 @@ libbasic_la_SOURCES = \
src/basic/copy.c \
src/basic/copy.h \
src/basic/alloc-util.h \
- src/basic/alloc-util.c
+ src/basic/alloc-util.c \
+ src/basic/format-util.h \
+ src/basic/khash.h \
+ src/basic/khash.c
nodist_libbasic_la_SOURCES = \
src/basic/errno-from-name.h \
@@ -450,7 +458,9 @@ libshared_la_SOURCES = \
src/shared/sleep-config.c \
src/shared/sleep-config.h \
src/shared/spawn-polkit-agent.c \
- src/shared/spawn-polkit-agent.h
+ src/shared/spawn-polkit-agent.h \
+ src/shared/nsflags.h \
+ src/shared/nsflags.c
if HAVE_ACL
libshared_la_SOURCES += \