summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-20 02:05:28 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-20 02:05:28 +0200
commit1afaf57346eca958ffe9e1617bb875d556f89a01 (patch)
treeaaeb800e7d8add95d659c04474f2c5b4f7ea7933 /Makefile.am
parent9949ac0cec2aa0de4159260b2817e136825dbc3c (diff)
fedora: we must call the halt script with a symlink of reboot for rebooting
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b0aecd26..8f0fdaab2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -477,6 +477,8 @@ if TARGET_FEDORA
( cd $(DESTDIR)$(systemunitdir) && \
rm -f local.service && \
$(LN_S) rc-local.service local.service )
+ ( cd $(DESTDIR)/etc/init.d && \
+ $(LN_S) halt reboot > /dev/null 2>&1 || true )
endif
DISTCHECK_CONFIGURE_FLAGS = \