summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-07-02 03:47:23 +0200
committerLennart Poettering <lennart@poettering.net>2013-07-02 03:47:23 +0200
commit1ee306e1248866617c96ed9f4263f375588ad838 (patch)
treeebcb5678d4236ea8a8afc30c6164a4b4f51a03bd /Makefile.am
parent374ec6abf31ada6ca554cc8ea99b282373fac010 (diff)
machined: split out machine registration stuff from logind
Embedded folks don't need the machine registration stuff, hence it's nice to make this optional. Also, I'd expect that machinectl will grow additional commands quickly, for example to join existing containers and suchlike, hence it's better keeping that separate from loginctl.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am70
1 files changed, 65 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index e79756e30..02cd7e2d2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3569,6 +3569,70 @@ lib_LTLIBRARIES += \
endif
# ------------------------------------------------------------------------------
+if ENABLE_MACHINED
+systemd_machined_SOURCES = \
+ src/machine/machined.c \
+ src/machine/machined.h \
+ src/machine/machined-dbus.c \
+ src/machine/machine.c \
+ src/machine/machine.h \
+ src/machine/machine-dbus.c
+
+systemd_machined_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(DBUS_CFLAGS)
+
+systemd_machined_LDADD = \
+ libsystemd-label.la \
+ libsystemd-audit.la \
+ libsystemd-shared.la \
+ libsystemd-daemon.la \
+ libsystemd-dbus.la \
+ libsystemd-id128-internal.la \
+ libudev.la
+
+rootlibexec_PROGRAMS += \
+ systemd-machined
+
+machinectl_SOURCES = \
+ src/machine/machinectl.c
+
+machinectl_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(DBUS_CFLAGS)
+
+machinectl_LDADD = \
+ libsystemd-shared.la \
+ libsystemd-dbus.la \
+ libudev.la
+
+rootbin_PROGRAMS += \
+ machinectl
+
+nodist_systemunit_DATA += \
+ units/systemd-machined.service
+
+dist_systemunit_DATA += \
+ units/machine.slice
+
+dist_dbussystemservice_DATA += \
+ src/machine/org.freedesktop.machine1.service
+
+dist_dbuspolicy_DATA += \
+ src/machine/org.freedesktop.machine1.conf
+
+SYSTEM_UNIT_ALIASES += \
+ systemd-machined.service dbus-org.freedesktop.machine1.service
+
+polkitpolicy_in_files += \
+ src/machine/org.freedesktop.machine1.policy.in
+
+EXTRA_DIST += \
+ units/systemd-machine.service.in
+
+endif
+
+# ------------------------------------------------------------------------------
if ENABLE_LOGIND
systemd_logind_SOURCES = \
src/login/logind.c \
@@ -3584,8 +3648,6 @@ systemd_logind_SOURCES = \
src/login/logind-seat.h \
src/login/logind-session.c \
src/login/logind-session.h \
- src/login/logind-machine.c \
- src/login/logind-machine.h \
src/login/logind-user.c \
src/login/logind-user.h \
src/login/logind-inhibit.c \
@@ -3593,7 +3655,6 @@ systemd_logind_SOURCES = \
src/login/logind-session-dbus.c \
src/login/logind-seat-dbus.c \
src/login/logind-user-dbus.c \
- src/login/logind-machine-dbus.c \
src/login/logind-acl.h
nodist_systemd_logind_SOURCES = \
@@ -3748,8 +3809,7 @@ nodist_systemunit_DATA += \
units/systemd-user-sessions.service
dist_systemunit_DATA += \
- units/user.slice \
- units/machine.slice
+ units/user.slice
dist_dbussystemservice_DATA += \
src/login/org.freedesktop.login1.service